Cannot set up Cox.net email in Mail -- iCloud account conflict?

Discussion in 'OS X El Capitan (10.11)' started by slobizman, Apr 28, 2016.

Tags:
  1. slobizman, Apr 28, 2016
    Last edited: Apr 29, 2016

    slobizman macrumors member

    Joined:
    Jun 16, 2008
    #1
    I'm pretty Mac-savvy but I'm having a heck of a time setting up Mail on a spanking brand new iMac for my brother-in-law today.

    When I set up the iMac for the first time today, I chose the option to sign into his existing iCloud account. No problems.

    Then, I wanted to set up his Cox.net email in Mail. And this is where I am stuck.

    I could describe the multitude of variations of the problems I've encountered trying to set this up, but it seems to me that it all boils down to one thing: the email address for the iCloud account and his Cox.net email address are the same.

    First, I tried adding a new account, as all the help pages I've seen tell me, but it won't let me because there is already an iCloud account with that email address. So then I figure that okay, it must want me to use that iCloud account for BOTH the iCloud and Mail. So, I went into the account and added the Cox incoming and outgoing mail server info.

    BUT...around the top right of the Mail screen it says "Login Failed." When I click that on, it tells me that my iCloud password is incorrect (it's not talking about the Cox password, but iCloud). So I enter the iCloud password in where it tells me to log into icloud again, and I'm in. But then every time I try to do anything in Mail, or click the "Login Failed" wording in Mail, then it wants me to log in once again to iCloud. I never logged OUT of iCloud, but it keeps wanting me to long in.

    It seems like everything I read on setting up email in Mail ignores the idea of already having an icloud account, and show you how to do it if there is no existing iCloud account.

    I'm pulling my hair out. Any help?

    P.S. This is an area on Macs that I am most unfamiliar because personally I use gmail and just access it from the browser -- never tried to set up an email account for Mail, nor do I use Mail.

    iMac, OS X El Capitan (10.11.4)
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    You should (and did you?) add a cox.net email account via System Preferences>Internet Accounts>Add Other Account..., which is at the bottom of the list of account types.
     
  3. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #3
    What BrianBaughn said.

    Add: my mother is a Cox customer with a Mac & Android tablet, and setting up devices for Cox can be wonky at times (they only started to truly support IMAP a couple of years ago, and their web-portal for e-mail is kinda like the equivalent of IE6). But big thing to make sure you do is in the field that has the user-id (?: not in front of my Mac right now, so, can't pull up the setup screen), need to specify "name@cox.net".
     
  4. slobizman thread starter macrumors member

    Joined:
    Jun 16, 2008
    #4
    When I attempt to add the account as you say, it tells me on the "Add a Mail account" panel that "This account already exists." It has to be referring to the iCloud Internet Account already set up (when I set up iMac yesterday, and which is used for iCloud).

    Maybe I have to update that account in some way. I tried many times last night, but I'll try again right now with a refresh reboot.
    --- Post Merged, Apr 29, 2016 ---
    Okay, I think I've had some (partial?) success. I had to go to the icloud Account and set up an icloud email address (even if I won't use it I guess). Then, I unchecked the Mail box off the iCloud Internet Account page. Then, I was finally able to add an Internet Account for Cox email, with just the Mail function selected. Please see the screenshots.

    It all seems to function now!

    Questions:

    1. Should I really have two accounts: iCloud (for all functions but email) and Cox (for just email)?

    2. When I set up the Cox Internet Account, it defaulted to checking Mail and Notes. I didn't understand why Notes should be selected, seems like and iCloud function, so I unchecked it. Should I add the checkmark it back?

    Screen Shot 2016-04-29 at 7.35.33 AM.png Screen Shot 2016-04-29 at 7.35.51 AM.png
     

    Attached Files:

  5. NoBoMac, Apr 29, 2016
    Last edited: Apr 29, 2016

    NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #5
    Is the iCloud e-mail account setup as the Cox account? That is probably the issue. The iCloud e-mail account is name@iCloud.com or name@me.com (though probably not @me, since if I recall correctly, those were discontinued a while back).

    Yes, the iCloud account will be tied to the Cox e-mail address, but the actual iCloud e-mail will be something different. In my case, I have a GMail account as primary, name@gmail.com. My iCloud account is tied to same. I have iCloud mail and GMail both setup on my Mail app, but my iCloud mail is setup as "name@icloud.com".

    Optional: turn off iCloud e-mail, delete that account if need be from Mail. Create Cox account. Then try to turn on iCloud mail.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    I think you already identified the issue here. So your AppleID/iCloud account name is say david1@cox.net and that is also the email account login for the Cox email account. It looks like the Mail app will not let you have two accounts on there with the same primary email address.

    Can you follow the instructions here to change the AppleID/iCloud email address to something else? Then logon to the iCloud account and Mail account with that new address. Then I'm thinking it will allow you to add the Cox email account.

    https://support.apple.com/en-us/HT202667
     
  7. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #7
    You don't need anything, really for iCloud. Nice to have turned on for things like Contacts, Calendar, etc. as a backup and access from some different computer.

    In your case, turn on other functions of iCloud, turn off iCloud mail? And yes, can turn off Notes for Cox since can get to those via Mac, iOS, and website when on different computer and iCloud turned on for Notes.
     
  8. slobizman thread starter macrumors member

    Joined:
    Jun 16, 2008
    #8
    Thanks to all who are helping me out (so quickly!); this is a great forum.

    So, since everything seems to be working correctly now, can I feel assured I have this set up right? (Leaving my non-techie brother-in-law's house in a couple days and what to make sure things are set right before I leave). Looking at the two screenshots I put up a few posts ago, does it seems like I've done this right and am good to go? His iphone and his new iMac are in sync, and no issues sending or receiving mail. His contacts are synced through iCloud and accessible in Mail. (But I know sometimes I can have things working, but maybe I really didn't set it up correctly. :) )

    Two other questions:

    1. So, with Mail unchecked in the iCloud account, I assume the mail will not be backed up to iCloud when it backs up. Is that right? And maybe that's how it's supposed to work (Again, I personally use gmail and don't use the Mail app so don't know).

    2. On his iphone, under Settings>iCloud, Mail is not turned on to green. Should it be? (Mail is functioning properly on iphone, so I guess this is about backup). I just set it to green to see what happens.

    THANKS SO MUCH
     
  9. Claudia P macrumors newbie

    Claudia P

    Joined:
    Apr 22, 2016
    #9
    I had a similar problem when I got my iMac. What I eventually had to do was to sign out of iCloud on the iMac completely and then setup the email account, after doing that I signed back into iCloud and all was well. :)
    This took about an hour to figure out with Apple Care help.
     
  10. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #10
    iCloud mail is totally separate from the Cox mail and not doing backup of other e-mail accounts. And if the Cox mail has been setup correctly, it should be IMAP by default, so, that e-mail is stored on Cox servers. So basically, backed up. Unless brother-in-law will be using his name@icloud.com account for something (eg. I use mine as a secondary e-mail address for recovery/alerts from other accounts, in case my GMail account gets compromised). Long story short, can keep iCloud mail unchecked.

    And if not using iCloud mail, can keep unchecked on the phone.

    And as for leaving in a couple of days, might want to look into installing on the Mac (and your computer), TeamViewer. Free, and makes for easy remote administration/fixing of computers. I have it installed on my computer and my mother's, and it has been a blessing to fix issues she has run into (or created). Easy to install and use vs. some other solutions (eg. Google Chrome Remote Desktop).
     
  11. slobizman thread starter macrumors member

    Joined:
    Jun 16, 2008
    #11
    Thanks. I will consider doing this. He just got scammed on his old Windows computer by one of those fake MS support remote help scammers, and out $800, so I'll have to convince my now paranoid (good!) brother in law that this is secure. LOL.
     

Share This Page