Resolved Can't delete photos from Watch

Discussion in 'Apple Watch' started by AJClayton, Apr 13, 2018.

  1. AJClayton macrumors 6502

    AJClayton

    Joined:
    Jan 9, 2007
    Location:
    Dorset, England
    #1
    I've got a strange problem with my Apple Watch Series 1 and can't see a way to resolve it, so would welcome any suggestions.

    Having recently taken up running, I've been trying to install the Nike+ Run Club app on my watch. It says that there's not enough space on the device.

    If I navigate (on my iPhone in the Watch app) to General -> About then it shows "Photos" as having 15,509 images.

    If I go to "Photos" settings, I have it set to "Custom" with a single synced album that has just 90 photos in it. For good measure, I've set the photo limit to 250 photos.

    I've tried re-booting the watch and tried adjusting settings (change synced folder, for example) in case this will force my watch to lose the seemingly massive number of images it tells me it's storing.

    Strangely, if I open the Photos app on my watch itself, it doesn't have 15,000 photos in it. I haven't counted, but it looks closer to the 90 odd although there are lots of duplicates.

    I don't use the Photos app for my images so I have Photo Stream turned off on all my devices. I also have "Photos" set to off for all settings in iCloud (Photo library, Photo Stream all off). (For the record, I use my Synology NAS for photos and videos).

    I've removed every app I can from my watch so I only have the native apps left (the ones that you can't remove even if you want to), however according to the Watch app on my iPhone I only have 273MB of the 5.5GB capacity on my watch free!?

    I've attached screen shots of the "General" and "Photos" settings screens.

    I'm totally baffled by this, so anything that anyone can suggest would be most welcome.

    IMG_9111.jpg IMG_9112.PNG
     
  2. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #2
    Probably this is a nice time to reset your watch to default and restore from backup. Don’t worry. The backup does not include the photo transferred to your watch. It will be synced back when you restore from backup.

    I had a reversed problem: could not sync enough photos to watch. I don’t use watch to browse my photo but I was curious to see how it works. I then set it to sync 500 images. It only synced somewhere between 237-270 images and it stopped at a random point forever. I fixed this problem by updating to watchOS 4.3 beta.
     
  3. AJClayton thread starter macrumors 6502

    AJClayton

    Joined:
    Jan 9, 2007
    Location:
    Dorset, England
    #3
    Thanks for the advice, Shirasaki. That's fixed the problem. Having performed a reset and restored from backup I now have 5GB free out of 5.5GB and have successfully installed the Nike+ Run Club app.

    I don't know if it's just me, but Apple software in general seems to be more buggy than a decade or so ago. Then again, I suppose it's much more complicated now so perhaps I'm being unkind.

    Thanks for your help.
     

Share This Page