Can't drag files in itunes

Discussion in 'Mac Apps and Mac App Store' started by BiggeeC, May 18, 2006.

  1. BiggeeC macrumors regular

    Jun 23, 2002
    Gaithersburg, MD
    hello all. just recently, as of 2 or 3 days ago, I suddenly cannot drag songs in itunes anymore. More specifically, I can't add songs to playlists, and I can't manage songs in the playlists. anyone else having this problem, or is this something new in itunes? (I should say that I haven't used itunes in a few weeks, and the only thing I've done is download the latest updates)

  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Is this on a Mac or a PC? Are they Smart Playlists? :)
  3. BiggeeC thread starter macrumors regular

    Jun 23, 2002
    Gaithersburg, MD
    it's a smart playlist. I just tried it on my desktop. Same result.
  4. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia

    Not quite sure what you mean here. :eek:

    Check that there's a folder called iTunes in your Music folder and that it has the right permissions by selecting it, and then using the Get Info function from the File menu in Finder. Check the two files and other folder inside this iTunes folder too. :)
  5. KeithinHawaii macrumors newbie

    Jan 21, 2008
    can't drag files in iTunes

    Chris, I too have the same problem, after just loading the newest version of iTunes. I hope this is an error which will be corrected.
    Keith in Hawaii
  6. jsowell macrumors newbie

    Jan 28, 2008
    Same problem

    I am suddenly having the same problem. After working fine 3 days ago when I last used it, today I can't drag files in iTunes.

    Music files in my library, and downloaded podcasts, can't be dragged onto a playlist or onto my iPod. Right-clicking to add the files to a playlist is also unsuccessful -- the arrow to the right of the play list option on the right-click menu (which would normally bring up a list of playlists available) is grayed out.

    Any ideas? I've tried reinstalling iTunes 7.6, and I've checked that I have read/write permissions for the Music files and folders.

  7. jsowell macrumors newbie

    Jan 28, 2008

    I was wrong about using the right-click menu to copy to a playlist.

    In fact, that menu option works, and even brings up the iPod as an option to copy to. So, I can copy songs and podcasts to my iPod or a playlist, but only with the right-click menu, not by dragging and dropping.

    I'm running Leopard 10.5.1 on a MacBook, and iTunes 7.6 (29).

    FWIW, my wife has iTunes on a Lenovo Thinkpad running Vista Home Premium, and drag-and-drop works fine.

  8. cribbs542 macrumors newbie

    Feb 4, 2009
    I just had the same problem. Right click on your desk top and hit 'Clean Up.' Should start working again
  9. cocoloco macrumors newbie

    Nov 25, 2009
    Thanks Mad Jew!

    I have a PC, not a mac :(
    BUT, your suggestion to make sure my iTunes folder has the right permission fixed this problem for me. I opened the properties for my iTunes folder in my music folder and unclicked the "read-only" box. I just updated my iTunes so I wonder if the update changed it to read-only. Either way, it worked! Now I can click and drag again! THANKS!!! :D
  10. clatms macrumors newbie

    Dec 12, 2009
    Suddenly cannot drag files into iTunes

    Running iTunes v9.0.2.25 on Vista. Used to be able to drag new song files into iTunes. Other older files drag fine. Double clicking on the music files (the ones I'm trying to drag and drop) in Windows file manager doesn't even launch it in iTunes whereas the other old music files launch fine in iTunes. The new song files play fine in Windows Media Player. Going thru the iTunes File menu to add file to library does not work either. The file format of the files that I am trying to add is "MPEG Layer 3 Audio (.mp3)." Files are not protected.
  11. clatms macrumors newbie

    Dec 12, 2009
    Resolved (kind of)

    I burned the songs to a CD and then ripped it into iTunes. If anyone knows what the root cause was - I'd be interested. Thx.

  12. babygaga macrumors newbie

    Dec 27, 2009
    hi there, i'm experiencing the same problem in my itunes. while i was updating my ipod touch and getting album artwork, i suddenly wasn't able to drag songs anymore. i can right click to add them to a playlist, but as for dragging and dropping.. it's not working :( i tried the clean up desktop trick, and it didn't work. any suggestions?

    itunes 9.0.2
    mac osx 10.5.8
  13. Super-Grover macrumors newbie

    Dec 29, 2009
    I was having the same problem. I discovered that, in my case, it had something to do with the iTunes Store. Just before drag-and-drop stopped working, I had posted a review and bought some tracks.

    I selected 'Sign Out' from the Store menu. Once I was signed out, I could drag tracks among playlists again. Some sort of temporary weirdness. Hope this helps in your case.

  14. JocelIan macrumors newbie

    Jan 1, 2010
    Super info, Grover! :D This resolved the issue for me. Thanks.

  15. Zuigia macrumors newbie

    Jan 8, 2010

    Hey, My itunes is not working properly. I have an iMac, with Itunes version 9, and about 2 days ago I found i cant drag any music into playlists, my ipod or anywhere else.
    I have looked at the replies to this forum, and i enabled itunes to work on my computer, but it still is refusing to drag music. One of the replies said something about an authorisation link on the itunes store but i cant find it. Signing out from Itunes didnt work either
    Any suggestions anyone?
  16. wsedlack macrumors newbie

    Jan 8, 2010
    Hi, running a macbook with Itunes current. Music is on three external hard drives, spread out and as of two hours ago I can't drag and drop.

    this is killing me as I want to reload Pavement onto my iphone.

    I tried signing out of Itunes, but that didn't work...anybody else have an idea?
  17. josselinrsa macrumors newbie

    Feb 9, 2010
    Drag & Drop isn't working

    Hi, having the same problem, drag & drop seems to be disabled in iTunes (9.0.3 & Mac OSX 10.6.2) I can't remember when the problem exactly occurred, but I saw it recently when trying to drag my iPhone Apps icons within the "Applications" tab from which you select the Apps you want or not to sync to your iPhone. Now I can't either do this nor drag any song/movie to anywhere may it be a playlist or even the desktop although the contrary works (from desktop to iTunes).
    I've gone through all the solutions found above but none worked.
    The worst thing is that I'm pretty sure I already had this issue before (months or years, can't remember) and never figured out how it came, nor how it vanished !

    I also have another problem which comes using the "List View" (only lines with the names of songs artists & Co, no album art or cover flow) may it be when the "Browser" column is on top or on the left, the left most column can't be scrolled through, the "scrollbar indicator" can't stop fidgeting trying to make its way down but always come back at the top of the scrollbar ! Quite visually funny but still extremely annoying when you just want to BROWSE ! This doesn't happen for the other columns on the right of the left most one...

    Anyone any idea ! I love iTunes & won't let it down, unless it does !
  18. josselinrsa macrumors newbie

    Feb 9, 2010
    got the solution !

    as simple as an old witch trick !

    can't understand how, why or when the issue occurred in the first place but I found the solution on Apple's Forum. as basic as logging out (from the  menu) and then logging in again...
    I still really feel like **** not to have more explanations !!! :mad: but :)
  19. GameKiller1119 macrumors newbie

    Feb 13, 2010
    I know this was started in 2006 but I'm haveing a similar problem w my MacBook Pro. I have had it for about a year and as of yesterday... I cant drag any files :( I can click and open them... but cant move them. Just wondering if any1 has any ideas or suggestions.
  20. Scardy macrumors newbie

    Mar 17, 2010
    So weird

    I swear I was adding tracks to a playlist and 5 minutes later I couldn't. I didn't mess with the permissions. Signing out of iTunes store didn't work. Finally just updated to latest version and that worked. So strange yet so annoying.
  21. tommygunner25 macrumors newbie

    May 30, 2010
    This may help you guys/girls

    I had same issue, clicked on my Ipod's name in left Column, under devices. You'll see Summary/Apps/Music/Movies/etc on top, a picture of your Ipod, along with Capacity, software version, serial number, below you have option to Check for update or restore, and below that, is options, Check the box "Manually manage music and videos", and you should be good to go with drag and drop. Hope this helps in your moving of files and whatnots you crazy kids do with your Ipods.
  22. darnelldesign macrumors newbie

    Jun 9, 2010
    This is the answer!!

    It sounds like we all have the same problem, and this worked great for me. Just to clarify for others: You have to log out of your entire computer, not just your itunes account. Thanks josselinrsa
  23. josselinrsa macrumors newbie

    Feb 9, 2010
    iTunes 9.2 didn't change anything

    a small update to the topic, but with no updated solution...
    the problem really pisses me off... Now with iOS 4 and the many apps you can have on your iPhone, the folders you can create, the Books you want to add... it's really annoying to log out from your session every time you need to change something !

    I sent a feedback to Apple, please do the same here
    the more we hammer our little anger the faster it might be solved, hope so, because I love iTunes, even when crippled... :eek:
  24. TXnATL macrumors newbie

    Jun 27, 2010
    this is caca del toro

    I have tried the above suggestions . Still not working. Os X 10.6.4, itunes 9.2, iPhone 3G with firmware 4.0

    The songs and playlist I can see in iTunes on my Macs. They are stored on a WD ShareSpace NAS box .

    Ahh here is an interesting wrinkle:

    Songs that were imported from a CD will play on this mac (which is authorized ) but music (and I presume movies, podcasts, etc.) That I bought on iTunes won't play and I keep going into a loop of "This computer not authorized to play..." entering my apple ID and password, getting the "this computer is Already Authorized..." message and the songs still won't play setting off another iteration of the above..

  25. Rahsaym1 macrumors newbie


    Jul 14, 2010
    Boston, Ma.
    I had the same problem yall, and here is the ultimate solution!!! I found it! :)

    In your playlist, you must have clicked the top bar that says: "Name" or something, At least that's what I clicked and immediately after, I wasn't allowed to re-arrange my songs.

    The solution:

    To your left of that bar, there is another column, with numbers, giving you the numbers of how many songs are in your playlist. Click that, and you should see an arrow facing UP or DOWN.

    1. Clicking the "NAME" bar, will lock the playlist order.
    2. Clicking the "NUMBER" bar (not TRACK NUMBER, the bar "left-est")
    Arrow Up=Unlock, then custom arrangement.
    Arrow Down=Flips that list.

    Now if you click the "NAME" bar, it will look, in alphabetically order.
    Click back the arrow to re-arrange again.

    Play with both of them a few times, back and forth, that way, you'll remember! :)

    Spread the word! :) Peace. ///

    Let me know if it worked for anybody. ///

Share This Page