Can't Enable TRIM

Discussion in 'MacBook Pro' started by 3568284, Jun 5, 2016.

  1. 3568284 macrumors newbie

    Joined:
    Jun 5, 2016
    #1
    Hi,

    I've replaced the hard drive of my MacBook Pro Mid-2012 running 10.11.5 by a Kingston SSDNow V300. Once installed Mac OS X, the first thing I've done is opening terminal to enable TRIMby using "sudo trimforce enable". After automatically restarting, I've checked the TRIM status on the System Information app, where it shows that it's still not enabled. Trying again I've realized that after confirming with the "y" twice when enabling TRIM, Terminal should show "Enabling TRIM...", then two more dots in the lines below and then "Operation succeeded. Your system will reboot momentarily, please wait...", as I've seen in some snapshots of the process I found on the internet. I my case, however, it's shown the "Enabling TRIM" and one dot, and then the system suddenly restarts. After restarting, Terminal is still open and it shows something like this:

    "[Restored 05 Jun 2016 22:28:38]
    Last login: Sun Jun 5 22:28:37 on console
    Restored session: Sun Jun 5 22:27:31 CEST 2016"

    Screen Shot 2016-06-05 at 23.33.52.png

    It seems that the SDD I bought indeed have support for TRIM, but somehow it can't be enabled in my case.

    Does somebody know why I'm not being able to enable it, or have it happened already to somebody? I've searched for a while in the forums but I haven't found the answer.

    Many thanks!!
     
  2. joecool99 Suspended

    joecool99

    Joined:
    Aug 20, 2008
    Location:
    USA
    #2
    i've similar problem, Sandisk X400 SSD - no problems enabling trim - now on this computer, after the terminal command to enable, system restarts, but trim support remains - NO. Bizarre... this is not a clean install, it's a restore from standard drive.
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    If you are on 10.11, you need to disable SIP before you enable TRIM or it won't work.
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    That's not correct. Trimforce will happily enable or disable trim with SIP enabled.
     
  5. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #5
    While the 10.11 betas required SIP to be turned off, it's hit or miss with SIP enabled for production 10.11+. For maximum reliability, it's best to disable SIP before using trimforce to enable TRIM.
     
  6. kywp macrumors newbie

    kywp

    Joined:
    Oct 14, 2016
    #6
    I, too, have a Kingston V300 120 GB installed in the main bay of a mid-2012 non-Retina MacBook Pro.

    I know this thread is about how to enable TRIM successfully with this set-up, but I'd like to pose the question of whether it can be done safely.

    Has anyone (original poster?) done this successfully and safely?

    - Yours n00bily
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    That SSD uses a SandForce SF-2281 that is very commonly used with SSDs and you should have no issues using TRIM. I have not seen reports of TRIM under OS X with that specific SSD mode, but there are many reports of it working fine with that controller.
     
  8. 3568284 thread starter macrumors newbie

    Joined:
    Jun 5, 2016
    #8
    Thank you all for your help!

    I can't remember if I had SIP enabled or disabled, but I eventually got to enable the TRIM support. I think I didn't change anything, I just tried 2-3 more times and finally got the "Operation Succeeded" message. A few seconds ago the Mac restarted and when it rebooted TRIM was enabled.
    When 10.12 was released, after formatting the SSD drive and installing, I was able to enable TRIM after the first attempt. I actually had disabled SIP before for other purposes, but recently I replaced the HHD for a SanDisk SSD on a friend's MacBook Pro and I was able to enable TRIM also after the first attempt without having to disable SIP.
     

Share This Page