Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

MacinMan

macrumors 65816
Original poster
Jan 27, 2011
1,254
686
Denham Springs, LA
Hey all,
I've had a strange issue lately. I'm unable to have the box for automatically download apps purchased on other devices stay checked after quitting the app store. This also happens with the toggle switch on the iPhone running 16.3.

All devices are signed into the same Apple ID so not sure what's going on. Only noticed this recently. Typically I have the option turned off on the mobile devices, but turned on, on the Mac. Now it won't stay on, on any device. Is this a known issue? if so, how can I resolve it.

Thanks
 

MacinMan

macrumors 65816
Original poster
Jan 27, 2011
1,254
686
Denham Springs, LA
I wanted to add, the iPhone and iPad work as expected. It's only the Mac which this setting doesn't stay checked for. I even tried signing out and back into the App store, and rebooting the Mac. Seems like something is preventing the computer from keeping that setting on. I'm running Monterey 12.6.3.
 

MacinMan

macrumors 65816
Original poster
Jan 27, 2011
1,254
686
Denham Springs, LA
Just checking back to see if anyone has any ideas on this issue. I haven't been able to resolve it, or find much current info on the problem. I can check the option, in the Mac app store preferences and it stays on until I quit the App Store and then is unchecked again. It does acknowledge that I am signed into my AppleID, and it's the same Apple ID I use on all my connected devices.
 

MacinMan

macrumors 65816
Original poster
Jan 27, 2011
1,254
686
Denham Springs, LA
What model Mac are you talking about…and…if you have more than one Mac what is/are the other(s)?
I have a late 2015, 27" iMac with Monterey 12.6.3. I also have a late 2013, 13" MBP, that I was using as a test machine for Ventura and OCLP. However, I signed the MBP out of my Apple ID so the iMac is the ONLY mac signed into icloud / Apple ID. The other devices are an iPhone 12 Pro Max, and iPad Air 2, an Apple TV 4k 2021 model. My thoughts were this behavior might be a result of not having another mac signed into the same Apple ID, but no one has confirmed this.
 

MacinMan

macrumors 65816
Original poster
Jan 27, 2011
1,254
686
Denham Springs, LA
That's what I was thinking. You could test by signing back in on the MBP.
I'll do that IF I need the feature. My main concern was if something was broken. I used to always have the setting on, in case I wanted it. However, typically I don't want things to automatically download from other machines and manually install apps. With that said, I do use automatic app updates, and that works as expected. The time I noticed the checkbox in question here's behavior was after putting Ventura on the MBP. I might be, because Ventura isn't recognized as a supported OS for that computer by Apple. As far as the iMac, I'm running Monterey, so that's the latest officially supported OS. So, since the MBP is just a test machine, and rarely used at this point. I just decided to sign it out and leave the iMac and my active devices signed in. Housekeeping stuff to help clean up the account from inactive devices.

Thanks again.
 

mjboda

macrumors newbie
Jun 5, 2023
2
0
I'm having the same problem. I do need this feature so am frustrated. My books are all synced nicely on my iPad and my iPhone but for some reason they are not automatically downloading on to my MacBook Pro Version 13.3.1 (a) (22E772610a)
 

MacinMan

macrumors 65816
Original poster
Jan 27, 2011
1,254
686
Denham Springs, LA
I'm having the same problem. I do need this feature so am frustrated. My books are all synced nicely on my iPad and my iPhone but for some reason they are not automatically downloading on to my MacBook Pro Version 13.3.1 (a) (22E772610a)
Apologies for not responding sooner. I never found a solution, and since I don't need the feature right now, as I only have one functional mac. I just decided to hold off and move on until something presented itself,
 

MacinMan

macrumors 65816
Original poster
Jan 27, 2011
1,254
686
Denham Springs, LA
Hey all, I was wondering if anyone has been able to solve this issue? As of 12.7, it's still not fixed, and what's even more strange, Ventura on the same Mac, under OCLP has this feature enabled.
This morning I downloaded the full 12.7 installer and decided to reinstall over the top of my existing 12.7 install that had been done through delta updates. Still not working as expected. However, the system as a whole runs fine.
 
  • Like
Reactions: Dylan33x

Agent007

macrumors regular
Nov 3, 2006
123
167
United States
I'm having this issue, too, so I came here to stand with you.
Books_Bug_1.gif
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.