Can't update Apps

Discussion in 'OS X El Capitan (10.11)' started by NoMansHome, Dec 26, 2015.

  1. NoMansHome macrumors newbie

    Joined:
    Dec 26, 2015
    #1
    Hi, I recently updated my 2010 27" iMac to El Capitan from Mountain Lion (I skipped Yosemite, I kept meaning to get the update, but never got around to it). After I applied the update, it was time to update applications that I had not been able to get the newest version of. So I go to the App Store and I see I have 6 updates; an update for El Capitan itself and then 5 other updates (Pages, Keynote, Numbers, iMovie & iPhoto). I accidentally hit 'Update All' when I only meant to do one at a time (slow Internet connection, wanted to get more used ones like Pages first), so I clicked cancel and then restarted just the update for El Capitan. When I did this, instead of getting the usual update status bar that shows how much is left to download, all I got was the spinning update symbol at the top left corner of the App Store window. Was worried by this, but it did download and install the update so all was OK I thought. Then when I tried to install the other 5 updates (whether individually or together), nothing happens. I get the spinning update symbol in the top left corner again, but nothing ever gets downloaded or installed. I tried restarting the App Store - nothing. I tried restarting the Mac itself - nothing. I tried the software update command in the Terminal, it says there are no updates to install. What is going on?!?!?!?!?
     
  2. Evren Carven macrumors regular

    Evren Carven

    Joined:
    Dec 16, 2014
    #2
    Please restart the Mac App Store and then go to 'Purchased' item from the top window. You can find the status for your apps.
     

Share This Page