Resolved Corrupt Safari ?

Discussion in 'Mac OS X Lion (10.7)' started by GPR, Apr 1, 2017.

  1. GPR macrumors newbie

    Joined:
    Jan 8, 2015
    Location:
    Lower Hutt ,Wellington ,New Zealand
    #1
    Hi everyone,
    It's late here, have been working on this problem for day and half time now to post the question , go to bed and try to forget it for awhile.
    For first time malware in form of ransomware has infected one of the computers in this house. Macbook Air, I don't know much about them I prefer desktop but the laptop serves purpose for daughter in law to access family overseas on Facebook and she opened an article on the Facebook page and that was that.
    The insurmountable problem has been that Safari just won't open due to "invalid parameters" and other things. It quits before it starts.
    I have done a lot... in no particular order.. removed Transmission app , I read it can enter through Transmission and that it might now be corrupt so that's gone.
    Deleted Safari cache.
    Repaired Disk Permissions.. and there was a lot of them to repair, a number connected to Safari.
    Gave myself Ownership of Safari and put it in trash and deleted Trash which it allowed me to do.
    Downloaded and installed another Safari, choose 5.1.1 was hard to find a Lion specific version.
    Read that it would be good to delete 2x WebKits (stagedframeworks?) Try as hard as I could I couldn't find them. I knew to look in systems Library.

    None of these things helped, not with Safari anway.

    There were other problems such as computer staying on for a little while with first start up then after turning itself off and being restarted it would only stay on for a minute or so. This happened over a number of hours from yesterday and today then for some reason came good.

    I have used a clean account and opened in Safe mode not that I knew what to do with it other than look around.

    Have looked in Activity Monitor but nothing looks out of the ordinary and have repeated these actions over several times.

    For awhile it wouldn't even Restart cleanly , had partial image of top of Finder screen, so I had to use power button but that has now improved.

    I have installed Firefox but it is an old version and can't be updated on 10.7, it is coping with basics, will probably run Facebook but we will have constant messages to update.

    It seems to be a problem specific to Safari and although I deleted it i am aware there will be files in the background and really technical people will know exactly what to do but I need to say I won't be comfortable coping with long technical instructions which might not be easy or clear to follow. And might cause me to stuff something else up.

    Sorry for long explanation but I had to try different strategies as much as I could and also cut short and avoid causing duplication of the help people might try to give.

    Maybe a lost cause ? But more knowledge might help in other situations like this.

    Thank you

    Susan
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Safe mode would stop any launch or startup items like malware, so that is not likely the problem.

    From what you have described, I think you may have deleted some system files that are required for Safari to operate. What I would do is backup first, then command-r boot to recovery and just reinstall the OS. Don't erase anything, just reinstall the OS over top of itself. That will fix/replace any files you may have removed and it won't delete your data.
     
  3. GPR thread starter macrumors newbie

    Joined:
    Jan 8, 2015
    Location:
    Lower Hutt ,Wellington ,New Zealand
    #3
    Thank you for responding. The malware was the issue as there was a long message about the computer being locked and having to pay for it to be unlocked and so on which we won't do. The reason I deleted anything at all was because of Safari not opening in the first place, I would never touch it unless forced to. I did think it was strange there were no other obvious signs of trouble except for computer repeatedly turning itself off which was not due to battery, it was running on mains power.
    The only things I deleted appeared to be non essential and I carefully followed advice on forums. I didn't randomly delete anything I wasn't fairly sure of.
    There are no files to speak of, just system files, anything of importance is on the desktop computer so that does give us some leeway to experiment with the laptop.
    The only other sign was lots of permission repairs needing doing ( twice)
    I'm curious how to reinstall the system over itself when it is from online purchase.. no disc for 10.7 or in this case the computer came with it installed.
    I have 10.7 on a usb stick and the very first action I took was to install from the stick which it said it had done but hadn't as previous owner;s name still appeared in places and Safari didn't change, it still kept quitting before starting.
    And the other problem we had was if you can't open a browser you can't do anything that requires internet connection.
    Until last night the computer wouldn't stay on long enough to do anything ( that was nearly 2 days)
    But I am keen to learn if there is a way to install system over itself where there isn't a disk and not worth purchasing new 10.7 from Apple.
    I did read about using remote disk so set the computers up to share and inserted 10.6 disk in desktop mac mini to try and replace 10.7 in the laptop but it wouldn't allow it which supported what I had read on forums that you can't go backwards from 10.7
    --- Post Merged, Apr 1, 2017 ---
    Just re read your message and now understand what you mean.
    I did start in Recovery mode a couple of times and as I recall it did offer to reinstall but when I tried to go ahead it said it wasn't connected to the internet which it is wirelessly but on the second time i tried to go further and it asked for the modem password but at that time it wouldn't stay on long enough to allow me to enter the password, I tried 3 times but it was pointless.
    Now it's staying on longer I might be able to go further with it.
    Sorry I didn't think more slowly about your answer.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Try turning off the wifi encryption altogether on your router then try again. Some types of wifi encryption are not supported in recovery.
     
  5. GPR thread starter macrumors newbie

    Joined:
    Jan 8, 2015
    Location:
    Lower Hutt ,Wellington ,New Zealand
    #5
    Hi.. son has just said he is taking it to be blanked which is a disappointment after all my efforts but probably the best idea however I asked him to let me have another try with Recovery and have just finished trying twice. It turned itself off each time, the second time it gave me a bit longer, I was able to enter the password both times and it was accepted and showed connection to the modem . It looked as if it would have gone further with it had it stayed on but each time it turns off I have to power on from scratch and go through the same procedure which could go on and off for hours, no way of knowing. Your reply will stand me in good stead for remembering the way to recover the system.
    Once disks were done away with I felt less confident.
    Thank you.
    Will try to find out how to give you recognition for this.
     

Share This Page