Could not set up Apple Pay - in watch app

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Super T, Oct 12, 2016.

  1. Super T macrumors newbie

    Joined:
    Oct 12, 2016
    Location:
    Aurora, IL
    #1
    I tried a couple searches and got hundreds of unrelated threads so starting a fresh one. I have an iPhone 7+ and a sport Watch Series 2. I have several cards set up with Apple Pay on the phone and I use it regularly. However, in the watch app, if I go into Wallet and try to add any of them to Apple Pay on the watch, I get a pop-up that says:

    Could Not Set Up Apple Pay
    An error occurred while setting up Apple Pay
    [OK]

    Is this a known thing? Anybody have any experience with this and find a solution/workaround? Thanks in advance.
     
  2. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #2
    Do you have a passcode setup and wrist detection enabled on your :apple:Watch?
     
  3. Super T thread starter macrumors newbie

    Joined:
    Oct 12, 2016
    Location:
    Aurora, IL
    #3
    Yes. Passcode once in the morning and not again all day.
     
  4. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #4
    In the Watch app is is called Wallet or Wallet & Apple Pay? If just called Wallet it is not setup correctly for some reason.

    First try a restart on both, then you could try un-pairing and then re-pairing them.
     
  5. Super T thread starter macrumors newbie

    Joined:
    Oct 12, 2016
    Location:
    Aurora, IL
    #5
    In the Watch app on my phone, from the main "My Watch" screen, if I scroll down it's just called "Wallet" - in there I can see all the cards stored for use on my phone. I will try restarting both and see how that goes.
     
  6. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
  7. Super T thread starter macrumors newbie

    Joined:
    Oct 12, 2016
    Location:
    Aurora, IL
    #7
    Sure 'nuff, just says "Wallet." What's the proper way to reboot this lil guy?
    --- Post Merged, Oct 12, 2016 ---
    And by the way, thanks!
     
  8. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #8
    Noting special, just power both off and then back on. If that doesn't work then you will need to try re-paring.

    Also just to be sure again you have Passcode setup? If you take your :apple:Watch off and put back on you must re-enter your code or unlock with your iPhone?

    And you also have Wrist Detection on. If so then try re-paring. It will take a little while (maybe an hour or so).
     
  9. Super T thread starter macrumors newbie

    Joined:
    Oct 12, 2016
    Location:
    Aurora, IL
    #9
    Whatever the problem was, unpairing and repairing fixed it. Thanks again!!!
     
  10. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #10
    Good to know. Re-pairing usually fixes almost everything. Too bad it is such a PIA to do. However at least the pay (pun) off is worth it.
     
  11. kkishfy macrumors newbie

    Joined:
    Dec 21, 2010
    #11
    I have the same setup and the same issue is also happening for me. Looks like a bug.
     
  12. Beards, Oct 21, 2016
    Last edited: Oct 21, 2016

    Beards macrumors 6502a

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #12
    Just found out I too have the exact same issue.
    On the iPhone 7 Plus it just says Wallet and the watch says No Passes.
    Currently unpairing with the hope it will get sorted.

    EDITED: After unpair/repair I then had to add the cards again both to the iPhone and then for the watch.
    Happy to say the unpaid/repair worked.... Cheers
     

Share This Page