Downgrade 4S iPad2/3 with new Redsn0w

Discussion in 'Jailbreaks and iOS Hacks' started by TriJetHero, May 11, 2012.

  1. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
  2. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #2
    Great news!:D But I think I'm going to hold off until the next update. A lot of people are having various problems and posting them in the comments on the dev blog. I'm in the middle of exams and I can't afford to screw up my phone.
     
  3. creativedogmedia macrumors 65816

    creativedogmedia

    Joined:
    Jun 26, 2011
  4. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #4
    Yeah. Provided you have your blobs.
     
  5. TL24, May 11, 2012
    Last edited: May 11, 2012

    TL24 macrumors 6502a

    TL24

    Joined:
    Oct 20, 2011
    #5
    Can someone post up directions on how to do this? I don't have any "blobs" saved since my replaced 4S is still on 5.0?

    How do I go about doing this? I'm assuming I need to upgrade to 5.1.1 then downgrade again to 5.0.1? If so, how do I downgrade? Sorry fellas, I'm still new to the iOS side of things. :confused:

    *UPDATE*

    I checked Cydia and it says my SHSH Blob is 5.1? How can this be? I also ran 5.0.1 JB a few months before upgrading to 5.1 - I then exchanged my 4S for a new one which came with 5.0 which I'm also running JB at the moment. Overall I'm confused on how Cydia says 5.1 instead of 5.0.1?
     
  6. bdoople macrumors member

    bdoople

    Joined:
    Apr 18, 2012
    Location:
    Cincinnati, OH
    #6
    Unfortunately for those of us who got the device new with 5.1, we don't have blobs so this doesn't help. Still a great breakthrough, but patiently waiting for JB 5.1(1). :(
     
  7. Netherscourge macrumors 6502

    Joined:
    Oct 11, 2011
    #7
    Whoa.

    So can I downgrade all the way back to 5.0 then on my iPhone 4S now?

    I made "clean" blobs of 5.0 and 5.0.1 (no jailbreak installed).

    Then I can install the Absinthe JB again?

    Is that correct?


    EDIT - nevermind - I only have two blobs of 5.0.1 - the #5 and the #6 updates.

    Still, this is fascinating. Downgrading without a bootrom exploit!
     
  8. its93rc macrumors 6502

    its93rc

    Joined:
    Feb 8, 2012
    Location:
    Austin, Texas
    #8
    Question : I ran cydia on iPhone 4S (running 5.0.1) for several months, do you guys think it saved my blobs? I'm actually quite positive that I hit the Blobs button anyway.

    Also, is there like a tutorial on this? I'm running 5.1 at the moment.

    Thanks in advance.
     
  9. Netherscourge macrumors 6502

    Joined:
    Oct 11, 2011
    #9
    Onyl one way to find out - run the new redsnow program. If it finds the blobs, then you're good to go.

    I used TinyUmbrella and just saved them to my PC.
     
  10. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #10
  11. BlueRaider macrumors regular

    Joined:
    Mar 2, 2012
    #11
    WHatever you do, DO NOT TRY to use this this tool with your phone. Your blobs from your first phone are useless now, they will not work on your replacement. If Cydia says you only have 5.1 blobs then you cannot restore to any firmware at the moment other than 5.1.1. which has NO jailbreak. When the iPhone 4S was released there was no reason to save SHSH Blobs for it because they were useless hence Cydia didn't cache the 5.0 A5 blobs. Later on Saurik changed this so that 5.0.1 blobs were saved but if you don't have those blobs saved for the phone you are currently using then you cannot downgrade OR upgrade in your instance to that firmware. You need to be very careful until the next jailbreak is released because if you get stuck in restore loop because of a bad tweak or package then your phone is going to be stuck at 5.1.1 with no jailbreak.
     
  12. TriJetHero thread starter macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #12
    As i read the tweet from pod2g, they haven't closed the loop on 5.1.1, my guess is that it will work on 5.1.1
     
  13. TL24 macrumors 6502a

    TL24

    Joined:
    Oct 20, 2011
    #13
    Thanks for the heads up my man! That clears it up :D
     
  14. Djlild7hina macrumors 6502a

    Joined:
    Mar 28, 2009
    #14
    this is awesome. just downgraded my 4S. first time i had that gui bug but second time worked like a charm :) now running absinthe
     
  15. Netherscourge macrumors 6502

    Joined:
    Oct 11, 2011
    #15
    I'm staying on 5.1 for now.

    Hoping for a 5.1 (or 5.1.1) JB so I can keep the battery-saving updates Apple made in the last update.

    5.0.1 ate my battery alive.

    But it's nice to know I can go back to 5.0.1 and use Absinthe whenever I feel like it to JB again.

    Thanks Dev-Team! You guys rock.
     
  16. rick snagwell macrumors 68040

    rick snagwell

    Joined:
    Feb 12, 2011
    Location:
    oceanside, ca
    #16
    has anyone done it yet?

    i would like to start fresh again with the absinthe jb.
     

    Attached Files:

  17. Netherscourge macrumors 6502

    Joined:
    Oct 11, 2011
    #17
    SHSH blobs are device-specific. You can't pull the blobs off of one iPhone 4S and then restore them with a DIFFERENT iPhone 4S. It has to be the exact same phone.
     
  18. 3bs, May 11, 2012
    Last edited: May 11, 2012

    3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #18
    I just tried and nearly had a heart attack thinking I screwed something up. It kept saying my shsh blobs aren't compatible with the ipsw build. I tried using the shsh on cydia but it said they can't be located. Not sure what I could be doing wrong. My phone got stuck on the connect to itunes logo. I used redsn0w to verify my blobs and it said they were valid and apticket present.
     
  19. gd6 macrumors member

    Joined:
    May 9, 2012
    #19
    Hmmm...I have a 4s on 5.0 that needs restored. It is a verizon that was unlocked with a CDMA ultra S Gevey. This said it updates to the latest baseband, I wonder if the CDMA gevey unlock is compatible with the latest baseband, as I know it is for GSM phones.
     
  20. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #20
    Do you have your shsh blobs for 5.0.1? You can't restore to 5.0.
     
  21. wellok macrumors 6502

    Joined:
    Oct 12, 2011
    #21
    I'm so excited! And glad I saved my blobs. I had to restore a while ago and it has been sad.
     
  22. gd6 macrumors member

    Joined:
    May 9, 2012
    #22
    Really? I havent tried but this was copied from the one link. The only IOS that my phone has ever been on was 5.0, so I only have the blobs saved from that.

     
  23. rick snagwell macrumors 68040

    rick snagwell

    Joined:
    Feb 12, 2011
    Location:
    oceanside, ca
    #23
    so as seen above, i have full blobs for 5.0.1

    im currently on 5.0.1, but wanna fresh jailbreak.

    im good to go right?
     
  24. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #24
    Maybe TinyUmbrella saved 5.0 blobs but Cydia didn't. My bad

    Do we have to be on 5.1.1 then restore back? Or can I do like rick wants and do it while on 5.0.1?
     
  25. wellok, May 11, 2012
    Last edited: May 11, 2012

    wellok macrumors 6502

    Joined:
    Oct 12, 2011
    #25
    Make sure you have the 9A405 blobs.

    Edit: Just reporting that the downgrade worked perfectly for me. No problems.
     

Share This Page