Facetime under 10.6

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by cqexbesd, Feb 24, 2016.

  1. cqexbesd, Feb 24, 2016
    Last edited: Feb 28, 2016

    cqexbesd macrumors regular

    Joined:
    Jun 4, 2009
    #1
    I recently bought Facetime from the App store for my 10.6 machine. Sadly I have never been able to login to my appleid account (that works fine with facetime under e.g. 10.8).

    I have tried using app specific passwords as well as creating a new (local) user to make sure it wasn't a setting. Regardless of what I try, after each attempt it tells me my password is wrong. After about 3 attempts it tells me I have my password wrong too many times and need to visit the apple ID website. I can use the same password to login to appleid.apple.com using a web browser on the same machine.

    I have tried periodically over a few weeks in case it was a temporary Apple problem. I tried ringing Apple support but they couldnt find anything (and didn't have access to any logs from their side). I wonder if its a problem of authentication methods being deprecated at some point but as they are still selling it I assume it should be able to be made to work...

    Has anyone had any luck? Is there a workaround?
     
  2. impaler macrumors 6502

    Joined:
    Feb 20, 2006
    Location:
    FL
    #2
    Why aren't you running something more modern?
     
  3. cqexbesd thread starter macrumors regular

    Joined:
    Jun 4, 2009
    #3
    Because 10.6 was the last supported OS for this machine.
     
  4. cqexbesd thread starter macrumors regular

    Joined:
    Jun 4, 2009
    #4
    I have confirmed that the sever at Apple that Facetime is talking to via SSL is presenting a certificate signed by something trusted (Apple Root CA). The connection isn't dropped straight after certificate presentation anyway - there is an exchange of data - so it's not that.
     
  5. cqexbesd thread starter macrumors regular

    Joined:
    Jun 4, 2009
    #5
    Having intercepted the communication between Facetime and Apple I see that I can't log in due to:

    status = 5012, DS login failed with code=-20101

    Sadly I can't find the meaning of those codes. There is a dserr command but it claims to not know them.
     

Share This Page