Firmware error with High Sierra?!

Discussion in 'macOS High Sierra (10.13)' started by BGBUXA, Sep 26, 2017.

  1. BGBUXA macrumors member

    Joined:
    Jul 6, 2012
    #1
    Hey Guys, I tried upgrading my mac to High Sierra and I am getting this error. Any suggestions on what may be the cause? I am running Sierra right now.

    [​IMG]
     
  2. Jimmyone macrumors newbie

    Jimmyone

    Joined:
    Feb 22, 2017
    #2
    i have the same exact problem from beta versions of high sierra since the official on a late 2009 iMac. Cannot install high sierra. First time all these years i face that
     
  3. RacecarGuy macrumors newbie

    Joined:
    Nov 21, 2014
  4. Dingo Dave 69 macrumors 6502

    Joined:
    Oct 23, 2007
    #4
    I have the exact same issue on my 2011 MBP. I had replaced my HDD years ago and I had cloned my original drive, someone suggested to me this may be the issue, does that sound likely?
     
  5. petterihiisila macrumors member

    Joined:
    Nov 7, 2010
    Location:
    Finland
    #5
    I got that for the GM candidate. The problem turned out to be a corrupted EFI partition. It's an MS-DOS formatted little slice that's needed when updating the computer firmware. If the update fails, the installer won't proceed.

    I booted inoto rescue mode, checked the partitions with "diskutil list" and "verifydisk" (terminal), and fixed the EFI partition. "diskutil repairdisk <your EFI disk/partition>".

    You can find more details of the error in the ia.log file, in the installation directory. Look for lines related to firmware, it might refer to inability to mount the MS-DOS EFI partition. That's what I had. But I don't have the logs anymore.
     
  6. dontworry macrumors 6502

    dontworry

    Joined:
    Mar 18, 2010
    #6
    same error here. mid-2010 15" MBP with Crucial SSD
     
  7. Sedulous macrumors 68020

    Sedulous

    Joined:
    Dec 10, 2002
    #7
    Same issue here. MBA 2010. I think it has to do with network access.
     
  8. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    It's apparently related to some third-party drives. If you still have the original drive then you can install to that, then put your third-party one back in and install again (the firmware is already updated so it'll work the second time).
     
  9. Sedulous macrumors 68020

    Sedulous

    Joined:
    Dec 10, 2002
    #9
    I have original drive but still have issue.
     
  10. petterihiisila macrumors member

    Joined:
    Nov 7, 2010
    Location:
    Finland
    #10
    Folks, you can try this even without rescue mode in terminal: "diskutil verifydisk disk0". Should work with those Macs with just one SSD inside. If you've got a more complex machine, check the location of the EFI partition with "diskutil list" first. Could be disk1 as well.

    It's going to check your disk, where the EFI partition lies. Takes a few seconds. Like noted, I had this issue, and it was a problem with that little partition that's needed for firmware update. Macbook 12" 2017.

    If you get this, then the partition is OK:

    user@mac : diskutil verifydisk disk0
    Started partition map verification on disk0
    Checking prerequisites
    Checking the partition list
    Checking the partition map size
    Checking for an EFI system partition
    Checking the EFI system partition's size
    Checking the EFI system partition's file system
    Checking the EFI system partition's folder content
    Checking all HFS data partition loader spaces
    Checking booter partitions
    Checking Core Storage Physical Volume partitions
    The partition map appears to be OK
    Finished partition map verification on disk0

    If yours is not OK "diskutil repairdisk disk0" in Rescue Mode terminal (boot with CMD-R) fixes it. This shouldn't be too dangerous of a fix, but of course do have a backup first.
     
  11. dontworry macrumors 6502

    dontworry

    Joined:
    Mar 18, 2010
    #11
    I "fixed" it somehow and got High Sierra working last night.
    • went to disk utility and ran first aid, got a message saying there was an error.
    • rebooted into recovery mode and ran first aid in disk utility.
    • the same error message did not pop-up
    • ok???
    • rebooted back into regular mode and ran first aid again.
    • no errors this time
    • reopened HS installer and after 30 minutes it was done and working.
    I don't know what I did but it seems to have worked, maybe the first aid in recovery mode just fixed it without telling me.
     
  12. tkermit macrumors 68040

    tkermit

    Joined:
    Feb 20, 2004
    #12
    If you can, try to unplug all external (USB) devices. That appears to have helped in my case.
     
  13. Smallcastler macrumors newbie

    Joined:
    Sep 27, 2017
    #13
    Hi there, what worked for me was to restart in Safe Mode (Hold Shift while restarting) and then run the app upgrade.

    The OS was somewhat slow in Safe Boot but the upgrade went smooth (approx 40min) from the app store. Also AFPS file system was installed on the system disk, whereas Bootcamp partition (NTFS) on the same disk was kept intact as well as ExFAT file system on my other SSD.

    Works fine so far (48hrs of testing), earlier installation of Windows10 is booting also flawlessly from Bootcamp.

    MBP 15" mid-2010 Samsung SSD and Optibay (Kingston SSD)

    hope it helped
     
  14. Jimmyone macrumors newbie

    Jimmyone

    Joined:
    Feb 22, 2017
    #14
    Not even in safe mode the installation finished, not errors with disk utility or via terminal (not SSD). All seem to work ok except verification of firmware during installation. I give up for now since my next shot is clean install
     
  15. adrianlondon macrumors 6502a

    adrianlondon

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #15
  16. BGBUXA thread starter macrumors member

    Joined:
    Jul 6, 2012
    #16
    So I took someone's advice and ran first aid in disk utility, once that was finished I received no errors, and then tried installing High Sierra with success. Good Stuff!
     
  17. DudeLA macrumors newbie

    Joined:
    Sep 29, 2017
    #17
    Solved :)
    Had the same issue. Tried many times. I do have the latest firmware so I don't know why it would do that.

    I fixed it by throwing away the High Sierra installer in the applications folder. I then reinstalled Sierra using a USB thumbdrive installer.
    Then after it started up I opened the app store to update to the latest version of Sierra. Then I downloaded High Sierra from the app store. When it came up I quit the installer and then shut down the mac. Then restart the mac and immediately hold down the shift key to boot into safe boot keep holding down the shift key and let go when progress bar is near the end. After it restarts the computer will show safe boot on the screen somewhere. The screen may flicker a little when starting up. That's ok it's normal. Then go to the applications folder and find the high sierra installer and run it. It worked for me.


     
  18. richinaus macrumors 6502a

    Joined:
    Oct 26, 2014
    #18
    I am in the same situation. This is the only time I have ever had issue with Apple. 2 MacBooks upgraded fine, but this iMac 2017 is big trouble.

    I really dont want to do a full clean install as is a work machine, and hopefully Apple will find a solution to this, so I will wait a bit.
     
  19. dudemanla macrumors newbie

    Joined:
    Jul 5, 2009
    #19
    Check out my post below DudeLA
    I don’t know if it will work for you but it worked for me
     
  20. ParanoidDroid macrumors 6502

    ParanoidDroid

    Joined:
    Sep 15, 2013
    Location:
    Venusville, Mars
    #20
    I ran into the same issue last night on my genuine MacBook 12" 2016. There was a problem that might have triggered this error. My guess is I had a firmware password set and didn't disable it prior to installation, thus EFI update couldn't work. High Sierra performs an EFI update to enable APFS

    I did a clean install anyway so I formatted my SSD to HFS+ journaled. Then ran High Sierra installer from USB-drive. The first attempt failed and produced the same error the OP had above.

    This was my approach.

    1. Make sure you have firmware password disabled.
    2. Use MacOS Sierra 10.12.x (or earlier?) recovery/install USB-drive.
    3. Boot from Sierra Recovery (hold Option-Key after reboot)
    4. Open Disk Utility, format entire SSD to HFS journaled, run first aid. Shutdown Mac.
    5. Reset NVRAM and SMC
    6. Install High Sierra from USB-drive again. If you get the error again (I did), abort and shutdown.
    7. Boot from Recovery on your SSD. High Sierra should have installed it. (Hold Command-R after reboot)
    8. Open Disk Utility and format entire SSD again to HFS+ journaled.
    9. Reboot. Your Mac is bricked now.
    10. Boot from Sierra 10.12.x Recovery USB drive
    11. Open Disk Utility and NOW you should see an EFI partition which is unmounted (was in my case).
    12. Mount the EFI partition. The EFI partition will disappear. Format SSD again to HFS journaled
    13. Install High Sierra from USB-drive. This time it should work.

    What a hilarious nightmare... Thanks Apple!
     
  21. richinaus macrumors 6502a

    Joined:
    Oct 26, 2014
    #21
    nightmare indeed. I dont understand how Apple could have messed this up so much with all the Beta testers etc.
    Anyway, I will wait as I am not doing what you did..... no time for that fun anymore.
     
  22. pinkoos macrumors 6502

    Joined:
    May 15, 2005
    Location:
    Texas
    #22
    Count me in with this problem on a MacBook Air that boots off external usb thumb drive.

    High Sierra installer hosed Sierra so I had to reformat and run internet recovery to...Mavericks! WTH!

    Looks like El Cap is in my purchase history on the MAS, so will try to upgrade back up to that.

    Why is Sierra not available in the MAS?
     
  23. Sharky II macrumors 6502a

    Sharky II

    Joined:
    Jan 6, 2004
    Location:
    United Kingdom
    #23
    I can't seem to get firmware validated on my 2010 MBP with a samsung SSD boot drive as disk0 and the original old 500GB in the DVD bay as disk1....

    'Partition map appears to be OK'...

    Have tried disk util from the installer, have tried safe mode... no luck...
     
  24. pinkoos macrumors 6502

    Joined:
    May 15, 2005
    Location:
    Texas
    #24
    Best I could do was get my Air back up to El Cap as that is the latest OS available on the MAS (other than High Sierra). I still don't understand the logic of pulling Sierra from the MAS.
     
  25. alexios_ii_komnenos macrumors newbie

    Joined:
    Oct 4, 2017
    #25
    I have the same problem and tried everything you guys recommended and still have nothing. I have a Mac Book Pro 9 from mid-2012, and an external 1TB WD Passport Hard Drive, and no original hard drive since it died a couple months ago. I tried fishing it out but the screws on the case were stripped to hell, hence the external hard drive. I'm running on Mountain Lion but before I got this external hard drive I was running Sierra via a thumbstick USB drive. That drive broke, after 2 weeks, since I got it from walmart.

    Possibly related is I have two updates queued; one a security update to the EFI and another is Macbook Pro Firmware Update 2.9. Every time I install them and restart they show up in the app store as if I never even downloaded them. Anybody in a situation similar to mine find a solution?
     

Share This Page