force itunes tu use ipsw file

Discussion in 'Jailbreaks and iOS Hacks' started by jayjar291`, Jan 28, 2017.

Tags:
  1. jayjar291` macrumors newbie

    Joined:
    Jan 28, 2017
    #1
    hi so i have a iphone 4 that i use to test random stuff and i want to install IOS 8
    ya i have read it is a no can do but i dont care if i brick it so can i force itunes to use the ipsw file for the iphone 4s?

    or can i edit the Iphone 4s ipsw file so it thinks it's for a iphone 4?

    Thanks
     
  2. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #2
    No.

    To everything.

    Why? Not because Apple is being a jerk and not letting iOS 8 install, but because the device itself has no ability to run iOS 8.
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  4. jayjar291` thread starter macrumors newbie

    Joined:
    Jan 28, 2017
    #4
    dang are you sure i don't care if i brick it so i cant force it dang
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  6. jayjar291` thread starter macrumors newbie

    Joined:
    Jan 28, 2017
    #6

    K I unzipped the ipsw with 7zip and edited the restore.plst and buildmanafest.plst and replaced the string "<string/>IPhone,4,1<\string>" with "<string/>IPhone,3,3<\string>" and it worked to the point you put in the pass code I put in the code and it paused for a second then gave me the error 3002
    So.... Thanks
     
  7. bbrks macrumors 65816

    bbrks

    Joined:
    Dec 17, 2013
    #7
    Well, let's put it this way....if successful, you would be the first one ever to do it....so, better start playing LOTO, you will have better chances to win :)
     
  8. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #8
    Error 3002 equates to this: "This device isn‘t eligible for the requested build‘ in iTunes"

    In other words, as we told you, iOS 8 cannot be installed on the iPhone 4. You can't brick it because you can't ever get it installed. iTunes won't let you.

    You'd have to alter Apple's iTunes servers and software. That's server side stuff you cannot control and don't have access to.

    Altering stuff on your side (client/iTunes) does nothing. If you could do this then it would mean all of us could downgrade to whatever iOS we wanted. And that's not possible.

    But I didn't want to go very deep into all of that in my first reply. Which is why I simply said no three times.
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    Yeah, and then you woke up :D
     
  10. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #10
    My son has an iPhone 4s. He can't run iOS 8.x either. :D :D :D
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11
    iTunes will never allow the install no matter what you edit on the .ipsw
    And even lets say you somehow hacked Apple and you enabled on their end to allow that 4S firmware to be signed and to be allowed to be installed on an iphone 4.
    The firmware and the drivers in the .IPSW for the 4S will not connect and be able to run the hardware inside the iphone 4 since they are different hardware drivers involved. So you will have to write a whole new ios 8 .ipsw with the correct drivers for the iphone 4 and make it all compatible. And then add the ios 8 iphone 4 firmware file in apples signed firmware on their end to be allowed to be installed via itunes and another 100's of hoops behind the scene that you're not even imagining about.
    But just shows how much you dont know about such things thinking you will edit some plists and get firmware not made for that device to be installed and run on an iphone 4. :D
     
  12. jayjar291` thread starter macrumors newbie

    Joined:
    Jan 28, 2017
    #12
    k i see now that it is a "no can do " Thank you much

    ps is there any war to flash android to the iphone 4.... JK lol :) ;)
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #13
    Lmao:D
    How about installing windows 7 Ultimate?
     
  14. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #14
    I want to run DOS 6.1!!!!
     
  15. jayjar291` thread starter macrumors newbie

    Joined:
    Jan 28, 2017

Share This Page