Get Time Machine to work with Airport Disk! (And possibly other network shares)

Discussion in 'macOS' started by smashingnick, Oct 26, 2007.

  1. smashingnick macrumors newbie

    Joined:
    Oct 26, 2007
    #1
    This is how it's done:
    First plug your airport disk directly to your mac and set up time machine to use it. If you want to let it back up now this is fine or you can stop it and let it back up when its plugged back into the AEBS.

    Time machine creates a file in the root directory of the disk called ".(Some hexdecimal number)" it appears this file has to be in the root of the network shared directory. In my case I use user accounts to manage my airport disk so the directory that it actually shares out is called /Shared on my disk. So I simply move the .23468f43400 file or whatever it may be called to the /Shared directory. If you let it back up while plugged in locally you will also have to move the .sparsebundle file to the /Shared directory.

    Eject the disk and plug it back into the AEBS and mount it via AFP and time machine should pick it right up. This method should work for any afp share not just airport disks.
     
  2. NYCMacUser macrumors newbie

    Joined:
    Mar 14, 2007
    #2
    Workaround

    I hate to ask, but can you explain this step by step for the novice user?
     
  3. Djmx macrumors 6502

    Joined:
    Jun 29, 2007
    #3
    lol ENGLISH...? PLEASE? :rolleyes:
     
  4. Mustard Chops macrumors regular

    Joined:
    Feb 15, 2007
  5. lilmoonee macrumors newbie

    Joined:
    Oct 28, 2003
    #5
    OPs suggestion worked! First you need a supported usb/firewire hard drive. Setup the time machine with that hard drive and cancel the first backup. Now setup the afp network to have the same name as your hard drive and connect to it. now open up terminal and run these commands.

    cd /volumes/[hard drive volume name]/
    ls -a -l

    Now look up to the list of files. There should be 12 character file that starts with a '.' example .0016fed52916

    sudo cp /volumes/[hard drive volume name]/[12 character files with leading '.']/ /volumes/[hard drive volume name] 1/
    sudo cp /volumes/[hard drive volume name]/.com.apple.timemachine.supported "/volumes/[hard drive volume name] 1/"

    Now disconnect the hard drive and time machine should detect the network share a the backup device.
     
  6. netdog macrumors 603

    netdog

    Joined:
    Feb 6, 2006
    Location:
    London
    #6
    All these brackets confuse me. Let's say the name of my drive is:

    The Wayback Machine

    What exactly would the lines for terminal be? Then I can just slug them in.

    Also, what about this theory that we just reattach to the AEBS and open the drive in finder, and then that TM will find it and continue backing up?

    Also, The Wayback Machine is going to go on a 2nd AEBS that extends the existing network. Will that make any difference?
     
  7. CavemanUK macrumors 6502

    CavemanUK

    Joined:
    Jun 29, 2006
    Location:
    Rhyl, North Wales
    #7
    Ok,

    If i have this straight, you could temporarily use a different hard drive/external drive to make those files and then copy them to your network share?

    Just a couple of other questions...

    Does it matter if you have any other data on the afp share already? will that get erase?

    Does the share have to be formatted with HFS? Im using FreeNAS on an old PC as my AFP share and im sure its not formatted as HFS
     
  8. J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #8
    I don't think this is the greatest idea in the world. Purely because you're hacking backup software — I know it's unlikely, but if Apple updates something it might start behaving weirdly, and possibly not report said weirdness. I really wouldn't want to have my hard drive fail, only to find out my h@x0ring has left my backup useless. Paranoid, I know, but anyone who backs up is by nature! :p
     
  9. CavemanUK macrumors 6502

    CavemanUK

    Joined:
    Jun 29, 2006
    Location:
    Rhyl, North Wales
    #9
    Well its not that hard to keep an eye on it.. and if your paranoid, you should be checking time machine even when your using it the recommended way... software does fail sometimes.. probably more often than hardware
     
  10. carbonizer macrumors newbie

    Joined:
    Jun 11, 2003
    #10
    What about Restore?

    Thank you very much for this post. I was able to get this to work my Lacie Ethernet Disk, wired to my computer. The one alteration I made to the procedure was that I renamed my network share while copying the files from my firewire drive, and then changed the name back once I had ejected my firewire drive. I have one very important question. Has anyone verified that we will be able to restore using this method should our entire system fail? I worry that the Leopard installer will ignore the drive. Thank you again.
     
  11. robogobo macrumors 6502

    robogobo

    Joined:
    Jun 6, 2005
    Location:
    Sitting down facing front.
  12. Chef Medeski macrumors 6502a

    Chef Medeski

    Joined:
    Jun 14, 2005
    Location:
    New York, NY
    #12
    Ohhhh good point! Well the thing is. If you restore from disk (say in the case of a full HD melt-down) then you are booting from the Install Disk. They are no files or anything. I would assume it would just look for any disk connected with Time Machine. Cause it won't have a file referencing what back up drive you used! Im unsure if it'll see AirDisks on the CD. But I would bet anythng that all you have to do is connect your HD and it would work.

    If anyone who has dones this would like to check:
    http://docs.info.apple.com/article.h.../en/15638.html

    Those are the instructions to Revert a System from the OS X disc. Just pop it in, connect the HD directly and see if its recognized.
     
  13. stefbook macrumors newbie

    Joined:
    Oct 30, 2007
    #13
    I done exactly the same procedure, and my timemachine still doesn't recognize my network drive, mounted afp://

    I have an afp share mounted. The server is netatalk linux. I know that netatalk doesn't support hard links, is that a reason why it doesn't work ?
    Is the airport extreme hard drive accept hard links ?

    thanks
     
  14. jowie macrumors 6502a

    Joined:
    Jun 9, 2004
    Location:
    London ish
    #14
    Call me Mr Stupid ;) but can't you just:

    • Connect t a network drive as per usual
    • Open Time Machine control panel
    • Choose the network drive
    • Sit back and wait?

    It's working for me...

    [​IMG]

    :)
     
  15. tjl226 macrumors newbie

    Joined:
    Nov 18, 2007
    #15
    There's a MUCH easier way!!!

    After trying to follow the instructions above without success (The LaCie Ethernet Big Disk wasn't mounting via USB) I went looking for another answer. And found it:

    http://www.macosxhints.com/comment.php?mode=view&cid=92090&query=Ethernet disk TimeMachine

    Copied here:

    There is a hidden system preference that needs to be change. This can be done by typing the following command in the Terminal:

    defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1


    After doing this, the AFP share on my Mac running Tiger appeared in the list of disks available to TimeMachine without any further modification. I kicked off a backup and it appears to be running just fine. Rather slow (I wish I had gigabit ethernet), but fine.

    Thank you Andy!!

    -TJ
     
  16. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #16
    Backup software is not something you want to hack. It has to work, no questions ask. Especially the restoring hast to work :D

    There are reasons why Airport Disks are not supported. First, Apple needs to be hundred percent safe that when the backup software thinks the data is written, then it is written. They can guarantee that with disks connect through Firewire or USB, but not with Airport (with the current firmware). Second, Time Machine creates hard links to directories, which are not supported by the Airport Firmware.
     
  17. PJALM macrumors newbie

    Joined:
    Dec 30, 2007
    #17
    Just wanted to say TM is working fine for me without any hacks of any sort.

    I was allready using TM on my external 1TB USB drive which is setup as 2 partitions, 1 for TM and 1 for file storage. I simply unpluged it and connected to my new AEBS Gigabit version and it kept working without any problems.

    The only thing I did was disable all the IPv6 stuff in Leopard and the AEBS, I allways do this because IPv6 has major issues.

    Hope this helps.
     
  18. braveheartbill macrumors newbie

    Joined:
    Jan 26, 2008
    Location:
    Sebastian, FL
    #18
    Brilliant! I copied the command and executed and Bam! my Iomega StorCenter 1TB showed up as the "volume" I authorized for my MacBook Pro. I'm doing a Time Machine backup now. I have the Iomega drive configured Raid 1 so I'm good even after a hard drive failure (the StorCenter is new 'cause the USB Maxtor 500Mb died without any warning). I use the "old fashioned approach on my windows machine using EMC's Retrospect backup software bundled with the Iomega net drive. All seems good so far.

    THANKS FOR THE EASY AND CORRECT ANSWER!

     
  19. Hawkeye411 macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #19
    I followed your simple instructions and it worked just fine. Apple won't be getting more money from me for Time Capsule!!

    Cheers.
     
  20. jowie macrumors 6502a

    Joined:
    Jun 9, 2004
    Location:
    London ish
    #20
    As mentioned elsewhere before, the problem with AirPort Extreme and Time Machine is not deliberate, it was probably disabled due to stability.

    10.5.2 was released yesterday (although I only just found this out!) and should fix this problem. I'd be very interested to hear from people who upgrade and whether the fix works!
     
  21. pilotError macrumors 68020

    pilotError

    Joined:
    Apr 12, 2006
    Location:
    Long Island
    #21
    There were some posts that said it still wasn't enabled.

    The good news is they didn't break it for those of us who did the workaround. I had a 3.8 GB backup after last nights 10.5.2 update.
     
  22. Breckenridge macrumors regular

    Joined:
    Feb 21, 2006
    Location:
    Telluride, Colorado
    #22
    Tried it and it works. Nevertheless, I'm going to stick with my firewire hd, it's just about 100 x faster.
     
  23. johny5 macrumors 6502a

    johny5

    Joined:
    Mar 31, 2007
    Location:
    UK
    #23
    Well eventually time machine works for me now.
    I had many issues with it on one Mac Pro but now I have a fw800 drive on the Pro using time machine and I have even shared this drive over the network and are successfully using this drive to also backup my macbook.
    On my macbook in time machine prefs i point at the shared drive on the Mac pro and "it just works" (at last) :D
     
  24. scottstephens84 macrumors newbie

    Joined:
    Apr 15, 2008
    #24
    Confusion

    Okay, I have read all the replys to this post. I am understanding them (for the most part), however I am not sure whether they address my specific scenario.

    I have an AEBS that has connected to it a Maxtor 500 GB HD via USB. I have iPhoto on that drive and have set it up as a share so that all computers on my wireless network can access iPhoto. I want to keep that functionality.

    I have, connected via Firewire to one of my Macbook Pro's on my wireless network (running 10.5.2), another external HD (a Western Digital MyBook Studio 1 TB drive) that is being used for backups with Time Machine. It is not currently backing up my drive connected to my AEBS.

    That is my problem. Time Machine won't back up that AEBS connected drive because it is considered a "shared" drive.

    I don't want to move the drive I am using for backups to my AEBS because of the limitation of only having one USB port on the AEBS and my desire to share my iPhoto library on my network.

    Any advice, suggestions for improvement, etc. anyone wants to offer with regard to how I have this setup overall, how I can accomplish the configuration of Time Machine to backup my shared drive, etc. I will certainly welcome and read with great interest.

    While I am somewhat experienced with Apple's jargon please be kind and write in as plain of English as possible when replying.

    Remember, my two goals are simple (I hope):

    1. Provide a shared drive for anyone on my network to access information on an external drive connected to my AEBS and;
    2. Be able to backup, using Time Machine to a separate external HD, all computers on my network, as well as the external drive connected to my AEBS.

    Thanks in advance for any help you may be able to offer.
     
  25. grayskull macrumors newbie

    Joined:
    May 8, 2008
    #25
    merge?

    I've *tried* following all this and other threads to try sort out my problem.

    I previously had my TM backing up to a USB drive directly attached to my MBP.

    Then I tried to get a bit beyond myself, and hooked the USB drive up to my Airport so I could backup wirelessly. I also have my parents iMac backing up to it via Ethernet and my girlfriends Macbook.

    There's were both fresh backups, so no previous records to worry about.

    However I thought that it would pick up on my previous backup and just carry on with it - no joy.

    So I'm wondering how I can merge my previous into the sparse image that there is now?

    I also seem to have problems mounting the sparse image over wifi - its saying the resource is currently unavailable even though i am able to connect to and browse the drive itself?

    cheers.
     

Share This Page