Getting MMS to work with AT&T (Screenshots Included)

Discussion in 'iPhone' started by JasonHiccup, Jun 17, 2009.

  1. JasonHiccup macrumors member

    Joined:
    Jun 17, 2009
    #1
    NOTE AGAIN...: I said calling AT&T is an important part of getting this to work. Not because I felt like typing useless information - but because it's an important step. It is true some users have been able to get it work without calling AT&T - also some users haven't been able to get it work even while calling AT&T. Just be sure to ask them switch over the way your phone receives MMS messages. You receive them in link form now. You need them to send & receive just like any other phones. DO NOT ask them to remove the "mms block". Chances are - your phone doesn't have one. You just receive the text messages wrong.

    ANOTHER NOTE: I keep hearing people saying that they're asking AT&T to remove the MMS block on there account. I said NOTHING about an MMS block. Your iphone is currently set up to receive MMS messages in the form of a link where you have to enter in a username and password. I simply asked them, like stated below, to change the settings so the phone receives MMS messages just like any other phone. Some reps will resist to change these settings. I had good experience from a Business rep. But like I said, Ask them to change the MMS settings so instead of receiving a link, you receive a direct picture. Unless you asked them to block MMS specifically, there will not be a block on your account.
    note: you must restart your phone after entering the mms settings for the camera icon to appear in the messages application.

    I just got my MMS working and this is how thanks to users in this thread.
    http://forums.macrumors.com/showthread.php?t=723378

    Goto this link and enable tethering.
    http://www.9to5mac.com/iPhone-3G-tethering?page=

    Use this settings (Thanks andrewseely) in settings:general:network:cellular data network

    APN: wap.cingular
    Username: wap@cingulargprs.com
    Password: CINGULAR1
    MMSC: mmsc.cingular.com
    MMS Proxy: 66.209.11.32
    MMS Max Message Size: [leave blank]
    MMS UA Prof URL: [leave blank]


    Then lastly, call ATT to have them change there MMS settings. I specifically said "Can you change my mms settings so my iPhone will receive MMS just like any other phone instead of the link method".

    I am now able to send and receive MMS.

    Hope this works for you guys instead. Here's a screenshot of the convo between the rep. Notice the AT&T network on the top left.
     

    Attached Files:

  2. komiothebeat macrumors 6502

    komiothebeat

    Joined:
    Jul 8, 2008
    Location:
    Corona, CA
    #2
    while there are a bunch of threads already on this

    this is what worked for me. :p on both lines of my account
     
  3. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #3
    i dont have a cellular data network under my network page, can you please help? thanks
     
  4. komiothebeat macrumors 6502

    komiothebeat

    Joined:
    Jul 8, 2008
    Location:
    Corona, CA
    #4
    if you read through the links you'd know that you have to update the ipcc file to get the options :p
     
  5. JasonHiccup thread starter macrumors member

    Joined:
    Jun 17, 2009
    #5
    Follow the steps from the start. The link that enables tethering will enable the screen.
     
  6. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #6
    i see, well i dont want to change the ipcc file so i guess i am out of luck until ATT allows it for us. thanks for letting me know though.
     
  7. jake36wi41 macrumors member

    Joined:
    Sep 12, 2006
    #7
    Same here, although I got tethering to work yesterday using the benm.at site. Any help is great (yes I know I could search, but I thought I'd throw out there that I'm experiencing a similar issue)
     
  8. komiothebeat macrumors 6502

    komiothebeat

    Joined:
    Jul 8, 2008
    Location:
    Corona, CA
    #8
    i don't know what file these people are hosting but i have one that is working i can send you for MMS ( i dont know if tethering is working seeing as i've only tested tethering through bluetooth once)

    aim : RmeOFme
     
  9. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #9
    i enabled tethering using the benm website. but i still dont see it.
     
  10. Cru Jones macrumors newbie

    Cru Jones

    Joined:
    Feb 23, 2008
    #10
    What about VM? I did this a few days ago, and now I've realized that I haven't received a VM since then. Now I haven't had a BM since realizing it.
     
  11. jake36wi41 macrumors member

    Joined:
    Sep 12, 2006
    #11
    wow my bad, that was easy, I'll try to not be so lazy next time :p
     
  12. jfreak623 macrumors 6502

    Joined:
    Sep 26, 2007
    #12
    i have had these settings for a few days now and i still cant get them to go through and im not on a "iphone texting plan"
     
  13. Senn macrumors member

    Joined:
    Jun 10, 2009
    #13
    :rolleyes:

    as if there arent 10 multipage threads about this as it is

    it doesnt work
     
  14. JasonHiccup thread starter macrumors member

    Joined:
    Jun 17, 2009
    #14
    I have the family text messaging plan. I had no problem what so ever getting the AT&T reps to change my mms to the right settings. I will note that JUST changing the settings did not work. It didn't work untill I called AT&T and had them change it.
     
  15. EatMyApple macrumors 6502

    Joined:
    Dec 2, 2008
    #15
    Settings > Network > Tethering
     
  16. JasonHiccup thread starter macrumors member

    Joined:
    Jun 17, 2009
    #16
    Umm. Yes. It does work. I am able to send and receive mms using my iPhone on AT&T.
     
  17. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #17
    hey thanks for the help. i did the 9to5 tether setup and i now see the cellular data network screen. i entered the settings but upon opening messages i dont see the camera button to send an mms.
     
  18. medicvz macrumors member

    Joined:
    Jun 14, 2009
    Location:
    California
    #18
    Seems like no one really has had luck with the AT&T reps... what number did you call and what did you say that convinced them to change your account to allow MMS? (Seems like most report that the AT&T reps are hip to folks trying to call and get their settings changed).

    Good for you that you got it working.
     
  19. JasonHiccup thread starter macrumors member

    Joined:
    Jun 17, 2009
    #19
    You have to restart your phone for the icon to appear.

    I have a buisness line so I had buisness customer care. I dialed 611.
     
  20. fazm macrumors newbie

    Joined:
    Jun 17, 2009
    #20
    anyone else tried this? i have done everything but make the call to att. before i do i want to see if it works.


    it is my bday after all lol
     
  21. dietwater5 macrumors newbie

    Joined:
    Jun 26, 2007
    #21
    i did the att file update and i can now see the cellular data settings and put them all in but i still do not have the camera icon in texting. I restarted my phone and still nothing. any ideas?
     
  22. brian4610 macrumors regular

    Joined:
    Jan 10, 2005
    #22
    can you send me one as well? i don't get that cellular network data page, i do have tethering set up....
     
  23. Westin macrumors regular

    Joined:
    Jun 16, 2009
  24. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #24
    ATT rep said on friday there will be an update through iTunes.
     
  25. Westin macrumors regular

    Joined:
    Jun 16, 2009
    #25
    Can you send me it as well
     

Share This Page