Ghost keyboard after swipe to unlock

mikedemunck

macrumors newbie
Original poster
Jun 8, 2009
24
14
Netherlands
I have been running into a pretty annoying bug since I got my XS.

After you swipe to unlock and immediately start typing on an empty area on the bottom of the screen (where a keyboard would normally appear), ghost keys appear on screen and you are not able to swipe to the next screen (for as long as the bug is present, which is a second or two).

Note: The bug is only present when you have set an alphanumeric code for your iPhone. When a 4 or 6 digit numeric code is set, there is no problem. The bug is still present in the 12.2 beta's.

I reported the bug multiple times now to Apple, but maybe I'm alone with this problem? Anyone else? fullsizeoutput_480e.jpeg
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
50,388
18,751
I have been running into a pretty annoying bug since I got my XS.

After you swipe to unlock and immediately start typing on an empty area on the bottom of the screen (where a keyboard would normally appear), ghost keys appear on screen and you are not able to swipe to the next screen (for as long as the bug is present, which is a second or two).

Note: The bug is only present when you have set an alphanumeric code for your iPhone. When a 4 or 6 digit numeric code is set, there is no problem. The bug is still present in the 12.2 beta's.

I reported the bug multiple times now to Apple, but maybe I'm alone with this problem? Anyone else? View attachment 823237
https://forums.macrumors.com/threads/hidden-keyboard-after-unlock-xs-max.2169761/

https://forums.macrumors.com/thread...eyboard-presses-on-home-screen.2158914/unread
 

mikedemunck

macrumors newbie
Original poster
Jun 8, 2009
24
14
Netherlands
I actually searched the forums, but didn’t find those posts... well thanks anyway. Let’s hope it is fixed soon.
 

Codeigniter

macrumors member
Feb 11, 2016
49
26
Canada
Don’t wanna jinx it but the latest 12.4 build the phantom keyboard doesn’t seem to appear after being unlocked anymore. Tested on my iPad Pro as well.
 

mikedemunck

macrumors newbie
Original poster
Jun 8, 2009
24
14
Netherlands
Don’t wanna jinx it but the latest 12.4 build the phantom keyboard doesn’t seem to appear after being unlocked anymore. Tested on my iPad Pro as well.
Don’t know about 12.4, but it’s definitely fixed in iOS 13. Good to hear that they included the fix in 12.4 as well
 
  • Like
Reactions: Codeigniter

myuserid08

macrumors 6502
Mar 15, 2008
352
4
This has been annoying me now for over 12 months.
I thought it may have been the screen - but this was replaced by apple under their recall warranty. Still the same.

Running 12.4 as well which apparently had a fix ?
 

fatkid98

macrumors newbie
Jan 21, 2012
2
0
Here I thought I was the only one! I've been racking my brain for over year about this! I recently visited the Apple Store on 3 separate occasions (over the span of about 2 weeks). I talked about this and my iPhone XR getting a kernel panic about once per month over the last 4-5 months or so, but really this ghost keyboard thing has been driving me crazy! Three trips to the Apple Store...3 different technicians, and neither of them know that this is a bug with the os. The first tech replaced my screen. After that didn't fix the problem, the 2nd tech swore that if I wiped my phone and started from scratch, that would solve the problem. After that didn't solve the issue, I took it back (with video evidence this time!) and that technician reluctantly swapped out my phone. When it was still an issue, I started searching the web a little differently, searching for "ghost" (a word the first technician I saw used) and "keyboard" and came across this forum! I switched my passcode to a less secure numerical passcode and so far, so good.
 

mikedemunck

macrumors newbie
Original poster
Jun 8, 2009
24
14
Netherlands
Yeah, it's a nasty bug for sure. Unfortunately not fixed in the 13.3 beta's as well... Also back to numerical password for now.
 

myuserid08

macrumors 6502
Mar 15, 2008
352
4
Think I've finally found the problem - it's to do with alphanumeric passwords. There must be a combination of digits and letters which causes this bug.

I have changed to a 4 digit numeric code and all has been well the past 4 weeks. Not as secure, but this bug was driving me crazy (6 digit will work as well). I havent tried changing back to alphanumeric to see if it reoccurs.
 

mikedemunck

macrumors newbie
Original poster
Jun 8, 2009
24
14
Netherlands
Think I've finally found the problem - it's to do with alphanumeric passwords. There must be a combination of digits and letters which causes this bug.
Yep, that is indeed the problem (as stated in opening post already). The bug has been filed numerous times and it was even fixed at one point in the 13.0 betas. The fixed probably introduced other issues, since they reverted it in another 13.0 beta...
 

threeonezero

macrumors newbie
Jun 6, 2007
23
18
Seattle WA
I’ve had and still have that bug on my last 2 iPhones and it occasionally happens on my iPad Pro. I made screen recordings of it and took it to Apple. Not fixed. So I dunno.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.