GM safe for non-developers?

Discussion in 'iPhone' started by ravensfan55, Oct 4, 2011.

  1. ravensfan55 macrumors 6502

    Joined:
    Mar 16, 2009
    #1
    Any other people here able to install the GM that aren't developers? I have the GM and iTunes beta here ready to rock, just making sure everything is fine.
     
  2. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
  3. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #3
    Just know once you go 5, going back is next to impossible and some of your apps may not work.
     
  4. schwilj macrumors newbie

    Joined:
    Nov 15, 2005
    #4
    I love the non answers in the threads.
    I've heard it's OK...debating it myself. It would be cool to see some simple "yep"s or "worked for me"s
     
  5. Skydivincoastie macrumors member

    Joined:
    Oct 31, 2008
    #5
    it works fine for non-devs...I am only a dev on the iPhone(my phone is only associated with a friends developer account)...I just updated my iPad...worked fine...no problems...
     
  6. CACTUARU macrumors member

    Joined:
    Dec 17, 2008
  7. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #7
    Why do you say going back is next to impossible? I ran the iOS 5 betas on my ipad2 for quite a while and had no problem restoring to 4.3.5 a couple of days ago. Do you mean that part where a backup made on iOS 5 can't be restored onto iOS 4?

    Only one app i use so far doesn't currently work, that's the WSJ iPad app. I haven't put the GM on my iPad yet so no idea if it is fixed or still broken. However it is a real risk.

    OP - no problem installing GM on my ip4, that device isn't registered to a developer account.
     
  8. r3voLoLwuT macrumors member

    Joined:
    Jul 29, 2010
    #8
    I keep getting "Device isn't eligible" when I try to install it... anyone else receiving this?
     
  9. Qoo macrumors 6502

    Joined:
    Jun 15, 2010
    Location:
    MI
    #9
    no developer account here and installed IOS 5 GM without any problem so far~~
     
  10. Shadow%20Mac macrumors 6502

    Joined:
    Dec 28, 2007
    Location:
    California
    #10
    Technically yes, developer credentials are not required to activate the iOS 5 GM.

    However, being a developer, I recommend not installing it unless you are sure you know what you are doing:

    - You need iTunes 10.5 B7, not B9. B9 is for testing iTunes Match. Attempting to activate the GM with the wrong version can be catastrophic.

    - iOS 5 GM must be a restore, not an upgrade. The SKU for the OS is different, and they want future OTA updates to work. That is also the reason that he GM can't be installed OTA from the iOS 5 Betas

    - Once you install iOS 5 GM, you can't downgrade. So, if you don't like it or it breaks some of your apps that haven't been upgraded for compatibility, you'll be stuck with iOS 5 till its official release (not too far away, but still)

    That being said, there are no technical restrictions from installing iOS 5 GM on non-dev iPhones.
     
  11. CACTUARU macrumors member

    Joined:
    Dec 17, 2008
    #11

    How? I have the the newest iTunes and the GM and it keeps giving me an error message??
     
  12. Dylatron2000 macrumors regular

    Dylatron2000

    Joined:
    Aug 4, 2011
    Location:
    Durham, NC
    #12
    I have iTunes 10.5 beta 9 with iTunes Match and I just installed the GM on my CDMA 4, given my UDID is registered as a developer, it worked with no problems.

    I'm going to try putting the GM on my girlfriend's 3GS with 4.3 in a sec, will post back with results.
     
  13. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #13
    You have to use iTunes 10.5 beta 7
     
  14. jauhari macrumors regular

    jauhari

    Joined:
    Mar 20, 2007
    #14
    Why So many new apps that show up on Apple Media Event such as (Cards, Where is My Friends, Notification Center) didn't available on iOS 5 GM... any body can found this app on iOS 5 GM?
     
  15. Qoo macrumors 6502

    Joined:
    Jun 15, 2010
    Location:
    MI
    #15
    I download the iTunes 10.5 Beta 7 and download the iOS 5 GM and using restore instead of upgrade to install on my 4, it runs great so far for me
     
  16. JamesHP macrumors regular

    Joined:
    Feb 6, 2010
    Location:
    Manchester, UK
    #16
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    I'm a non developer, the GM works perfectly on my iPhone 4. Genius seems to have disappeared from the music app but that's about it.
     
  17. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #17
    When you did that does it keep all the apps and all your media (like music) as well?
     
  18. CACTUARU macrumors member

    Joined:
    Dec 17, 2008
    #18
    When it's done restoring, which file would I choose to restore it from? Or set it up as a new phone?
     
  19. frunkis54 macrumors 65816

    frunkis54

    Joined:
    Apr 2, 2009
    #19
    that is not true. i am a dev i have 10.5 b9 and i updated today flawlessly.
     
  20. Qoo macrumors 6502

    Joined:
    Jun 15, 2010
    Location:
    MI
    #20
    i set it as new instead of using backup.
     
  21. theone09 macrumors regular

    Joined:
    Nov 17, 2008
    #21
    Do i need the itunes 10.5 beta 9 to upgrade to the iOS5 gold version? Thanks
     
  22. adztaylor macrumors 68000

    Joined:
    Aug 20, 2009
    Location:
    Preston, UK
    #22
    Yep, you can use beta 9 without problems.
     
  23. Qoo macrumors 6502

    Joined:
    Jun 15, 2010
    Location:
    MI
    #23
    you will select the iOS 5 GM as the file to restore and i am not sure you want to set it up as a new phone or use your backup, for me just set it up as a new phone.
     
  24. 34design macrumors newbie

    Joined:
    Sep 1, 2011
    #24
    mac iTunes b9 works perfectly for GM upgrade
     
  25. creativedogmedia macrumors 65816

    creativedogmedia

    Joined:
    Jun 26, 2011
    #25
    It's not letting me select the file...it's a dmg file and I am using Lion on a MBP.
     

Share This Page