Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

musqayan

macrumors newbie
Original poster
Jul 2, 2013
14
1
Anybody else have any GPS or Cell Service issues? Was playing Pokémon Go and checking my maps, and it wasn't keeping up with my movement, then would lose GPS signal. Obviously it's a beta, but didn't see any reports from other people on this. Just did a DFU restore back to 11.4 to double check it's not a hardware issue out of nowhere.
 
  • Like
Reactions: yaronr

Danbrown521

macrumors regular
Jun 19, 2011
214
145
Lakeland, Fl
I'm having the same issues. When using the maps app for directions it gets hung up and loses me altogether sometimes. The only real bug that I've reported so far
 

drtome

macrumors member
Dec 22, 2013
32
4
I have the same GPS / navigation problems with Apple/Google Maps, Tomtom Go etc. on my iPhone X.
 

0014

macrumors 65816
May 23, 2016
1,031
677
Middle East
I use Google maps daily for my commute to/from work and have had no issues, even re-routing around traffic.

However RunKeeper it can't get a decent fix, even in wide open country. I've tried using it when running yesterday and today.

Yesterday it locked on 2miles in but then said my run was 2 miles shorter than it was. Today it went the other way and 5 mins in said I'd ran 3.9miles (I wish!) so I stopped using it.

Fortunately my Suunto watch has built in GPS so was able to track the runs fine.
 

musqayan

macrumors newbie
Original poster
Jul 2, 2013
14
1
Did anyone attempt a clean install using the .ipsw? Or did you guys do OTA? Attempting a clean install this morning. (I know, I know, rookie mistake, should have just done clean install form the start)
 

drtome

macrumors member
Dec 22, 2013
32
4
Did anyone attempt a clean install using the .ipsw? Or did you guys do OTA? Attempting a clean install this morning. (I know, I know, rookie mistake, should have just done clean install form the start)

No, I did an OTA installation.
 

cmhsam

macrumors 6502
Jul 14, 2008
448
70
Add me to the list. IPx OTA upgrade

UPDATE - I reset network settings and seems to have fixed the problem.
 
Last edited:

dan9700

Suspended
May 28, 2015
3,347
4,824
My GPS on the x isnt working as well my drone and waze has a hard time to find it
 

musqayan

macrumors newbie
Original poster
Jul 2, 2013
14
1
Did a clean install, haven't had a chance to truly test it, but will later today. Hoping that will help. I tried resetting network settings yesterday to no avail.
 

dan9700

Suspended
May 28, 2015
3,347
4,824
Did a clean install, haven't had a chance to truly test it, but will later today. Hoping that will help. I tried resetting network settings yesterday to no avail.
i didnt i done OTA update im thinking i might have to go back to 11.4 as gps is a huge deal for me its a shame cos the beta is running so well
 
  • Like
Reactions: yaronr

mattopotamus

macrumors G5
Jun 12, 2012
14,678
5,898
No issues here with the X (did not do a clean install). I used GPS with CarPlay and it worked like always. Also, no CarPlay issues either.
 

planetf1

macrumors 6502a
Aug 8, 2014
549
203
Hampshire, UK
So I do get a location in maps which isn't far off but it's to within 100m not say 10m . Compass looks fine. So it half works. Not tried a network reset yet
 

mattopotamus

macrumors G5
Jun 12, 2012
14,678
5,898
So I do get a location in maps which isn't far off but it's to within 100m not say 10m . Compass looks fine. So it half works. Not tried a network reset yet

My GPS initially did that. It was off, but as soon as I started moving it fixed itself.
 

sam3020

macrumors 6502a
Dec 3, 2007
555
77
I'm just trying a restore through the ipsw to see if it fixes this problem
 

musqayan

macrumors newbie
Original poster
Jul 2, 2013
14
1
I'm just trying a restore through the ipsw to see if it fixes this problem

That's what I tried, still off/on unfortunately. Also having weird Cell Issues, random no connectivity even with showing 2-3 bars of LTE. But that's the nature of the beast with the beta software.
 

rjlawson

macrumors newbie
Sep 18, 2013
10
6
Location on my 6S seems OK, TomTom GO & Maps both navigate fine. However I'm not seeing a map in the Activity app after a run with either phone paired GPS, or purely on my Apple Watch 3 (still on 4.3.2) with phone Wifi/Bluetooth disabled. Anyone else see the same issue?
 
Last edited:

drtome

macrumors member
Dec 22, 2013
32
4
The restore via iTunes did the trick. Google Maps navigation went flawlessly this morning. Quick GPS fix, no stuttering etc..
 
  • Like
Reactions: gwhizkids
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.