[Guide] Success! Install 10.8 on old unsupported Mac

uby1

macrumors newbie
Jan 6, 2018
2
0
Hi ADDvanced,
Thanks for the hint and for the link to your thread.
So I gave it another try (actually 2 or 3) with MLPostFactor v0.3 and this morning it worked!
It seems the flavour (10.8.0/1/2/3/4..) of my Installation Package was not clear.
I did not need to run manually the patching scripts.
So no time right now to do extensive test, but it boots up and show correct hardware configuration.
So one more unsupported iMac running OS X 10.8
Many thanks,
Uby1
 

aggourin

macrumors newbie
Jan 11, 2018
6
1
Hi,
Thanks for all that great Work! Thanks to all!
Yesterday I install mlpostfactor v0.3 to my unsupported macbook 4,1 white a1181. It seems to work fine except 2 issues that is minor and too small issues, but if anyone know how to fix it will be great!
A) my touch pad have a little lag that is nearly unnoticeable and i reduce the sensitivity and now seems that work good, so is minor issue,
and
b) When i use firefox to view some web pages like waterfox webpage or to view a pdf file , I see distortion image like GPU issue. With the same websites opened by chrome , work perfectly fine..... So is this Firefox glitch or mlpostfactor glitch? Can this cause damage? Can anyone test it in there mlpostfactor instance and inform me for the results?

I also notice that the mac is more silent now and more fast and responsive .... It seems that mountain lion is better than lion.... Is this normal ? Any logical explanation?
 

aggourin

macrumors newbie
Jan 11, 2018
6
1
On my MacBook 4,1, with 10.8.5 Update 1 (why they didn't call the most recent version 10.8.6 is anybody's guess), everything seems to be working fine except for occasional graphics anomalies AND broken SMB. Has anyone been able to replace Apple's SMB stack with something that works, like SAMBA or DAVE? I have tried both, but out of the box neither allowed me to access Windows and Linux network drives through the finder. I guess I don't know how to configure them. Any help would be appreciated. Thanks!
Hi! , Did you find any solution for the occasional graphics anomalies that i Also have? Can this anomalies cause any hardware damage or ...It will be fine?
[doublepost=1515698943][/doublepost]
Hello :) I have a Macbook 4.1 (early 2008) and want to install Mountain Lion on it using MacPostFactor. No matter what i do it won't boot from the partition created, instead it gets me back to the old system. Anyone can help me out about this?
This is issues with the partitions on your usb stick. You must have 1 partition extended jurnald. Also that can be caused by non compatible usb sctick.
 

e38BimmerFN

macrumors newbie
Mar 18, 2018
1
0
Hey ADDvanced Sir.

I have been looking over this and I have a few questions, if your still around. So I have a Mini A1176 Intel with 4Gb ram. Was my father in laws. Had 10.6.8 loaded on it. I happened to install 10.7 on it and got it upgraded to 10.7.5. However I was hoping to max this thing out with OSX 10.8. I gathered all the required software and such. Got ML .v03 package as we.
I don't have 10.8.4/5 on disk, only 10.8. I followed the instructions and after following and waiting. I got 10.8 loaded on top of 10.7.5. The mini booted find and I was able to log in. However only two issues I found, I could not connect to any SMB shares that I have in place not could I use the 10.8.5 update combo file. Said it could not be installed on this PC.

Should I have installed 10.8 over 10.6.8 instead of 10.7.5?
If and when I do this again, should I start with 10.6.8 and install 10.8 directly over 10.6.8?
If and when 10.8 is fully loaded, can I upgrade using any of the combo packages after installation of 10.8?
Is there an actual 10.8.4 or.5 installer disk DMG available some place to download?
Is 10.8x the max OSX version that the mini will support?


I'm currently installing 10.7 on to the mini to see how well it goes. I do have a back up DMG of the drive before I started all of this so I can re-image it later on. Just hoping to clarify some questions.

Thank you for your time and efforts.


Uby1; I got it to work and it's now running 10.8.4 perfectly, no weird issues like you are describing.

Please read my thread here:

https://forums.macrumors.com/threads/32bit-efi-on-2007-imac-can-this-be-hacked.2094278/
 

chriz74

macrumors member
Sep 11, 2014
57
12
Italy
I went back to MPFC 1.something to install Mountain Lion, bluetooth is working however the system profiler can't tell what BT hardware it has, I think this is why facetime is not working, the calls fail, probably facetime checks mac address consinstency of the BT hardware. Infact in the same pc with Mavericks facetime works and BT is seen correctly but opengl is not supported.
I tried to use kexts from LION for blutooth but they don't load, probably I made some mistakes, I extracted them from the installer and looking inside they don't have codesignature...

Imessage works. This is the summary fror BT on system profiler:

"There was an error while gathering this information."

console:

4/15/18 11:50:27.000 AM kernel[0]: CSRUSBBluetoothHCIController::setupHardware super returned 0

4/15/18 12:09:18.235 PM system_profiler[355]: Exception while calling [SPBluetoothReporter updateDictionary:]
-[CSRHostController USBProductID]: unrecognized selector sent to instance 0x7ff142465ed0

ioRegistry:

Screen Shot 2018-04-15 at 12.11.26 PM.png
 
Last edited:

Romanesq

macrumors 6502a
Jun 16, 2003
901
67
Hoboken
Would this work with a 24" iMac 6.1 with a 7600GT? Or would I lose the 7600GT drivers?
Well, I surrender. After a day of trying to do the install on a Mac Mini (upgraded) to 2.1 with 4GB RAM, the install goes to the end and then we get this message:

The 'swap' folder is missing! MCPF cannot continue!
Please contact MLforAll at voolfy@me.com.

I had tried ML install from a USB and then a USB stick but that's where it gets stuck with the same message. Of course I did send an email fwiw.

Did go into disk utility and repaired a ton of stuff automatically. But trying to boot into the main drive or the recover drive loops back to the message. MCPF tries to run and then blamo, you go to the error message.

I'm out of ideas and have tried a clean ML install using three different MCPF versions: 1.0.1, 2.0 and the most recent 2.0.1.

No dice.

What is this "swap folder" even referenced?


UPDATE: With no apparent change on a lark, I booted up the Mac Mini and decided to just hold the SHIFT key and see what would happen. Yesterday it didn't fare well.

Today, it went into the new mac opening and loaded! It shows Mountain Lion 10.8.5.
I'm trying to create some space for desktop working. Slow as molasses but let's wait until indexing stops.

No idea why it suddenly began working though. If it helps anyone, here it is. Shift from the boot up of the new Mountain Lion fresh install.

UPDATE 2: One reboot and kaput. Back to the original issue above. Then reboot with option key to main drive and hold shift key goes into an endless white screen but does not go back into launching the system.

UPDATE 3: Another install attempt but this time the difference was a USB drive and a partition with 18GB space. It went through but oddly the same issues as above. It works when the USB is connected to the Mac Mini at bootup and gives the same error message as above when it isn't.

It was running smoother but there didn't seem to be a good browser option. Safari was having all kinds of server connection issues to websites including the homepage of this one. So I went back to Snow Leopard for this old backup (upgraded) Mac Mini 2.1.
 
Last edited:

applCore

macrumors regular
May 3, 2011
142
58
Has anyone managed to get GPU acceleration on X1600 (via MacbookPro 2,1) on 10.8 Mountain Lion? I thought I'd read that someone managed this with macOS Extractor, but I'm not having success.
 

Czo

macrumors 6502
Dec 30, 2008
404
250
Debrecen, Hungary
Has anyone managed to get GPU acceleration on X1600 (via MacbookPro 2,1) on 10.8 Mountain Lion? I thought I'd read that someone managed this with macOS Extractor, but I'm not having success.
Acceleration works fine with 64 bit kernel on 10.8 if you downgrade the X1600 kext's and two frameworks (OpenGL and OpenCL) from 10.7.
 

ribero

macrumors newbie
Dec 17, 2017
10
6
Hi All,

I just browsed the full thread to find information about why I'm the only one not succeeding in installing ML on a Macbook Air 1.1 (original).

The Macbook Air is running 10.7.5, I tried to install 10.8.5 using MacPostFactor 2.0.1, 2.0 and 1.0.1.
I tried to install on an external usb hard drive freshly formated, tried to install on the internal disk... no success.

After MPF prepartion of external Usb i reboot the mac (by selecting the usb drive at boot). Mac starts to boot (grey apple on screen) then the screens goes white and the mac continues to boot (or reboot ?) on the previous 10.7.5 internal disk.

I tried all option of MPF with no success.

Can anyone help or give good ideas to go further ?

Thanks !
 

chriz74

macrumors member
Sep 11, 2014
57
12
Italy
Hi All,

I just browsed the full thread to find information about why I'm the only one not succeeding in installing ML on a Macbook Air 1.1 (original).

The Macbook Air is running 10.7.5, I tried to install 10.8.5 using MacPostFactor 2.0.1, 2.0 and 1.0.1.
I tried to install on an external usb hard drive freshly formated, tried to install on the internal disk... no success.

After MPF prepartion of external Usb i reboot the mac (by selecting the usb drive at boot). Mac starts to boot (grey apple on screen) then the screens goes white and the mac continues to boot (or reboot ?) on the previous 10.7.5 internal disk.

I tried all option of MPF with no success.

Can anyone help or give good ideas to go further ?

Thanks !
I had this when creating the USB pen under High Sierra, it makes a bad pen. Under Yosemite works.
 

ribero

macrumors newbie
Dec 17, 2017
10
6
ok finally I got ML 10.8.5 installed but I had to use MPF v0.3... which seems to manage 10.8.4 max.

Anyway it is now installed but iMessage/Facetime is broken :( . It was the main reason why I tried to upgrade
Now I'm looking for a way to make iMessage and Facetime work.

The few things I read are not very encouraging. It seems very hard to have those parts of ML to work correctly.

I already tried to tweak the nvram settings with no success.

Does someone have an advice on this topic ? Thanks !
 

RV-ABZ

macrumors 6502
Apr 11, 2013
256
3
10.8.5 is MLPF'able. The 10.8.4 numbering is just cosmetic and you can edit the file carrying this info yourself. It makes no difference at all whether you apply MLPF to 10.8, 10.8.3 or 10.8.5.

Just remember that what this hack really does is tune down your ML vanilla installation to a bastardised DP1 version.
 
  • Like
Reactions: G4fanboy

ribero

macrumors newbie
Dec 17, 2017
10
6
10.8.5 is MLPF'able. The 10.8.4 numbering is just cosmetic and you can edit the file carrying this info yourself. It makes no difference at all whether you apply MLPF to 10.8, 10.8.3 or 10.8.5.

Just remember that what this hack really does is tune down your ML vanilla installation to a bastardised DP1 version.
Thanks for your reply ! Yes I understood that version numbering is easy to change (and I done it).
Unfortunately it seems that this "MLPF 10.8.5 downgraded version" is not really usable in my context.
I found that iMessage / Factetime is broken but also Bluetooth (control panel crash when I try to open it).

It was a fun adventure but I'm afraid that this old Macbook Air will stay in the bottom drawer . Without those apps it will be not ver useful for my kid.

Anyway, thanks for your help.
 

TMRJIJ

macrumors 68040
Dec 12, 2011
3,215
5,218
South Carolina, United States
MacPostFactor has been depreciated and will no longer be updated. macOS Extractor v1.45 will experiment with the
‘OS X 10.8.5 Supplemental Update 1.0’ in hopes of avoiding overwrites to kernel extensions.
 

Th3odor3

macrumors regular
Jun 19, 2018
115
14
Santa Clarita, CA, US
I am using MacPostFactor 2.0.1 in creating a mountain lion usb install for a unsupported Mac Pro 2,1 I checked legacy graphics drivers. what does this mean? and I have a non-efi graphics card a Nvidia GT 120 512MB installed.
 

mpbb

macrumors newbie
Jun 15, 2014
11
2
I am using MacPostFactor 2.0.1 in creating a mountain lion usb install for a unsupported Mac Pro 2,1 I checked legacy graphics drivers. what does this mean? and I have a non-efi graphics card a Nvidia GT 120 512MB installed.
The only advice I could give you is not to use 2.01 but rather the 1.01 version . Dont know about mac pro 2,1...
 

mlmacml

macrumors newbie
Oct 22, 2018
6
0
hi guys!

i know mlpostfacotr doens't support installESD.dmg
but that's the only kind i have.
is there a way to somehow make it work?

also, i read on the osxhackers site, "if your mac blows up, it's your responsibility!"... something like that. i know it's a figure of speech, but does this mean if i mess up, my macbook 2,1 would become unusable? i have no data on there, so data recovery is not a concern, but if i do this whole mlpostfactor installation incorrectly, would i not be able to even go back to my current snow leopard, and my mac would be "bricked"?

i'm a total noob so i'm worried about that :(
 
Last edited:

faizalnin

macrumors newbie
Nov 6, 2018
1
0
MacPostFactor #TeaserImage Taken down temporarily. Can't handle the load of emails and tweets asking for release date.
Made a installer partition on my Dell Inspiron 1525 which is currently running LION 10.7.3
Stuck at the below mentioned screen . Help !
Dell Inspiron 1525
4GB Ram / 500 GB HDD
 

Attachments

Czo

macrumors 6502
Dec 30, 2008
404
250
Debrecen, Hungary
Made a installer partition on my Dell Inspiron 1525 which is currently running LION 10.7.3
Stuck at the below mentioned screen . Help !
Dell Inspiron 1525
4GB Ram / 500 GB HDD
Something went wrong with Apple's CPU Power Management kext (because you are try to run it on a hackintosh). Why are you try to install this? This is for real but outdated Macs, not for generic PC's.
 

smuudge

macrumors newbie
Jun 1, 2007
10
0
Interesting thread! Before i waste time trying to resurrect my dead 1.6 Intel Core Duo Mac Mini 1,1. Will this hacked OS work on this machine, and what version of MLPost Factor should i use if so? Cheers!
 

Larsvonhier

macrumors 6502a
Aug 21, 2016
602
979
Germany, Black Forest
Interesting thread! Before i waste time trying to resurrect my dead 1.6 Intel Core Duo Mac Mini 1,1. Will this hacked OS work on this machine, and what version of MLPost Factor should i use if so? Cheers!
First you should update your Mini1,1 to a 2,1 by running the firmware updater tool that can be found in other threads of this forum. That gives you more max. RAM and the possibility to change your CPU to a C2D Merom type. After that, you can run up to El Cap (without full graphics accel.) or Mountain Lion (with good acceleration).
 

howardc64

macrumors newbie
Mar 14, 2011
26
8
Thought I provide an update mid 2019 on how to get the old Core Duo machines over to 64 bit and Mountain Lion. Probably still some tinkerers out there like me :) Doing this on an early 2016 iMac 17" Core Duo.

- Install OSX 10.6.8 as a starting point.

- Do surgery to install the C2D CPU. T7200 is $1.50 on ebay shipped from China as of this post. $0.50 more than a couple of years ago haha.

- Update firmware from 4.1 to 5.1. Good old firmware tool stopped working as Apple moved their firmware locations on the net. Posted work around here https://forums.macrumors.com/threads/problems-upgrading-imac-4-1-to-5-1.2188232/#post-27525859

- Had difficulty installing Lion. Perhaps its the copy I had (might have already been patched on a prior iMac 4,1 effort) Went to SFOTT to make a USB install key for ML. SFOTT also encountered error due to age and solution is here https://forums.macrumors.com/threads/solved-sfott-usb-key-not-bootable-mavericks.1903561/#post-27528884

- SFOTT key installed ML fine but had no accelerated graphics. Messed around with trying to patch kexts and OpenGL without success and decided to just run MPF v1.0.1 since I had prior issues with v2.0.1. Now have latest ML all properly patched after Apple updates. Here is my post on that https://forums.macrumors.com/threads/guide-success-install-10-8-on-old-unsupported-mac.1325709/page-189#post-24821336

- On note on running MPF v1.0.1 on SFOTT installed ML is need to make another partition for MPF to install ML (which also creates a MPF patching capable recovery partition). If SFOTT ML partition was removed, the MPF ML partition can not grow upwards. I eventually cloned (using Carbon Copy Cloner) MPF ML to external HDD, wiped the internal HDD and did MPF ML install on internal HDD again along with creating the special patch capable recovery partition. Probably good idea to archive the recovery partition off HDD for safe keeping in case HDD fails.

Thought I post the entire solution sequence in one place for someone attempting the same.
 
Last edited:
  • Like
Reactions: typofonic

typofonic

macrumors newbie
May 10, 2019
3
0
Hi,

I tried to install Mountain Lion on a MacBook 2,1 following the OSXHackers Method 1 with macOS Extractor. The Installer completes but it says that the system maybe can't boot because it can't set the startdisk disk. But it boots succesfully.anyway However installing the GMA950 drivers doesn't complete succesfully (the postinstall installation script fails - no further details in the log).

After booting the GMA 950 drivers are loaded fine though, but the dock is gone and checking Activity Monitor and the Console shows that the dock keeps restarting and crashing.

I have tried to start up in safe mode, tried to create a new user and reinstall the GMS850 package, but the problem persists.

Any ideas on how to fix this?
[doublepost=1564990970][/doublepost]Anyone have a working install image of Mountain Lion 10.8.5 for MacBook 2,1?
 

zcream

macrumors member
Sep 8, 2008
40
6
Hi,

I tried to install Mountain Lion on a MacBook 2,1 following the OSXHackers Method 1 with macOS Extractor. The Installer completes but it says that the system maybe can't boot because it can't set the startdisk disk. But it boots succesfully.anyway However installing the GMA950 drivers doesn't complete succesfully (the postinstall installation script fails - no further details in the log).

After booting the GMA 950 drivers are loaded fine though, but the dock is gone and checking Activity Monitor and the Console shows that the dock keeps restarting and crashing.

I have tried to start up in safe mode, tried to create a new user and reinstall the GMS850 package, but the problem persists.

Any ideas on how to fix this?
[doublepost=1564990970][/doublepost]Anyone have a working install image of Mountain Lion 10.8.5 for MacBook 2,1?
I've a macbook 2,1 as well :) I'll follow your adventures as Im not happy with Lion.