Handbrake taking up more than 100% of my cpu???

Discussion in 'Mac Apps and Mac App Store' started by xi mezmerize ix, Jul 23, 2010.

  1. xi mezmerize ix macrumors 6502a

    xi mezmerize ix

    May 24, 2010
    Maryland, USA
    Activity monitor shows that handbrake is taking up more than 100% of my CPU for a length of time, sometimes even 300%. Other applications sometimes show this too. How is this possible?
  2. sammich macrumors 601


    Sep 26, 2006
    At least have some idea of what you're talking about if you're going to reply.

    In Mac OS X, each logical core is designated as 100%. So if you have 2 cores, you get a max of 200%.
  3. xi mezmerize ix thread starter macrumors 6502a

    xi mezmerize ix

    May 24, 2010
    Maryland, USA
    I'm pretty sure my i5 2.53 GHz only has 2 cores, so why does it show 300%+ sometimes?
  4. gnasher729 macrumors P6


    Nov 25, 2005
    Hyperthreading. On the MacPro, iMac with i7, and MacBook Pro with i5 or i7, each core consists of two virtual cores. That means each core can run either at 100% normal speed, or as cores each running at maybe 60% of normal speed for a total gain of 20%. Handbrake thinks you have four slower CPUs running at 60% speed instead of two faster ones running at 100% speed.
  5. wordoflife macrumors 604


    Jul 6, 2009
    Sorry. I didn't know. I just switched over from a PC a few days back, and I remember on my PC it taxed 100% of my CPU.
  6. filfortugno macrumors regular

    Jul 1, 2010
    Montreal, Quebec, Canada

    the core i5 and i7 are physically dual core but the os sees 4 cores, so its possible to go up to 400%
  7. adammjenkins macrumors member

    Dec 15, 2009
    West Virginia
    I decided to revive this old thread with a similar question. I understand that my i5 iMac can register up to 400% cpu through Handbrake, but how can I actually encourage this? Here's my dilemma, if I am ripping a dvd, I am generally only web browsing or doing something else light (if I am even on the computer during the rip at all). I can only seem to get Handbrake to use up to slightly above 200%. I obviously would like it to use the cpu to the most of its ability to get the task done faster... that's why I bought the quad core. I want to use the cpu, not allow over half of the power to sit idle.

    Any thoughts or settings that I might be able to try to get Handbrake to use all the the iMac will give?
  8. plinden macrumors 68040


    Apr 8, 2004
    You should probably have created a new thread, but anyway ... you can't encourage Handbrake to use more CPU - it uses up as much as it can. So if you're doing something else that uses 4% CPU, Handbrake should use 396%

    So the question now is, why doesn't it do that with your iMac? The only thing I can think of is that maybe the DVD drive is acting as a bottleneck, although it shouldn't. However, Macworld in their last iMac review - http://www.macworld.com/reviews/product/586737/overview/27inch_core_i5_imac28ghz_quadcore.html - found that:
    Try ripping the DVD to the hard drive and encoding from the rip and see if that improves anything.
  9. mulo macrumors 68020


    Aug 22, 2010
    Behind you
    really, I thought they allowed for 100% on each logical core.

Share This Page