Have I ruined my iMac?

Skeptical.me

macrumors 6502a
Original poster
Jun 10, 2017
503
418
Australia
IMG_6856.jpg

Hi,

I installed mac OS High Sierra on my iMac Late 2015 27” i5 5K. Something I completely regret doing.

It was a disaster. So I decided to re-install macOS Sierra.

Firstly, I erased the Macintosh HD.

I booted up into Recovery (Command R) and erased the Macintosh HD in my iMac using disk utilities (“Mac OS Extended (Journaled)”). Then I re-installed macOS Sierra 10.12.5 from a bootable drive I had prepared earlier.


However, once re-installed I tried to encrypt the drive using Filevault and this error occurred:


“Boot File Not Written”.


I searched for a solution and found an article suggesting a new clean install would fix this. So I attempted to install macOS Sierra 10.12.5 again.


So I booted up into Recovery again and attempted to erase the Macintosh HD again.


When I attempted to erase Macintosh HD I selected “Mac OS Extended (Journaled)” as I did the first time and then I clicked erase. Then I received this message:


“Erase process has failed. Click Done to continue”.


Under Details:


“Unmounting disk3

Couldn’t unmount disk.

Operation failed.”


This same issue occured when I tried to run “First Aid” on the drive.


This problem occured regardless of whether I booted from the Macintosh HD recovery or the macOS Sierra install USB Drive.


I am was also unable to re-install macOS Sierra onto the drive. When I tried to re-install macOS from the bootable USB drive I received the following message:


“Building boot caches on boot helper partition failed.


Quit the installer to restart your computer and try again.”


I also tried downloading and re-installing from recovery which also failed.


And I also booted into macOS Sierra and re-downloaded macOS Sierra from the App Store and was unable to re-install it.


Then panicking I booted back into Recovery and tried the restore function. Not understanding what I was doing I somehow restored the macOS install usb drive contents to Macintosh HD.

I then erased the drive successfully and rebooted and attempted to boot from the USB Drive (holding Option key at startup), that failed (see image above). I then tried to enter Recovery but also ended up with the same screen before me. See image above.

What the hell did I do? Have I ruined my iMac?

It’s still under warranty.
 

m4v3r1ck

macrumors 68020
Nov 2, 2011
2,341
355
The Netherlands
Hi C3po7,

That's indeed a h*ll of a first post! But hey when things do go wrong, your help is here on MR. ;)

First things first:

1.
Late warning, but please remember NEVER install a beta on your day-to-day machines for which I presume your iMac is?

2. Did you make a proper backup before you performed this - beta - upgrade? This is very important for those who will be troubleshooting your issue(s). Worst case scenario, your drive may need to be reformatted for another clean install.

Cheers
 
  • Like
Reactions: willmtaylor

petterihiisila

macrumors regular
Nov 7, 2010
141
66
Finland
It's not ruined. Perhaps the disk is now formatted with APFS, or left in some weird state after those operations, something that Sierra has trouble with. If you want the original macOS version back, booting Internet Recovery brings you close. Shift-Option-Command-R during boot. It will take a while to boot from the Internet.

Then with Disk Utility and Terminal study what's happening with your disk. In my case I had to use both the GUI and terminal versions of "diskutil apfs" to get rid of everything apfs-related. It should be okay to fool around and make errors there, as you're trying to zap the disk anyway. You cannot really "break" the computer via your keyboard. "diskutil list" shows you the disk configurations. Take some time to study and understand what they are, you'll learn for the next disaster too.

If as a result you're able to have just one large disk, formatted with HFS+, then you're ready to install OSX again in the main menu. It will load may gigabytes over the Internet, so prepare to wait.

Once Sierra is installed, then you can point it to a Time Machine backup.

Alternatively, you can skip the Internet Restore altogether. If you can make the machine boot into Recovery Mode, and empty the disk into HFS+, then just restore from Time Machine.
 
  • Like
Reactions: m4v3r1ck

Fishrrman

macrumors Core
Feb 20, 2009
19,645
6,842
OP:
Your post ought to be filed under the archived topic titled "learning about what NOT to do to your Mac the hard way"…

Rule #1:
DO NOT put beta software onto a Mac that you depend on without a backup.

My own rule:
Get an external drive and CarbonCopyCloner (or SuperDuper).
BEFORE you install a beta, create a cloned backup of the internal drive on the external drive.
Now, if the beta messes things up, it's easy to boot from the backup, re-initialize the internal drive, and RE-clone the backup BACK TO the internal drive.

If you're getting nowhere, and the Mac is still under warranty, take it to a brick-n-mortar Apple Store.
They'll get you fixed up.
 
  • Like
Reactions: m4v3r1ck

bopajuice

Suspended
Mar 22, 2016
1,571
4,348
Dark side of the moon
Another great example of why I don't mess with betas. As others recommend, boot from internet recovery, or create a bootable USB copy of Sierra. You will need another mac and a USB thumb drive. I assume this was not your only mac or main computer, right?

I always keep a USB thumb drive with a bootable version of MasOS handy just in case. It's also much faster than using internet recovery. After that transfer your data from your backup.
 

Riwam

macrumors 65816
Jan 7, 2014
1,084
244
Basel, Switzerland
View attachment 706727
Hi,

I installed mac OS High Sierra on my iMac Late 2015 27” i5 5K. Something I completely regret doing.

It was a disaster. So I decided to re-install macOS Sierra.

Firstly, I erased the Macintosh HD.

I booted up into Recovery (Command R) and erased the Macintosh HD in my iMac using disk utilities (“Mac OS Extended (Journaled)”). Then I re-installed macOS Sierra 10.12.5 from a bootable drive I had prepared earlier.


However, once re-installed I tried to encrypt the drive using Filevault and this error occurred:


“Boot File Not Written”.


I searched for a solution and found an article suggesting a new clean install would fix this. So I attempted to install macOS Sierra 10.12.5 again.


So I booted up into Recovery again and attempted to erase the Macintosh HD again.


When I attempted to erase Macintosh HD I selected “Mac OS Extended (Journaled)” as I did the first time and then I clicked erase. Then I received this message:


“Erase process has failed. Click Done to continue”.


Under Details:


“Unmounting disk3

Couldn’t unmount disk.

Operation failed.”


This same issue occured when I tried to run “First Aid” on the drive.


This problem occured regardless of whether I booted from the Macintosh HD recovery or the macOS Sierra install USB Drive.


I am was also unable to re-install macOS Sierra onto the drive. When I tried to re-install macOS from the bootable USB drive I received the following message:


“Building boot caches on boot helper partition failed.


Quit the installer to restart your computer and try again.”


I also tried downloading and re-installing from recovery which also failed.


And I also booted into macOS Sierra and re-downloaded macOS Sierra from the App Store and was unable to re-install it.


Then panicking I booted back into Recovery and tried the restore function. Not understanding what I was doing I somehow restored the macOS install usb drive contents to Macintosh HD.

I then erased the drive successfully and rebooted and attempted to boot from the USB Drive (holding Option key at startup), that failed (see image above). I then tried to enter Recovery but also ended up with the same screen before me. See image above.

What the hell did I do? Have I ruined my iMac?

It’s still under warranty.
-----------------------------------------------------
I don't think that this is the solution for your situation and probably the other comments you received are. o_O
Just to consider about... :rolleyes: I have solved many difficult solutions by starting from any OS version which allowed me to boot my Mac from it (external USB drive or USB pen key) on which DISK WARRIOR was installed, either version 5 or a previous one.
I do not know anything as effective as let DISK WARRIOR analyze and rebuild any faulty volume.
Good luck. :rolleyes:
Ed
 

dianeoforegon

macrumors 6502a
Apr 26, 2011
907
137
Oregon
I'm guessing this is a Fusion iMac. I had the same thing happen to me. Did you made a bootable clone backup prior to running the High Sierra installer?

If yes, boot into your clone.

Note: Disk Utility, DiskWarrior, using Terminal commands to revert to CoreStorage all failed.

I had installed a previous version of High Sierra and was able to boot into the High Sierra partition and use the new Disk Utility to fix the drive.

If you do not have a previous High Sierra partition, if you can boot from your clone and create a partition on an external drive to install the latest High Sierra beta. Once you are booted from the High Sierra partition, you can start the fix on your drive. I can give you more details if you can get to this point.
 

Skeptical.me

macrumors 6502a
Original poster
Jun 10, 2017
503
418
Australia
It's not ruined. Perhaps the disk is now formatted with APFS, or left in some weird state after those operations, something that Sierra has trouble with. If you want the original macOS version back, booting Internet Recovery brings you close. Shift-Option-Command-R during boot. It will take a while to boot from the Internet.

Then with Disk Utility and Terminal study what's happening with your disk. In my case I had to use both the GUI and terminal versions of "diskutil apfs" to get rid of everything apfs-related. It should be okay to fool around and make errors there, as you're trying to zap the disk anyway. You cannot really "break" the computer via your keyboard. "diskutil list" shows you the disk configurations. Take some time to study and understand what they are, you'll learn for the next disaster too.

If as a result you're able to have just one large disk, formatted with HFS+, then you're ready to install OSX again in the main menu. It will load may gigabytes over the Internet, so prepare to wait.

Once Sierra is installed, then you can point it to a Time Machine backup.

Alternatively, you can skip the Internet Restore altogether. If you can make the machine boot into Recovery Mode, and empty the disk into HFS+, then just restore from Time Machine.
Hey,

Thanks for the reply. I really appreciate everyones input.

Unfortunately the Shift-Option-CMD-R doesn’t work, nor does just Option, or CMD R. I keep getting the same screen.

I am, however, using the standard Apple Bluetooth Keyboard that came with the iMac. So, maybe there aren’t any drivers for it to work??? I’ll try a wired keyboard asap.

Thanks again (to everyone) I’m completely lost without assistance from others.
I’ll also read as much as I can about this, I’m sure others have encountered something similar.
[doublepost=1498946941][/doublepost]
I'm guessing this is a Fusion iMac. I had the same thing happen to me. Did you made a bootable clone backup prior to running the High Sierra installer?

If yes, boot into your clone.

Note: Disk Utility, DiskWarrior, using Terminal commands to revert to CoreStorage all failed.

I had installed a previous version of High Sierra and was able to boot into the High Sierra partition and use the new Disk Utility to fix the drive.

If you do not have a previous High Sierra partition, if you can boot from your clone and create a partition on an external drive to install the latest High Sierra beta. Once you are booted from the High Sierra partition, you can start the fix on your drive. I can give you more details if you can get to this point.
Would you believe me if I said that when I got High Sierra running I setup time machine in settings and without realizing deleted the Sierra backup. Yep, this is a nightmare (I lack some basic understanding of this stuff, I think that’s obvious. :( )

I don’t have a clone either (but I will after this).

The only thing I have is a bootable USB Drive with Sierra 10.12.5 on it.

Also, as I wrote above I’m unable to access recovery (CMD-R at startup) as well as Shift-Option-CMD-R as well. And just holding down Option at startup to choose what drive to boot from doesn’t work either.

I’m using a Bluetooth keyboard, so I’m going to try a wired keyboard asap and try again.
 

winterny

macrumors 6502
Jul 5, 2010
386
201
If you have another mac and an appropriate thunderbolt cable to link them together, command-t at boot will put the system into "target disk mode", and you should be able to do whatever is necessary to restore the partition table on that drive.

As others have said, you probably have a drive which is half-way converted to apfs, and the old Sierra recovery disk utility probably cannot handle it.

A wired keyboard is probably more useful than bluetooth at this point also.

Ultimately, zeroing out the drive and doing a reinstall should bring you back. Zeroing out the drive might be a little bit of a challenge, but it's not impossible.

Also keep in mind, even if you can't get into the Recovery mode due to a busted partition on there (it's honestly surprising that Internet Recovery would fail) ... You can use recovery mode on another mac hooked up via Thunderbolt to repartition and reinstall as well ... just be very careful to work on the right drive and not to blow away the working OS :)
[doublepost=1498956779][/doublepost]Also, to all of the 'don't run beta blah' comments ... You are learning a lesson now. Perhaps the process of bringing it back, while scary, is interesting, and you'd like to be part of the development/testing process ... Or perhaps it's just not for you. Either way, in the future, the advice that others gave by using a separate partition (or even an external drive) is def the right way of going.

I have run beta OS's many times in the past, and I generally clone my drive onto an external usb3 drive, install there, and try it out for at least a couple of week switching back and forth before I decide to actually upgrade my main drive.

In this particular case, I would say that High Sierra with APFS conversion is the highest risk beta from apple in many years -- beta filesystems are EXTREMELY high risk. I wouldn't trust that for primary use until we are near the final release.


I actually just saw your last post about having a thumb drive that will let you boot up ... From there you should be able to zero out the drive. Hopefully it is easy to use the Disk Utility "partition" tool, but if not, diskutil commands may work, or as a worst case scenario, using "dd if=/dev/zero of=(path to device of the bad drive)" for a few seconds and then ctrl-c will clear the first few bytes and will almost certainly make Disk Utility work with it again. Be very very careful to make sure you run it on the correct device ... System Information or Disk Utility should help you find the right device name.
 
  • Like
Reactions: Skeptical.me

Skeptical.me

macrumors 6502a
Original poster
Jun 10, 2017
503
418
Australia
If you have another mac and an appropriate thunderbolt cable to link them together, command-t at boot will put the system into "target disk mode", and you should be able to do whatever is necessary to restore the partition table on that drive.

As others have said, you probably have a drive which is half-way converted to apfs, and the old Sierra recovery disk utility probably cannot handle it.

A wired keyboard is probably more useful than bluetooth at this point also.

Ultimately, zeroing out the drive and doing a reinstall should bring you back. Zeroing out the drive might be a little bit of a challenge, but it's not impossible.

Also keep in mind, even if you can't get into the Recovery mode due to a busted partition on there (it's honestly surprising that Internet Recovery would fail) ... You can use recovery mode on another mac hooked up via Thunderbolt to repartition and reinstall as well ... just be very careful to work on the right drive and not to blow away the working OS :)
[doublepost=1498956779][/doublepost]Also, to all of the 'don't run beta blah' comments ... You are learning a lesson now. Perhaps the process of bringing it back, while scary, is interesting, and you'd like to be part of the development/testing process ... Or perhaps it's just not for you. Either way, in the future, the advice that others gave by using a separate partition (or even an external drive) is def the right way of going.

I have run beta OS's many times in the past, and I generally clone my drive onto an external usb3 drive, install there, and try it out for at least a couple of week switching back and forth before I decide to actually upgrade my main drive.

In this particular case, I would say that High Sierra with APFS conversion is the highest risk beta from apple in many years -- beta filesystems are EXTREMELY high risk. I wouldn't trust that for primary use until we are near the final release.


I actually just saw your last post about having a thumb drive that will let you boot up ... From there you should be able to zero out the drive. Hopefully it is easy to use the Disk Utility "partition" tool, but if not, diskutil commands may work, or as a worst case scenario, using "dd if=/dev/zero of=(path to device of the bad drive)" for a few seconds and then ctrl-c will clear the first few bytes and will almost certainly make Disk Utility work with it again. Be very very careful to make sure you run it on the correct device ... System Information or Disk Utility should help you find the right device name.

Thank you so much for your reply. I’d be lost without the help.

The good news is the wired keyboard worked.

I am able to boot into recovery, I’m also able to boot from the USB Drive.

So, now I’ll read through all of the comments and learn as much as I can before I act (something I ought to have done to begin with). And you’re absolutely right, although frustrating, I will learn from this experience and I do enjoy it when I accomplish something on the Mac I’ve not done before.

The comments are correct, I should not have put this beta on my only iMacs HD. And also I’ll clone the drive once the issue has been solved.
 
  • Like
Reactions: willmtaylor

Samblis

macrumors newbie
Jul 2, 2017
3
0
Same thing happened to me.When i run first aid the AppleAPFSMedia drive seems to be corrupted. I have a recent time machine back up. Do I erase the AppleAPFSMedia drive and then install the Time Machine Back up?
 

petterihiisila

macrumors regular
Nov 7, 2010
141
66
Finland
Same thing happened to me.When i run first aid the AppleAPFSMedia drive seems to be corrupted. I have a recent time machine back up. Do I erase the AppleAPFSMedia drive and then install the Time Machine Back up?
Yes. Erase it and make sure it’s a GUID partition and HFS+ format before installing Sierra back in, or restoring. The APFS stuff needs to be gone.
 

Skeptical.me

macrumors 6502a
Original poster
Jun 10, 2017
503
418
Australia
Yes. Erase it and make sure it’s a GUID partition and HFS+ format before installing Sierra back in, or restoring. The APFS stuff needs to be gone.
Hi,

I haven’t been able to get some time to fix this issue until now.

I don’t see an APFS when I run Terminal “diskutil list” See image.

https://imgur.com/a/nukr8


And I have no idea what disk4 & disk6 to disk20 are.

Even with the HFS GUID partition I can’t install Sierra from the internet or from the usb install.

Is there anything on the diskutil list that could give some clue to what’s going on?

Edit: When I try to run First Aid (or try to erase the volume) I receive the following message:

“Storage system check code is 0.
Updating boot support partitions for the volume as required.
Unable to unmount volume for repair.
Operation failed...”
 
Last edited:

iMi

macrumors 65816
Sep 13, 2014
1,399
2,730
Thank you so much for your reply. I’d be lost without the help.

The good news is the wired keyboard worked.

I am able to boot into recovery, I’m also able to boot from the USB Drive.

So, now I’ll read through all of the comments and learn as much as I can before I act (something I ought to have done to begin with). And you’re absolutely right, although frustrating, I will learn from this experience and I do enjoy it when I accomplish something on the Mac I’ve not done before.

The comments are correct, I should not have put this beta on my only iMacs HD. And also I’ll clone the drive once the issue has been solved.
You should be able to repair core storage from Terminal. All you need to know to fix the problem is here. Don't worry. Nothing serious happened to your iMac and you'll be back up and running in no time.

Also, ignore all the "you shouldn't have..." comments. In hindsight, some choose to be all high and mighty - like they've never done anything that they regretted - instead of offering useful advice.

Good luck. Let us know how things go. There is a ton of super knowledgable people here. You'll get the help you need.
 

petterihiisila

macrumors regular
Nov 7, 2010
141
66
Finland
Hi,

I haven’t been able to get some time to fix this issue until now.

I don’t see an APFS when I run Terminal “diskutil list” See image.

https://imgur.com/a/nukr8
Even with the HFS GUID partition I can’t install Sierra from the internet or from the usb install.

Is there anything on the diskutil list that could give some clue to what’s going on?
It looks like disk0 is your small SSD, and disk1 is the 1 TB HDD. And disk3 combines those (with corestorage) into an unecrypted Fusion drive. So you want to be sure that disk3 is well.

Disk2 is a recovery partition or boot disk you used. Those others shouldn't be relevant here. They are some sort of helper partitions, or maybe you've got external drives plugged in.

From here it's hard to see what could be wrong with the Fusion drive. Did you try to check the health of disk2, and/or reformat it with HFS+? Once the Fusion drive is properly formatted, Sierra should be able to accept it fine.

It's possible to use "diskutil cs" commands to split the Fusion drive and rebuild it, but looks like it'd be total overkill.
 

xgman

macrumors 603
Aug 6, 2007
5,050
811
Is this APFS conversion really as bad and troublesome as it seems? I haven't really read anything good about it here yet.
 

Skeptical.me

macrumors 6502a
Original poster
Jun 10, 2017
503
418
Australia
It looks like disk0 is your small SSD, and disk1 is the 1 TB HDD. And disk3 combines those (with corestorage) into an unecrypted Fusion drive. So you want to be sure that disk3 is well.

Disk2 is a recovery partition or boot disk you used. Those others shouldn't be relevant here. They are some sort of helper partitions, or maybe you've got external drives plugged in.

From here it's hard to see what could be wrong with the Fusion drive. Did you try to check the health of disk2, and/or reformat it with HFS+? Once the Fusion drive is properly formatted, Sierra should be able to accept it fine.

It's possible to use "diskutil cs" commands to split the Fusion drive and rebuild it, but looks like it'd be total overkill.
Thanks for the reply.

When I check the health of disk2s1 everything appears ok. Just testing the disk I ran “diskutil repairvolume /“
and I received the same error message “unable to unmount volume for repair (-69673)”

https://imgur.com/a/jgOQi

So it appears that I am stuck. I am unable to install macOS on it.
 

petterihiisila

macrumors regular
Nov 7, 2010
141
66
Finland
Thanks for the reply.

When I check the health of disk2s1 everything appears ok. Just testing the disk I ran “diskutil repairvolume /“
and I received the same error message “unable to unmount volume for repair (-69673)”

https://imgur.com/a/jgOQi

So it appears that I am stuck. I am unable to install macOS on it.
You are trying to repair the wrong disk, that’s a normal/proper message for it. When you boot from recovery partition, “/“ is not your Fusion drive, its the recovery volume aka Base System. And diskutil can’t repair the volume you booted from, because current boot drive can’t be unmounted. Can’t cut the branch you are sitting on.

Tell it to repair disk3, or wherever the Fusion drive is mounted into. Check /Volumes directory. That’s where the drives are mounted, if they are. Get to know the relation between your disks, where they are mounted, and what’s in them. How to mount and unmount.

For that purpose the GUI diskutil also works. Check the drive names, and then what “disk” they are associated with. The fine print :)

The Fusion drive is a virtual disk, made of two physical disks. Diskutil told the numbers, and can accept them as targets for the repair command.

I hesitate to give direct copy paste commands, because if they are not for your current disk numbers, they don’t work, or (in some cases) could push you deeper into ditch. But the computer looks fine, it’s not “broken” ... just needs a little kick.
 

petterihiisila

macrumors regular
Nov 7, 2010
141
66
Finland
Is this APFS conversion really as bad and troublesome as it seems? I haven't really read anything good about it here yet.
You are reading the problem threads. Not many people report their successes, but failed cases need help, so that’s more public. The ratio is misrepresentative in this context.

The conversion has been fine for most. It’s getting back, what’s been difficult, as some parts can require more technical insight than regular users typically have. Those are known issues in this beta, it’s work in progress. The developer release notes warned about some “not yet ready” back conversion features. Public beta documentation doesn’t tell as much during the process. Perhaps the public beta testers should be pointed through release notes too, this year, so they know what to watch out. It’s technical but relevant.

It’s fair to say this public beta might have arrived a bit too “half baked” after all. Then again, now they get lots of feedback, if that’s what they wanted :)

This time “have a backup” has even more relevance than before. Time Machine and clones makes beta testing much more safe. And knowing Diskutil makes it a lot less confusing.

Personally, the file system has been working great for me. Same speed, some individual operations are very fast. Window management is more responsive, thanks to Metal2. And it’s cool to play some high quality videos without any CPU impact on a lowly MacBook Adorable 2017.
 

Skeptical.me

macrumors 6502a
Original poster
Jun 10, 2017
503
418
Australia
You are trying to repair the wrong disk, that’s a normal/proper message for it. When you boot from recovery partition, “/“ is not your Fusion drive, its the recovery volume aka Base System. And diskutil can’t repair the volume you booted from, because current boot drive can’t be unmounted. Can’t cut the branch you are sitting on.

Tell it to repair disk3, or wherever the Fusion drive is mounted into. Check /Volumes directory. That’s where the drives are mounted, if they are. Get to know the relation between your disks, where they are mounted, and what’s in them. How to mount and unmount.

For that purpose the GUI diskutil also works. Check the drive names, and then what “disk” they are associated with. The fine print :)

The Fusion drive is a virtual disk, made of two physical disks. Diskutil told the numbers, and can accept them as targets for the repair command.

I hesitate to give direct copy paste commands, because if they are not for your current disk numbers, they don’t work, or (in some cases) could push you deeper into ditch. But the computer looks fine, it’s not “broken” ... just needs a little kick.
Thanks. Sorry I’m not following correctly, I do appreciate the help.

Just to be clear I was following what you wrote “Did you try to check the health of disk2, and/or reformat it with HFS+? Once the Fusion drive is properly formatted, Sierra should be able to accept it fine.” Disk2 is the OS X Base System.

This is my problem: I can’t unmount the Fusion disk to run first aid or reformat/ erase. See the photos.

Here are a series of photos (4 photos) of me trying to run “first aid” on the Fusion Drive (disk3) from Disk Utility. As well as try to erase the disk. Both actions end with “unable to unmount...”

https://m.imgur.com/a/7jR7t

Here is a photo of when I tried to repair the disk3 volume from Terminal. I received the same error message:

https://m.imgur.com/a/kCEYj


I hope this shows clearly what I’m experiencing. Sorry for any confusion.
 
Last edited:

Skeptical.me

macrumors 6502a
Original poster
Jun 10, 2017
503
418
Australia
You are trying to repair the wrong disk, that’s a normal/proper message for it. When you boot from recovery partition, “/“ is not your Fusion drive, its the recovery volume aka Base System. And diskutil can’t repair the volume you booted from, because current boot drive can’t be unmounted. Can’t cut the branch you are sitting on.

Tell it to repair disk3, or wherever the Fusion drive is mounted into. Check /Volumes directory. That’s where the drives are mounted, if they are. Get to know the relation between your disks, where they are mounted, and what’s in them. How to mount and unmount.

For that purpose the GUI diskutil also works. Check the drive names, and then what “disk” they are associated with. The fine print :)

The Fusion drive is a virtual disk, made of two physical disks. Diskutil told the numbers, and can accept them as targets for the repair command.

I hesitate to give direct copy paste commands, because if they are not for your current disk numbers, they don’t work, or (in some cases) could push you deeper into ditch. But the computer looks fine, it’s not “broken” ... just needs a little kick.
So, I used “diskutil cs” and learnt the option available to delete the core storage group and then create a new group. And I successfully deleted it and re-created the 1TB Fusion drive. Then I erased the “untitled” drive renamed it Macintosh HD, verified the disk, and now I am installing macOS Sierra from the USB drive.

All seems OK.

And it was a hell of a lot easier then I expected.

Thank you, and everyone else, for helping me.

Edit: All is working perfectly well. The OS installed, all apps and data reinstalled. Perfect, thanks!
 
Last edited:

dualist

macrumors newbie
Jan 5, 2008
10
0
I've read issues with fusion drives, not so much with full SSD or HDD.

I know this thread is pretty old, but I found it very helpful, and it put me on the right track.

I was unable to install any OS on the iMac Fusion Drive, but using diskutil and diskutil cs, and the instructions in this article, I managed to rebuild the drive and successfully install.

Cheers to all!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.