Help: Could not mount disk1s2 after erase

Discussion in 'macOS High Sierra (10.13)' started by lowkeygunner, Mar 25, 2018.

  1. lowkeygunner macrumors newbie

    Joined:
    Mar 25, 2018
    Location:
    Pakistan
    #1
    Hey,

    I'm new to this forum and, don't know much about Mac. I have a Macbook Pro mid 2012 edition. I recently Installed a used SSD (Samsung Evo 850 250gb) in place of my HD, and took out the optical drive and placed my HD there instead. I have a USB to boot High Sierra on the new SSD, which i'm planing on using to boot my Mac.

    The problem is, when I go into disk utility I can't erase nor partition the disk on "Mac Os Journaled". I get
    "Could not mount disk1s2 after erase", and "Operation Failed".
    I can only partition the SSD on "ExFAT", but I can't load the operating system on ExFAT format. I've tried force erasing the disk via terminal but that too gives me error, and says "Could not mount disk1s2 after erase".
    I've also tried going into recovery mode with "Command + R" and trying to erase/format the SSD from there but it gives me the same error.

    Any help will be highly appreciated!! THANK YOU!
     
  2. BLUEDOG314 macrumors 6502

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #2
    do 'diskutil list' in terminal and paste results here. On that model machine however, there is potential that the hard drive cable is going bad.
     
  3. lowkeygunner thread starter macrumors newbie

    Joined:
    Mar 25, 2018
    Location:
    Pakistan
    #3
    Screen Shot 2018-03-26 at 12.25.44 PM.png
    --- Post Merged, Mar 26, 2018 ---
    This is what i get with "diskutil list"
     
  4. lowkeygunner thread starter macrumors newbie

    Joined:
    Mar 25, 2018
    Location:
    Pakistan
    #4
    Problem solved. I changed the SSD cable and it worked. Thanks!
     

Share This Page