Help! Updated to macOS 10.12.4, MBP randomly shuts off

Discussion in 'macOS Sierra (10.12)' started by mokhan23, Mar 30, 2017.

  1. nicoguzman macrumors newbie

    nicoguzman

    Joined:
    Oct 17, 2017
    #76
  2. Brinsley macrumors newbie

    Brinsley

    Joined:
    Oct 24, 2017
    Location:
    Mumbai
    #77

    Hi there, ok so i ran the code on terminal trick and it has worked but using 100 percent of my cpu makes my mac hot but still am happy it works. Now i followed all the steps in your tutorial but however when i drag Run shell script and it opens, i then select as arguments in the drop down, i get a code as follows :-

    for f in "$@"
    do
    echo "$f"
    done

    so should i wipe this code away and then enter your code or should i just enter your code after this ??
    i tried doing both and saved the application etc but when i restarted my mac it gave me an error saying MacFix cant open due to the error.

    And about the authorised apple service center i collected my mac and they said there is a problem with the logic board and that will need replacement. and the replacement cost is 44,000 rupees.
     
  3. maciek1422 macrumors newbie

    Joined:
    Oct 29, 2017
    #78
    Hi guys, I have the same problem on my MacBook Retina 13 Late 2013. I take it to apple authorized service, but after a week they tell me that everything is okay. I found this thread yesterday, but I have this problem since March I think. Now I'm testing python script and I hope so it will work for me too. I'll let you know in a few days.
    I see there is more and more people with this problem, so maybe Apple will find out that this is a bigger problem...
     
  4. boblikesoup macrumors newbie

    boblikesoup

    Joined:
    Nov 7, 2017
    #79
    Took mine in to a repair shop and they said there was nothing wrong with it. They did some hardware maintenance too and the problem persists. If you don't want to run the Python script, something that helps me get fewer crashes is running x1-2 long (fantasy background music) YouTube videos on mute in background tabs.

    How to run Python script: Run Terminal application > type "cd Downloads" > type "python solution.py"

    Problem for me started a month ago. MacBook Pro 2014.
     
  5. bulatbulat48 macrumors newbie

    Joined:
    Nov 11, 2017
    #80
  6. Raul P. macrumors newbie

    Raul P.

    Joined:
    Nov 12, 2017
    #81
    Hey everyone. Add me to the list of sufferers. My MacBook pro 15" (mid-2014) that is less than 3 years old just started shutting down last week. Safe boot mode is the only stable place right now and I am awaiting a response from Apple engineers regarding my computer logs to determine whether this is a CPU frequency or kernel issue. I am not confident that this will end without being asked to fork over hundreds of dollars for a "rare" hardware repair.

    I have been in contact with the developer of a software package that is supposed to prevent the CPU from ever entering the low frequency mode that is causing these shutdowns. I will be waiting until I hear back from Apple engineering department before I move forward with any additional mods but I can tell you I sure as hell won't be paying Apple to bury their problems under the rug.

    However at the moment I have observed something curious on my end so I don't know if anybody else has seen this. There is currently a glitch going around with iOS and the letter "i" causing it to autocorrect to A and a symbol and I am not sure whether these two issues are just a big coincidence. From digging around the internet about this shutdown problem and this computer model, it seems to correlate with the emergence of the iOS glitch. When the iOS problem started on my phone last Tuesday and I force-corrected it to revert to the proper letter, then through the syncing or online account logins or the direct cord connection of my phone to the MacBook, this glitch and the correction I made appeared on the computer. Almost immediately after that the shut downs started and the logs began indicating "BUG in libdispatch", "Unknown key for integer: _DirtyJetsamMemoryLimit" etc. and I have not been able to get rid of them.

    My hypothesis is that this glitch has infiltrated and corrupted a litany of files on the computer that has either caused or exposed the flaw in the CPU by engaging the frequency lowering that causes these shutdowns. It may also explain why wiping what I thought were the major culprits like Chrome, Adobe and various Library caches were able to provide longer stretches of time without shutdowns. No matter what I do though the glitch returns and shut downs resume, and even though this isn't recognized as malware or a virus it sure behaves like it. If the iOS glitch and this logic board failure are indeed related and it is exposing a hardware flaw then we may be the tip of a massive iceberg.
     
  7. samuelheinrich, Nov 12, 2017
    Last edited: Nov 12, 2017

    samuelheinrich macrumors newbie

    Joined:
    Sep 4, 2017
    Location:
    basel
    #82
    Welcome on the Bus, please take a free seat. j/k
    thanks for sharing your story and for that detailed analysis. it's sad to hear that there are more and more macbooks out there with this problem.

    did you tell apple the fact that there is countable number of user facing the same issue? and maybe refer to this forum thread?

    I don't think that the problem is related to hardware, since the issue seems to spread over different plateforms like MBP late 2015, MBP mid 2014, MBP 2013 and also MB Retinas. The only thing in common here is afaik that the problem started with sierra.

    in my case i did e fresh install from scratch and the problem occured right after the firsttime login, so I also don't think that is related to any 3rd party software.

    But good point though with that relation to IOS, because when i did a fresh install, the first thing it does is to sync with icloud... It would be interessting if the problem also happens if you do a freshinstall without syncing icloud.. but unfortunatelly i don't have the time to test that.
     
  8. crowhill macrumors newbie

    crowhill

    Joined:
    Nov 12, 2017
    Location:
    Dubai
    #83
    ok, so unfortunately I have to get on this bus too.

    I have a Mid 2014 MBP Retina with 2.5 GHz Intel Core i7, 16 GB 1600 MHz DDR3, NVIDIA and Intel Iris Pro graphics processors and currently running OS HS 10.13.2 Beta with an external Apple monitor.

    My sudden shutdowns started about 4 weeks ago, only happen when I am not connected to the power adapter and I don't think they are related to the battery charge level (I have shutdowns occurring at >90% charged). I haven't traveled with my MBP for the past 3 months, so the problem could have possibly already existed with earlier High Sierra versions, I just don't know because I never ran my MBP only on battery for the past 3 months.

    I am certain, however, that I never experienced sudden shutdowns with OS Sierra, only on High Sierra.

    I haven't taken my machine to Apple and probably won't. From what I have read in this thread and elsewhere on the net, I am quite sure that my sudden shutdowns are caused by a problem with Mac OS. I'll ride with my fellow passengers on this bus, contribute where I can and hope that we can together come up with some (more) good temporary fixes until Apple addresses the bug in an OS update in the hopefully not too distant future.
     
  9. bulatbulat48 macrumors newbie

    Joined:
    Nov 11, 2017
    #84
    Macbook pro 15, mid 2014
    MGXA2LL/A

    My results:
    1) new SSD - doesn't solve;
    2) new I/O board - doesn't solve;
    3) new Airport board- doesn't solve;
    4) Python script - machine does not shut down 2 days.
     
  10. nicoguzman macrumors newbie

    nicoguzman

    Joined:
    Oct 17, 2017
    #85
    [QUOTE="But good point though with that relation to IOS, because when i did a fresh install, the first thing it does is to sync with icloud... It would be interessting if the problem also happens if you do a freshinstall without syncing icloud.. but unfortunatelly i don't have the time to test that.[/QUOTE]

    Fresh install without iCloud sync does not work either.
     
  11. crowhill macrumors newbie

    crowhill

    Joined:
    Nov 12, 2017
    Location:
    Dubai
    #86
    I'm trying to run that Python script, but seem to be something wrong. I've downloaded Python 3.6.3 and followed the instructions in the pdf I got from your dropbox link (thanks, by the way!). When I restart my MBP, the attached error window pops up. Any suggestions what I might be doing wrong?

    Run Shell Script Erros.jpeg
     
  12. Tammytastic, Nov 13, 2017
    Last edited: Nov 13, 2017

    Tammytastic macrumors newbie

    Tammytastic

    Joined:
    Nov 13, 2017
    #87
    Please ignore my original post as I thought you were someone else
     
  13. Raul P. macrumors newbie

    Raul P.

    Joined:
    Nov 12, 2017
    #88
  14. bulatbulat48 macrumors newbie

    Joined:
    Nov 11, 2017
    #89
    try to open python (you can use python in terminal):

    python
    ..script..
     
  15. edubecks macrumors newbie

    edubecks

    Joined:
    Nov 14, 2017
    #90
    Hello all, I just signed up to report the same problems:

    MBPr 15" late 2013 and this problem started 5 days ago

    Already tried:
    - fresh install of macos high sierra
    - SMC reset
    - NVRAM reset
    - fresh install with low level format on hard drive (dd if=/dev/zero ...)
    - downgrade to macos sierra
    - not installing any application and work, crashes as well
    - hardware diagnostic test: all ok

    Maybe related:
    I used my macbook with an external trackpad and keyboard. After several fresh installs, SMC reset, NVRAM reset.
    they still keep appearing as paired devices on bluetooth preferences, I think there is something that is not being restored to factory defaults.

    I will try the python script as well and get back to you if it worked

    Thanks for all the info
     
  16. bulatbulat48, Nov 15, 2017
    Last edited: Nov 15, 2017

    bulatbulat48 macrumors newbie

    Joined:
    Nov 11, 2017
    #91
  17. bulatbulat48 macrumors newbie

    Joined:
    Nov 11, 2017
    #92
    the problem is easy to reproduce in PyCharm
     
  18. samuelheinrich macrumors newbie

    Joined:
    Sep 4, 2017
    Location:
    basel
    #93
    don't waste your money, it's literally the python script. it does not even start automatically on logon. you can recreate the "app" in 1min for free
     
  19. timbowaggins macrumors newbie

    Joined:
    Nov 26, 2017
    #94
    Wow.. so I'm not the only one with this EXACT issue! Thought I was going mad.

    Thanks for the Python script and all the help everyone. Managed to get it to work by changing the Shell: to the Python script... hope that's right? Is there a way to close the Shell window popup automatically on startup?

    I have a late MacBook Pro (Retina, 15-inch, Late 2013)... this only happened recently and I've tried all the usual steps. Went to the Mac store, tests came back fine and they cleaned the vents. Still crashed. Formatted and fresh install of High Sierra - same issue.
     
  20. Barry_Cooper macrumors newbie

    Barry_Cooper

    Joined:
    Dec 3, 2017
    Location:
    Herefordshire, UK
    #95
    Hi all
    I've spent the last week suffering from this issue on my MBPR (mid 2014). Since last sunday i have been suffering from random shutdowns. Been a real pain as i use my mac for my photography work - and having it shutdown mid-edit has been annoying to say the least.

    Anyway, having trawled the internet for solutions i came across this site and have read through all the posts.

    From my own experience, here is what i have gone through (in more or less chronological order)
    • Full system scan with ESET (as first thoughts were that it was a virus!)
    • Reset PRAM / NVRAM (many times)
    • Reset SMC (many times)
    • Created a ghost user account, and swapped to that - run a repair on my main user account
    • Booted into Apple diagnostics check - surprise surprise, no hardware issues
    • Booted to safe mode and run disk check (again no issues)
    • Booted to recovery mode and performed disk check
    • Removed software installs that were made following the High Sierra upgrade (Adobe CC - thought they might be the culprit).
    I also ran an etrecheck report, which showed nothing of any issue...

    None of this worked, so today i bit the bullet and performed a bare metal rebuild - Format & and fresh install of High Sierra.
    I thought that this had done the trick but then it froze and shut down again - so can say that a fresh install does not solve the issue at all.

    What is odd is, as well as having my MBP, i also have a MacBook 12" (the ones with the single USB-C port) - this too has been upgraded to High Sierra, however i have not suffered any issues with this at all. And i'm running virtually the same software set-up as my main mac.

    The one odd thing about the issue on the MBP that i have not seen clearly documented elsewhere is this.
    When i boot up, i get the select user piece, so chose my user (i have one main account, and one ghost account for testing) - fill in the password, then get the progress bar. It gets to half-way and then the whole screen goes black, and then the progress bar shows (just the bar, none of my background picture). When it completes, i get my desktop back as expected.
    Very odd - almost as if it is some issue with the GPU?

    Anyway, having read all the posts before this, i have gone with the python script "hack" as an interim to see if this helps any.
     
  21. Roman Switzerland macrumors newbie

    Roman Switzerland

    Joined:
    Dec 4, 2017
    #96
    Hello
    I also started to suffer from the random shutdown. I use a mid 2014 MBP 15,4" and OS X 10.12.6. I installed the latest incarnation of Sierra a while ago and hadn't had any problems. Suddenly after the installation of Scrivener 3 with eSellerate activation it started. First it occurred while watching a video on the new Firefox. So I first had Firefox under suspicion, then eSellerate. But a look into the logs revealed nothing further.

    I went through the usual steps like:
    - reset SMC
    - hardware check, no problems
    - uninstalling of recent software
    - removing every piece of unused software remains (old printers and the likes)

    Nothing helped until now, only the shell script / python script or booting into safe mode. The safe mode is no option because I need the computer professionally for writing and photo editing.

    If there is any better solution, I'm open to any and all suggestions.
     
  22. Barry_Cooper macrumors newbie

    Barry_Cooper

    Joined:
    Dec 3, 2017
    Location:
    Herefordshire, UK
    #97
    By way of an update to my post from earlier...
    Yesterday i gave my MBP a full workout, with some heavy duty image manipulation and rendering work, whilst having many other apps and processes running. Several times the fans ramped up to noisy levels, but i had not freezing and no crashes.
    So whatever this scripting "fix" is doing, it is doing it well. Just dont understand why it would make the difference between life and death on the Mac?
     
  23. maciek1422 macrumors newbie

    Joined:
    Oct 29, 2017
    #98
    There are more and more people with this problem, maybe we should write on apple forum with this problem and all of us will write something about it? I think we should show Apple that it is a bigger problem.

    I'm wondering all the time why this python script help us... It's incredible for me, but it definitely have influence on battery life :(
     
  24. OlegK0 macrumors newbie

    Joined:
    Dec 16, 2017
    #99
    Hi guys,
    Same problem as the most of you here, MBP15 Late 2013, High Sierra, shuts down every 2-5 minutes without any reason, no hardware issues. Been in the Apple Store - they found nothing.
    After reading this thread and trying different things (only Python script works in my case ) I think I found another way without creating any additional charge on the CPU and though no additional battery loss.

    Here's the link where a guy basically disables most of the drivers: usb, thunderbolt etc and after that no shutdowns MacOS.
    In my case when something is connected via Thunderbolt (screen, ethernet etc) MBP doesn't shutdown at all.
    So I took from the list of the drivers only Thunderbolt related ones (which start with "AppleThunderbolt") and it runs ok !
    But obviously I want to be able to connect external displays via Thunderbolt so I started enabling one after another to see if I can find one which causes problems and I think I found it (at least in my case).

    So if you disable (move out of /System/Library/Extensions) AppleThunderboltNHI.kext driver then reboot. Everything runs ok, you can connect external screens via Thunderbolt.

    The only drawback is that Ethernet via Thunderbolt will not work.


    PS : you can't just move kext driver files from /System/Library/Extensions even if you're root. You need to disable "csrutil" (just google it)
     
  25. Shurland macrumors newbie

    Joined:
    Aug 22, 2017
    #100
    Thanks what you advised seems to be working for me
     

Share This Page