High Sierra BURN IN / IMAGE RETENTION / GHOSTING issue!

imageWIS

macrumors 65816
Original poster
Mar 17, 2009
1,235
736
NYC
Hello,

Has anyone else had an issue with their MBP that after upgrading to High Sierra their monitor shows ghosting / image retention / burn in only minutes after an image is on the screen?? Is this an issue connected to Metal 2?

I had zero issues with my late 2013 MPB until I upgrade to High Sierra and then started to get this crazy issue. Any ideas how I can resolve it? I don't want it to permanently damage my retina screen...!

Thanks.
 
Last edited:

Audit13

macrumors 601
Apr 19, 2017
4,386
1,103
Toronto, Ontario, Canada
The ghosting is only appearing on an external monitor?

I use an external 1080 monitor with my late 2013 13" MBP running HS and I don't have the ghosting or image retention you have experienced.
 

imageWIS

macrumors 65816
Original poster
Mar 17, 2009
1,235
736
NYC
The ghosting is only appearing on an external monitor?

I use an external 1080 monitor with my late 2013 13" MBP running HS and I don't have the ghosting or image retention you have experienced.
It's appearing on the retina screen, but only after I upgraded to High Sierra. :-(
 

Camacorn

macrumors member
Dec 22, 2017
56
43
Ocala, FL
I don't have any burn-in issues, even if in use for an entire day. Granted I am using a 12" MacBook, it is a Retina Display, just figured I'd pitch in.
 
  • Like
Reactions: HenryDJP

imageWIS

macrumors 65816
Original poster
Mar 17, 2009
1,235
736
NYC
I did a fresh install of High Sierra and it's again happening, after a few minutes, there is a already ghosting of the default apple menu bar on top after only a few minutes... :-/
 

Crammy

macrumors newbie
Jul 25, 2018
2
2
I did a fresh install of High Sierra and it's again happening, after a few minutes, there is a already ghosting of the default apple menu bar on top after only a few minutes... :-/
Have to say iMac late 2012 upgraded to High Sierra - hit with the ghosting issue. Clean install of Mojave b3 public - still the same issue. After some reading and testing back to a clean Sierra install, it appears to an OS issue - Not the screen.

I don't understand why Apple hasn't fixed this already! Others have complained and being told by Apple its an IPS known issue and to live with it. If you have just spent over $7k for a new iMac Pro - I would have been mad as others.

So, I'll stop with Sierra on the iMac for now until its fixed.

BTW: Once you install High Sierra or higher - Apple removes the download link from the App Store for Sierra. This can be a pain downloading the old installer. If you use the following link - The hidden app is shown as normal: https://itunes.apple.com/au/app/macos-sierra/id1127487414?mt=12

Hope this solution help others.....
 
  • Like
Reactions: imageWIS