High Sierra Won't Unlock with Apple Watch

Discussion in 'macOS High Sierra (10.13)' started by kbajura, Jul 18, 2017.

  1. kbajura macrumors newbie

    kbajura

    Joined:
    Jun 8, 2017
    Location:
    Cary, NC
    #1
    After hearing that the Time Machine issue has been fixed in release 3, I tried the beta. And yes. That issue has been resolved for me.

    But does anyone know if "Allow your Apple Watch to unlock your Mac" is also disabled or broken? I had it working just fine before the Beta. But after the Beta, that open was turned off (it was checked before). When I try to check it I get this:

    Your Mac was unable to communicate with your Apple Watch.
    Make sure your Apple Watch is unlocked and on wrist, and your iPhone is unlocked.


    Of course it's unlocked and on my wrist.
     
  2. cmChimera macrumors 68040

    cmChimera

    Joined:
    Feb 12, 2010
    #2
    I had a ton of issues with it but eventually got it working. You might have to unpair your watch and re-pair.
     
  3. kbajura thread starter macrumors newbie

    kbajura

    Joined:
    Jun 8, 2017
    Location:
    Cary, NC
    #3
    shoot. I tried that and that didn't work. It's almost as if the first generation watch isn't compatible or something.
     
  4. cmChimera macrumors 68040

    cmChimera

    Joined:
    Feb 12, 2010
    #4
    I have a first gen watch, so that's definitely not it. I'm kind of unsure of how it started working. I just kept trying.
     
  5. TofSanity macrumors 6502a

    TofSanity

    Joined:
    Oct 29, 2010
    #5
    Mine isn’t working either. Also, Touch ID not working on mine.
     
  6. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #6
  7. tirby macrumors newbie

    Joined:
    Jul 20, 2017
    Location:
    Paris, TN
    #7
    --- Post Merged, Jul 20, 2017 ---
    updated apple watch to 3.2.3, now unlocks MacBook air
     
  8. hifismith macrumors newbie

    hifismith

    Joined:
    Dec 5, 2012
    Location:
    Houston
    #8
    Same
    --- Post Merged, Jul 20, 2017 ---
    I looked at my other admin account and everything seemed fine there. My Touch ID System Preferences is missing, but the other accounts are fine.

    I tried deleting my main account to restore the Apple Watch & Touch ID functionality only to find that I couldn't delete the account no matter how hard I tried: Root couldn't, turned off fast switching, was logged out, Single-user startup failed to load.

    What else have people tried.
     
  9. lesliesj715 macrumors newbie

    lesliesj715

    Joined:
    Jul 21, 2017
    #9
     
  10. Tomaj40 macrumors newbie

    Tomaj40

    Joined:
    Aug 13, 2017
  11. Krit04 macrumors newbie

    Krit04

    Joined:
    May 23, 2016
    #11
    Me, too. By Apple Watch Gen 2, it's not work with my MacBook Pro 2017. Touch ID is working.
     
  12. ersan191 macrumors regular

    Joined:
    Oct 26, 2013
    #12
    Not working for me with GM Candidate and a new Series 3 with WatchOS 4 (On MBP Late 2013)

    Been trying to troubleshoot it for an hour or so and not making any progress.
     
  13. bradley8795 macrumors member

    Joined:
    Sep 19, 2013
    #13
    Mine works. New series 3 LTE and 2017 TB 13”
     
  14. jbachandouris macrumors 601

    jbachandouris

    Joined:
    Aug 18, 2009
    Location:
    Upstate NY
    #14
    I had the same issue this morning. Rebooted the MBP and now it's working.
     
  15. ersan191 macrumors regular

    Joined:
    Oct 26, 2013
    #15
    Yeah I tried 40 different things and eventually it started working, all I remember is the last thing before it worked was logging out and back into iCloud on the mac.
     
  16. Ossyref macrumors newbie

    Joined:
    Apr 21, 2015
    #16
    I am having issues getting unlock with Apple Watch to work.

    It worked on Sierra but I can't get it to activate now. Is anybody else having the same issue?

    I have Apple Watch first generation and High Sierra public release.
     
  17. deany macrumors 68030

    deany

    Joined:
    Sep 16, 2012
    Location:
    North Wales
    #17
    Have you force restart both apple watch and iPhone?
     
  18. iJohnnyG macrumors regular

    Joined:
    May 7, 2011
    Location:
    Newcastle
    #18
    Having the opposite for me, I've never been able to unlock my late 2015 27 5K iMac, yet since HS update it now works flawlessly. Hope you get it sorted, spent a lot of time trying to get it work in the last OS.
     
  19. elemenohme macrumors regular

    Joined:
    Nov 6, 2014
    #19
    When I set up my new Series 3 watch with Sierra, the Mac wouldn't let me select it to unlock, even thought my Series 0 watch worked fine.

    After upgrading to High Sierra yesterday, I can now set the Mac up to unlock with the Series 3 watch, but it doesn't work. The Mac gives me the "unlocking with Apple watch..." message and then displays the password prompt :(

    Has anyone had success getting this to work? I've unpaired and repaired the watch and restarted the Mac, all to no avail.
     
  20. realpras macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #20
    I'd say the feature itself has 50/50 chance of being working. I don't have the issue in particular, sometimes it unlocks, sometimes I have the same "unlocking with Apple watch..." message and then displays the password prompt" issue as well. And I kinda expect that, it's just not reliable enough; just like Handoff & Personal Hotspot features, sometimes it works, sometimes it doesn't. These fancy iCloud features haven't been 100% reliable in my experience.
     
  21. elemenohme macrumors regular

    Joined:
    Nov 6, 2014
    #21
    FYI, this now works with Watch OS 4.1 beta, so it looks like there was something awry in the released version.
     
  22. mabaeyens macrumors newbie

    Joined:
    Jan 11, 2012
    #22
    Good to know. AW Series 1 here, working fine with a MBP 15" and 10.12, but after upgrading all iOS, watchOS and macOS shows "it cannot unlock" or directly prompts for password.

    Tried almost everything as the Belkin Thunderbolt USB hub was causing issues exactly with Bluetooth.

    Will wait for 4.1 then or give a try to the beta
     
  23. HeadphoneAddict, Oct 2, 2017
    Last edited: Oct 3, 2017

    HeadphoneAddict macrumors regular

    HeadphoneAddict

    Joined:
    Sep 16, 2007
    #23
    My previous Series 2 Apple Watch with WatchOS 3.2.2 would unlock my 15" MacBook Pro just fine with Mac OS X Sierra 10.12.6 (not high sierra) (and iPhone 7+ with IOS 10.3.3 with no issues).

    I had to update my iPhone 7+ to 11.0.1 to use my new Series 3 Apple Watch with LTE, same Mac OS, and now my computer won't unlock and give me the following error message, "Update your Mac’s software to allow your Apple Watch to unlock your Mac."

    But it worked before and there is no update for Mac OS out yet, yet the error says I can't unlock my Mac now until I update. I've rebooted the phone, watch and Mac, but nothing helps.

    Any suggestions that don't include the following? (I just can't unpair my new Apple Watch after all the hell I went through to activate the LTE, and it's a pain to sign out of iCloud and back in on any device when it removes all my data and has to download everything all over again.
     
  24. AlliFlowers Contributor

    AlliFlowers

    Joined:
    Jan 1, 2011
    Location:
    L.A. (Lower Alabama)
    #24
    I could never unlock my Mac with my series 0 until updating to HS. Worked fine until this morning. Now my Mac tells me it needs a password in order to unlock it with my watch. What? Either I enter the pw to unlock, or I use the watch.
     
  25. thirdeyeopen666 macrumors 6502

    thirdeyeopen666

    Joined:
    Sep 16, 2007
    #25
    Anyone else seeing where the unlock with apple watch box unchecks itself at random?
     

Share This Page