HomePod HomePod stereo pairing not working with iOS 12

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by nico887, Sep 18, 2018.

  1. nico887 macrumors newbie

    Joined:
    Sep 18, 2018
    #1
    Hello,

    I have just upgraded my 2 HomePods to iOS 12, but now process to set-up stereo pairing doesn't work anymore.

    HomePod Stereo was working fine with IOS 11.4.

    I have done factory resets, tried several combinations to have this stereo set-up, with iPhone, iPad, etc. but iTunes never not able to detect my stereo pairing.

    Has anyone encountered the same problem following iOS 12 homePod firmware update ?

    Thank you for your advices,

    Kind regards,
    Nicolas
     
  2. Mpalmieri1203 macrumors member

    Joined:
    Jul 4, 2007
    #2
    This same thing is happening to me. It is extremely frustrating.
     
  3. nico887 thread starter macrumors newbie

    Joined:
    Sep 18, 2018
    #3
    Hi Mpalmieri1203, thank you very much for your feedbacks.

    I fear this is an iOS 12 bug.

    I have contacted Apple support. They are investigating the problem, they took all my serial number devices and they said they will come back to me today. I will let you know.

    Another member told me to try with IP address reservation for the HomePod, rather than dynamic address. I will try this turn around tonight and will let you know.
     
  4. Mpalmieri1203 macrumors member

    Joined:
    Jul 4, 2007
    #4
    Great. I appreciate that. I don’t think there are too many people running more than one or two of these. I’m using 8 and my system is completely screwed up.
     
  5. nico887, Sep 21, 2018
    Last edited: Sep 21, 2018

    nico887 thread starter macrumors newbie

    Joined:
    Sep 18, 2018
    #5
    Hi Mpalmieri1203, thank you for your message.

    Here are the latest news : I had 2 new exchanges with Apple Support : they are still investigating the problem - they went through a check list with me -, but at this stage, they did not confirm that the problem was global and related to iOS 12.

    They say that their engineers were still investigating, but no solution at this stage. They will recontact me on Monday morning. I will let you know.

    Macrumors forum members, if you have this same problem, please leave a reply. Thanks a lot !
     
  6. lazypoet macrumors regular

    lazypoet

    Joined:
    Jun 9, 2015
    #6
    IP address reservation fixed a lot of my bugs with homepod! Some of my bugs included :

    - Sudden loss of connection
    - Stereo pair not showing up on Apple TV
    - Stereo pair getting ungrouped
    - When asking for a song by voice while connected to the Apple TV, it would play one song on one of the homepods while continue another song on the other.
     
  7. chabig macrumors 601

    Joined:
    Sep 6, 2002
    #7
    I had stereo pairing set up with iOS 11 and the update to iOS 12 didn't change anything. Did you lose the stereo pairing during your iOS 12 update?
     
  8. nico887, Sep 22, 2018
    Last edited: Sep 22, 2018

    nico887 thread starter macrumors newbie

    Joined:
    Sep 18, 2018
    #8
    Hi, thank you all for your feedbacks and advices.

    I have just spent 3 hours renewing the HomePod network configuration with IP address reservation. Unfortunately, nothing has changed. Declaration of 1st HomePod is flawless - it takes less than 30 seconds - I can see and use this standalone HomePod in Airplay. No problem.

    But when I declare the 2nd HomePod with Stereo pairing, it takes forever - more than 4-5 minutes - it seems to end properly, but I can't see them in airplay via iTunes. It happens that sometimes I see the paired HomePod, but iTunes cannot connect to them. Of course, before every tries, I have factory reseted my HomePods...

    I will not wait for Apple engineers feedbacks - they say they will can me on Monday morning -. I will go to an Apple Store tomorrow morning and buy 2 new ones. I will block 12.0 update and try to do the stereo pairing in 11.4 and we will see.

    I will let you know. Again thank you all for your messages.
     
  9. firewire9000 macrumors regular

    Joined:
    Sep 15, 2015
    #9
    Wow thank you!! I have the same problems with my HomePod, at this point I’m used to constantly restart them and I blame to my router. I’ll try it, I hope this resolves the problem.
     
  10. nico887 thread starter macrumors newbie

    Joined:
    Sep 18, 2018
    #10
    Hi All,

    I have made considerable progress today and I can confirm that this problem is indeed iOS 12 related.

    I went this morning to my Apple Store : I explained my problem to an apple representative, who happens to be the store manager. He was very helpful and supportive with my proposal : that is to say buy 2 new HomePods (still with iOS 11.4, block iOS 12 update and try stereo pairing.

    I went back home and ... everything worked perfectly with my 2 new iOS 11.4. HomePod Stereo pairing went flawless.

    The Store manager refunded me my old bricked iOS 12 HomePods. Again thank you Apple for having such a good client relationship.

    So now, updates on my HomePods are blocks until the release of a patch. I will report this to Apple support Monday morning and will let you know if they give me new information such as an upcoming patch.

    Hope its helps.
     
  11. nico887 thread starter macrumors newbie

    Joined:
    Sep 18, 2018
    #11
    Hi All, this message to give you the latest news.

    I had 2 new discussions with Apple support this week. They said they are still investigating, but at this stage, they did not confirm the root cause (iOS 12), neither if a patch was to be releases soon.

    I am still on 11.4 (iOS 12 is blocked), the Mojave update - and iTunes 12.9 - did not impact anything.

    Any news from your side ?
     
  12. kschles macrumors regular

    kschles

    Joined:
    Apr 3, 2008
    #12
    I recently moved, and set up my three homepods in my new house. I updated to IOS 12 on my iPhone and iPad (use both to control homepods). After reading this thread, I checked, and my homepods had all updated to IOS 12 automatically. No problem with stereo pairing. I actually now use three homepods in my quite long living room/dining room combo. Two are paired (centered in living room area), and another is in the dining area. The work well separately, or playing all three at once.

    Not everyone is having IOS 12 problems.
     
  13. nico887 thread starter macrumors newbie

    Joined:
    Sep 18, 2018
    #13
    Hi kschles,

    Thank you for your valuable feedbacks. This problem is indeed not systematic.

    I can tell you that I have spent several days trying to do stereo repairing again of my iOS 12 Homepods without success. Going back to 11.4 instantly solved the problem. I also see that I am far to be the only one.

    I will take the risk to upgrade to iOS 12 when Apple will release an update - like it has been done this week with Apple TV. (12.0.1).

    Again thank you for your message kschles.

    Macrumors forum members, if you have this same problem - or not -, please leave a reply. Thanks a lot !
     
  14. firewire9000 macrumors regular

    Joined:
    Sep 15, 2015
    #14
    Did you try with another network? I don’t know if it’s my router or what but I was not able to have my stereo pair working in the 5 Ghz network, only with the 2 Ghz one. Neither with 11.4 nor 12.
     
  15. nico887 thread starter macrumors newbie

    Joined:
    Sep 18, 2018
    #15
    Hi firewire9000, thank you for your message. No, I have not tried another network, knowing that it was perfectly working with my current router in 11.4.

    My router is an AirPort Extreme with both 5 and 2,4 Ghz activated. I assume that Homepods are fully compatible with the AirPort Extreme and that they will choose the best wifi network.
     
  16. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #16
    If I asked the HomePod to play something with Hey Siri via Apple Music it would play stereo just fine.

    If I played music from my iPhone 6S (iOS 12) via AirPlay (from the phone not controlling the HomePod) it only plays on one.

    To fix it, at least temporarily. I AirPlayed a song from my iPhone, went to the speaker that wasn't work and tapped on it to play. It started playing a different song from my library than the other HomePod was playing. Then the other one started playing the new song. I went back to the phone and airplayed to it again and it stuttered around for a brief second and now its working. Switching everything around and currently its working as well as it was in iOS 11.

    I also have an AirPort Extreme and something strange has been going on with it. I've never had to power cycle it or disconnect and reconnect to wifi however recently its been flakey...
     
  17. todd61968 macrumors newbie

    Joined:
    Oct 2, 2018
    #17
    Has anyone heard anything else on this problem? I too can't pair my homepods in stereo on ios 12. I've done everything correctly. Speakers pair but only play out of one speaker.
     
  18. Zimmy68 macrumors 68000

    Zimmy68

    Joined:
    Jul 23, 2008
    #18
    I'm on ios12 (iPhone X) and fully updated HomePods. I listened to them in stereo all weekend.
     
  19. H3LL5P4WN macrumors 65816

    H3LL5P4WN

    Joined:
    Jun 19, 2010
    Location:
    Pittsburgh PA
    #19
    I may have a related issue. Since 12, my HomePods will either drop out of stereo pairing at random or even drop all together.

    I use them primarily as stereo speakers connected to the Apple TV 4K.
     
  20. cap7ainclu7ch macrumors 6502

    Joined:
    Jun 30, 2010
    #20
    Not having that issue but my right one decided to be the Siri primary instead of the left one, which it was before the update. Seems fine otherwise.
     
  21. tromboneaholic macrumors 68000

    tromboneaholic

    Joined:
    Jun 9, 2004
    Location:
    Clearwater, FL
    #21
    This happens to me all the time watching shows on the NBC app. The HomePods will disconnect when the commercials come on, and not connect after the commercials unless I select the stereo pair again.
     
  22. H3LL5P4WN macrumors 65816

    H3LL5P4WN

    Joined:
    Jun 19, 2010
    Location:
    Pittsburgh PA
    #22
    I don't think it's quite the same issue. I've noticed that when navigating the menu or an app's menu, the sound is via HDMI (my TV). It isn't until the actual content starts playing (be it YouTube, a movie, Hulu, etc) that the sound is routed to the HomePods. I guess this activity is normal?

    What my issue is, is that the HomePods seems to literally be losing their stereo pairing, meaning I have to remove it on my iPhone then recreate it, then direct the sound back to the newly created pair on my Apple TV. The Apple TV also displays a message stating that connection has been lost.
     
  23. ibarnett macrumors regular

    ibarnett

    Joined:
    Aug 20, 2010
    Location:
    Gold Coast, Australia
    #23
    I have only last week purchased a second HomePod, when working, the sound is greatly improved.
    However I am having problems with the Pods losing sound on one, happens intermittently & they reconnect themselves for a while then the same happens. I have tried complete resets, initialise & repairing, to no avail.
    I have contacted Apple Support, but no fix yet.
    Sample of my log sent to them:
    Times are approximate, with no user intervention or interaction, i.e. just initiate music & then let the pods do their own thing.
    Number of pods working in brackets (1) or (2).
    Saturday:
    System on @ 5:20
    5:20 (2)
    7:30 (1)
    7:45 (2)
    8:55 (1)
    9:25 (2)
    10:55 (1)
    11:07 (2)
    11:45
    Turned off
    Sunday:
    7:20 (2) turned on
    7:40 (1)
    7:55 (2)
    8:40 (1)
    8:55 (2)
    9:30 (1)
    10:00 (2)
     
  24. nico887 thread starter macrumors newbie

    Joined:
    Sep 18, 2018
    #24
    Hi All, thank you very much for your feedbacks, sorry for my late answer.

    I see that this HomePod stereo pairing bug is not systematic as some of you are not impacted at all by the iOS 12 upgrade. Additionally, other member testimonies show that this upgrade has messed up their stereo configuration, making it instable or not working at all.

    -- Cynics, when I was in iOS 12, I had the exact same symptoms.

    As of today, my HomePods are still in iOS 11.4 and they are working fine.

    No feedbacks from Apple support, but I have talked recently to an Apple Store member : he was testing iOS 12.1, we checked that his HomePods were in iOS 12.1 and he said that everything was working great.

    So I suggest we continue to give feedbacks to Apple and wait for iOS 12.1 release, hoping that it will contain the expected fix.
     
  25. ibarnett macrumors regular

    ibarnett

    Joined:
    Aug 20, 2010
    Location:
    Gold Coast, Australia
    #25
    Mine are now working perfectly.
    Why? Well, I'm not really sure......
    I changed my WiFi from a single Asus RT-AC88U connected through a Draytek ADSL modem to a Asus DSL-AC68U then Aimesh to the original 88U.
    No visible signal differences in the same relative positions of Router & HomePod, however has now been working paired perfectly for 4 days!:)
     

Share This Page