How To: Enable AirPrint on Windows (32/64Bit) with iOS 5+ Support

Discussion in 'iOS 5 and earlier' started by JasonHD, Dec 19, 2011.

  1. JasonHD, Dec 19, 2011
    Last edited: Jul 1, 2012

    JasonHD macrumors regular

    Jul 23, 2010
    *V.2 now supports both 32/64Bit* Working on iOS 6
    (Download source link no longer works and has been removed from this post, download the attached .zip file below as an alternative!)

    Hello :D,

    The program “AirPrint Installer” enabled windows users to install the AirPrint service. This allowed iOS devices to print to shared printers on the network, via AirPrint, that don't natively support it. However, iOS 5 broke this neat windows service.

    I have made two .reg files (32/64Bit) to fix the AirPrint service, allowing iOS 5.x devices to use AirPrint through a Windows PC. I have attached a zip file containing both .reg fixes and the installer.


    After extraction you should have three files:
    - "AirPrint_Installer.exe"
    - "AirPrint iOS 5 FIX - 32Bit.reg"
    - "AirPrint iOS 5 FIX - 64Bit.reg"

    1. Run "AirPrint_Installer.exe" and then click on "Install AirPrint Service".

    2. Run the "AirPrint iOS 5 FIX - 32Bit.reg" or "AirPrint iOS 5 FIX - 64Bit.reg" to install the iOS 5 fix (Choose the correct file for you operating system, 32 Bit or 64 Bit Windows).

    3. Go back to "AirPrint_Installer.exe", make sure "Service Startup" is set to "Auto" and click "Start".

    4. Restart computer.

    If there is a locked icon next to the printer on the iOS device enable the guest account in windows (Control Panel > User Accounts > Manage Another Account > Turn the Guest Account on). Then in the "AirPrint_Installer.exe" choose to use Guest Account Auth and tick the "Enable Guest Account" box. Then click "Update". You will then need to restart. If you want windows to automatically log you in on startup, type "netplwiz" into the start menu search box, hit enter. Uncheck the box that says “Users must enter a user name and password to use this computer”, and then hit Apply. You’ll see a username and password box. Enter in the appropriate information here and hit OK..

    I hope people will find this helpful, please spread the word...


    JasonHD :)

    Credits for the Installer .exe file go to

    Attached Files:

  2. Ashwood11 macrumors 65816

    Nov 10, 2010
    Thanks, I'm sure many members will find this very helpful.
  3. kflack macrumors newbie

    Jun 3, 2011
    If a Lock Symbol Appears in the printers

    I tried the solution above and the Printers mysteriously re-appeared in the available printer window on the iPad.

    When selecting the printer it had a LOCK symbol preventing it from being selected.

    I enabled the guest account on the windows 7 machine.
    I edited the AirPrint Service (Windows Manager) and enabled login with a valid account.

    The locks disappeared....And Printing worked...

    Will verify if enabling Guest is sufficient.....
  4. DocMartin macrumors newbie

    Dec 13, 2011
    tried to download

    I just tried to download with Firefox. It downloaded but then my pc acted strangely. I could not move the mouse to the task bar or click on anything else.
    I had to turn off the pc in order to restart.
    Anyone else experience this?
    Perhaps a hacker got into the website or I had a conflict present on my machine. I will try using IE.

    Will your fix enable any network printer work or only airprint printers?

  5. DocMartin macrumors newbie

    Dec 13, 2011
    I used your zip file and installed it.
    After it didn't work, I realized that I have an ethernet printer not attached to my pc. Therefore airprint software on the printer can't "enable" the printer.
  6. takeshi74 macrumors 601

    Feb 9, 2011
    Thanks for doing this! I've been trying to avoid paying for and dealing with FingerPrint.

    It sure can. I've been using this to print to an HP LaserJet 2300DTN (has an internal JetDirect print server) on my network. You may need to set up the printer as a local printer (using TCIP/IP port) which is what I have done.
  7. JasonHD thread starter macrumors regular

    Jul 23, 2010
    Yes this ^^^ make sure the printer is being shared via the pc you install on.

    Any network printer. There is nothing wrong with the download. It must be your pc.
  8. Ristin macrumors newbie

    Oct 11, 2011
    I tried this and get an error when trying to start the Air Print service. Error 1075 Dependencies missing or selected for deletion. Any ideas?
  9. JasonHD thread starter macrumors regular

    Jul 23, 2010
    Hmmm... Do you have 32bit windows? Make sure you install it when on the administrators account and you run it as administrator. You need latest iTunes and bonjour services installed and running too. Hope that helps.
  10. Ristin macrumors newbie

    Oct 11, 2011
    Thanks JasonHD. I totally forgot I don't have iTunes on that machine anymore. I'll try that when I get home.
  11. RickGowins macrumors newbie

    Dec 22, 2011
    Thanks for doing this for everyone....unfortunately I still can't get it.
    Running 32bit XP, Itunes & BonJour services running, working from Admin.

    Airprint was working great prior to IOS 5. After I ran your AirPrint Installer, the "Install AirPrint Service" button was gray, so I assume it found the old installation. After Airprint wouldn't work, I hit the "Remove Airprint" button, then the "Install Air..." button thinking this might activate a sleeping service.

    Have tried all 3 of the AirPrint Auth settings.. Windows User Acct, AirPrint, & guest rebooting after each change.

    All I've managed to do is deactivate AirPrint for my wife who didn't upgrade to IOS 5 on her phone.

    Any thoughts?

  12. takeshi74, Dec 22, 2011
    Last edited: Dec 22, 2011

    takeshi74 macrumors 601

    Feb 9, 2011
    Resolved above but... The message indicates the issue. The AirPrint service is dependent on the Bonjour service (installed with iTunes).

    Check to see if the AirPrint service is running. If it isn't try to start it. If it can't start then fire up Regedit. You're looking for \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AirPrint. Click on it and edit the ImagePath value. The AirPrint installer above seems to assume you're on a 64 bit system. Change ImagePath by removing the (x64) in its Value Data.

    In other words, change:
    C:\Program Files (x86)\...

    C:\Program Files\...

    Had this problem when I was setting it up on my 32 bit system.
  13. RickGowins macrumors newbie

    Dec 22, 2011
    Takeshi74...great advise !

    Getting Close...
    Changed the value in the Regedit & now the printer shows up, but the lock icon is there & it won't print. When I tap "print" on the phone it seems to go through the motions & I get a message that the doc was sent to the printer, but then the print screen on the phone closes & nothing happens at the printer. When I check the printer status in the control panel it registers 0 docs pending. Printer definitely on & connected to computer...can print from computer. Sharing set. Firewall exception for airprint set.
    Have gone through all the AirPrint Auth choices, including "password blank"..(reboot each time) nothing works.

  14. JasonHD, Dec 23, 2011
    Last edited: Dec 23, 2011

    JasonHD thread starter macrumors regular

    Jul 23, 2010
    I have updated the attachment for both 32/64Bit support.

    Have you enabled the guest account on windows?

    Click start > Click on your picture to go to User Accounts > Click on manage another account > Click on the Guest account > Turn it on.

    Now, make sure Guest Account Auth is selected and Enable Guest Account Box is ticked in the installer window. Click on update and restart you computer. The lock icon should now have been removed on your iOS device and will now allow you to print.
  15. Lyons00 macrumors 6502a

    Dec 9, 2010
    Bay Area, California
  16. JasonHD thread starter macrumors regular

    Jul 23, 2010
    Good to hear it!
  17. RickGowins macrumors newbie

    Dec 22, 2011
    Nice Job! That was it. Everything working.
    Thanks much.
  18. irDigital0l Guest

    Dec 7, 2010
    I'll try this!

    Thanks! I dont really want to spent $100 to buy an airprint enabled printer and Apple really needs to increase the # of printers that airprint can support.

    Looks like I found a solution to all this mess!
  19. rasputinj macrumors regular

    Sep 25, 2007
    Thanks it works great for me on 32 and 64 bit
  20. irDigital0l, Dec 23, 2011
    Last edited: Dec 23, 2011

    irDigital0l Guest

    Dec 7, 2010
  21. atscntsc, Dec 23, 2011
    Last edited: Dec 23, 2011

    atscntsc macrumors newbie

    Dec 23, 2011
    I recall that on pre iOS5, the user name and password of the account sharing the printer would be prompted on the iOS device, thus not requiring a Guest account. That seems to be no longer true.

    Thumbs up to the OP for getting AirPrint working on Windows!
  22. Ristin macrumors newbie

    Oct 11, 2011
    Finally got this working tonight. I couldn't get the Airprint service to start using the guest account. It would start with the log in set to the local account and my iDevices would find the printer and send stuff to it, but nothing would print. Changed the log in to the computer name and my password and now it prints like a champ.
  23. inanis macrumors newbie

    Dec 27, 2011
    Support for Windows Server 2008 R2 Standard 64-Bit?

    Any help for a fellow running Windows Server 2008 R2 Standard Service Pack 1 x64, running Active Directory as a Domain Controller?

    Came across these instructions after getting an iPad 2 with iOS5 and found my old installation of AirPrint didn't work anymore (printers didn't show).

    I ripped out my entire AirPrint Install, downloaded your zip. Ran the installer. Ran the Reg File. Did the Use Guest Account thing in AirPrint Auth, and hit the Enable Guest Account check mark then hit update.

    I get my printers listed now, but I get a lock.
    Double-checked everything. Still a lock. Manually enabled the Guest Account in Active Directory. Still a lock. Ripped it all out, rebooted, re-installed it, rebooted. Still a lock. I tried to change the service manually to log on as a guest, but when I do that, the service won't start.

    On a whim, I added the Guest account to the Administrators group and set the service again to use the guest account. That allows the service to start, but I still get a lock on the iPad. (Not to mention it's a total security no-no).

    Can I set this all up on my high end power hungry video editing Windows 7 machine and bypass this craziness? Yeah, probably. Do I want to leave my high end power hungry video editing Windows 7 machine running all the time just to print from an iPad when I have a perfectly capable low power server that should be able to do the same thing. Not really.

    Maybe the new solution is just not compatible with Active Directory. Maybe that's the real reason Apple changed it the way they did - not to hurt end users, but to block out corporate users? (I'm not a corporate user, BTW, just a nerd with a Windows Server).

    Please don't take the last paragraphs as snarky or unappreciative. I really do appreciate the work done to make this stuff work, and also any thoughts, insight or assistance anyone can give me, especially because I'm not really sure what I'm doing (or doing wrong) here!
  24. JasonHD thread starter macrumors regular

    Jul 23, 2010
    So you have tried enabling the guest account though windows instead of the installer?
  25. dcook1237 macrumors newbie

    Dec 28, 2011
    Lock still there

    I installed this and the registry fix and the printer now shows up on the IPad. I however still have the lock. I tried enabling guest and rebooting and I still have the lock.

    I'm using Windows 7 (64 bit), any other suggestions. My computer does not have multiple accounts. It logs in automatically on boot up.

Share This Page

234 December 19, 2011