How To: Enable AirPrint on Windows (32/64Bit) with iOS 5+ Support

Discussion in 'iOS 5 and earlier' started by JasonHD, Dec 19, 2011.

  1. hchavarria macrumors 6502

    Joined:
    Oct 8, 2008
    #51
    This worked perfectly for me but is there a Mac version of this? I just bought an iMac and am trying to transition over.
     
  2. luckman212 macrumors newbie

    Joined:
    Sep 27, 2009
    #52
    Worked great! Win7 x64 -sp1, iPhone 4S 5.0.1, generic Brother inkjet printer. Cheers to JasonHD for sharing this! :eek:
     
  3. greyskymedia macrumors newbie

    Joined:
    Jan 17, 2012
    #53
    close, but...

    My ipad and iphone are both trying to connect but i'm getting back printer is offline. any thoughts?
     
  4. greyskymedia macrumors newbie

    Joined:
    Jan 17, 2012
    #54
    Well, i was able to get them available by clicking around and messing with things. Now my label printers just can't print. I have a feeling that that is because the stock and safari aren't jiving... SIGH... onto the next hack...
     
  5. mprater macrumors newbie

    Joined:
    Jan 18, 2012
    #55
    I am running Windows xp 32 bit, bonjour service is running, itunes is loaded. I have checked the registry and it points to c://program files/airprint (no x64). When I go to services and try to start airprint it says : could not start the AirPrint service on local computer. Error 21: The device is not ready. Any ideas what this could be? I have also tried to start it within the airprint program also.
     
  6. planteg, Jan 20, 2012
    Last edited: Jan 21, 2012

    planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #56
    Print jobs stuck in the iPhone

    Hi,

    was I happy to find out that AirPrint was working on iOS 5. Unfortunately my happiness turns short :(.

    I had to tell AirPrint to use the Guest account in order to get rid of the locked icon - I don't like it since there is no password on this account - this is not secure at all. Is there a way to have access to printers without using Guest ? I tried everything with no luck.

    Anyway, since I could pick my printer, I was confident it would work. Well it doesn't. The print jobs get stuck in my iPhone.

    What have I done wrong ? My computer is brand new, running Win 7 Pro x64, and the AirPrint service is started. I tried also on my old computer the new one will replace, it didn't work either. Since its knows that it will be put to rest, it does not cooperate a lot :p.
    ________________________________

    Oh boy, am I shameful and mad at me :mad:.

    It does work. Yesterday when I tried, the printer was connected to the old computer, not the new one I am preparing. This morning I connected it to the new computer, turned it on and gave a try. Both the iPhone and iPad prints, with the service connected with the system or my account.

    Thanks a lot for this tweak :eek:.
     
  7. Richdmoore macrumors 65816

    Richdmoore

    Joined:
    Jul 24, 2007
    Location:
    Troutdale, OR
    #57
    I use printopia on my Mac to allow AirPrint on legacy printers, it works great but is not free.

    http://www.ecamm.com/mac/printopia/
     
  8. luckman212 macrumors newbie

    Joined:
    Sep 27, 2009
    #58
    Anyone else having the problem where after some time (hours, days?) the Airprint service just needs to be stopped & restarted in order to start working again? I tried running it as "Local System" as well as an Administrator user on my system- didn't make a difference. As soon as I restart the service everything is perfect again until ... it's not. Then I just "kick" the service and it's all back to working. Weird. Guess it's just buggy!

    Annoying thing is the service is still "Running" so there's no way to even make a script to check & restart the service if it crashes. It has to be done by hand. :(
     
  9. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #59

    I assume you leave that machine on 24x7? Just write your script to restart it every day at 2am or so, don't check for a failure.
     
  10. mdntblu macrumors member

    Joined:
    Aug 14, 2004
    #60
    inanis:
    Have you been able to get it to work yet? I have the same 2008 server with the same configuration and have been trying to get it to work. Haven't been able to. Seems that people have luck on Server 2003 (http://www.howardforums.com/showthread.php/1751615-AirPrint-not-working-for-me) but not Server 2008.
    I might just install Windows 7 on my server room desktop that I use and just run it on there. I was able to get it to work fine at my house on my wife's Win7.
     
  11. ngzuwi macrumors newbie

    Joined:
    Jan 29, 2012
    #61
    amazing patch

    I use ios 4.2 before, and the airprint disfunctioned after the machine is upgraded to 5.0.1

    simply install the '.reg' file, and the airprint worked again!!
     
  12. personsd macrumors newbie

    Joined:
    Jan 29, 2012
    #62
    Easy as 1, 2, 3

    I'm running a Ubuntu 64bit Linux server hosting Windows 7 Ultimate 64bit using Oracle's VirtualBox. I have 2 Non AirPrint printers. A networked Brother HL-3040CN Color Laser and an Epson Artisan 800 Wireless Ink Jet. Following the instructions for installing on Windows 64bit, I ran the AirPrint Install Service then the Registry Update (That's always a bit scarry messing with the Windows registry) and Rebooted the Win 7. After the reboot as I shared each printer on the Windows box they appeared in my IPAD2 IOS 5.0.1 printer list, but were locked. I enabled the Windows Guest account, ran the AirPrint Install program, checked Enable Guest Account and clicked Update. When I clicked STOP then START on the AirPrint Installer the Locks went away and I can print to either printer from the IPad. Good By Fingerprint which was printing in big block letters "This copy of FingerPrint is not licensed" on each page I printed.
     
  13. waveryder macrumors newbie

    Joined:
    Feb 1, 2012
    #63
    Important Question

    Can you not use the Guest Account and just have another login or use your own if the lock comes up??

    Thankyou
     
  14. TioP macrumors newbie

    Joined:
    Feb 2, 2012
    Location:
    California, US
    #64
    You won't tell until someone breaks into your computer using this password-less account. Then you will regret that you enabled it.

    -TioP

    ----------

    Truly, this free AirPrint solution would be optimal if it didn't have to use the Guest account, described everywhere as a security risk. I see nothing wrong about having to type a user name and a password on the iPad once to connect to the printer if it remembers them for the next time.
    -TioP

    ----------

    interesting what makes my new Epson printer a "legacy" printer ... is it Apple's 'AirPrint' scam in association with printer makers to sell more printers because my just-purchased printer is not AirPrint that makes it "legacy"?.

    Pardon me, but Apple doesn't decide what is 'new', 'cool' or 'modern' for me, as much as Apple fans would love to believe that.

    What would be 'cool' for Apple and their co-scammers is quickly abandon this stupid 'development'. We have been doing network printing for years and the mobile devices can connect to local networks without a problem. No need for 'AirPrint' novelties anywhere.

    -TioP
     
  15. janvandessel, Feb 7, 2012
    Last edited: Feb 8, 2012

    janvandessel macrumors newbie

    Joined:
    Feb 7, 2012
    #65
    Brilliant solution - many thanks

    Followed all the instructions, had to download latest iTunes on to my windows 7 laptop which included Bonjour. Enabled guest user account via Windows 7 > Control Panel.

    Printing from my iPad 2 in about 30 mins in total (and I did lose a lot of time before I realised the laptop needed iTunes). Reckon I would have been up and running in about 5 mins otherwise. Printing from my iPhone as well :)

    Thanks you JasonHD for a fantastic original post and for all who added.

    Was on verge of buying an HP AirPrint enabled printer until I found this post. New there had to be a better way than having another printer in the house!!

    Will certainly share this link!
     
  16. mazerlui macrumors newbie

    Joined:
    Feb 8, 2012
    #66
    don't work for me

    Hi everybody
    First, excuse me for my english, i'm french... ;)

    I try to install airprint on my computer on Windows XP SP3. I have the latest iTunes update, and I have done all the instructions, but I have no print found on my ipad...
    I am in a domain with a windows 2003 server, but I didn't try to install airprint on the server, I just try in my own computer on XP because I thought it would be easier. My printer is a Network HP laserjet CP4005n configured as a local printer in TCP/IP port. I tried to share the cutePDF printer as well, but again no printer shown on the iPad...

    Please help me ! I have 10 salesmen in my office who wants to print with there new iPads :)
    Thanks for all the job you've already done, and for your help !
     
  17. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #67
    Context matters. In the context of Airprint it's legacy. :rolleyes:
     
  18. pocketth macrumors newbie

    Joined:
    Feb 10, 2012
    #68
    Hi

    First... sorry for my English. I'm Thai :p

    I used this app with my iPhone4S with iOS 5.0.1... It work :D !!!
    But..... When I update my iOS to 5.1 Beta 3 .. It can't use

    Does Anyone found this problem like me ?
     
  19. smoothunit macrumors newbie

    Joined:
    Feb 10, 2012
    #69
    I just had a quick play to try creating a new user account 'AirPrint' with and without a password for my WHS2011 setup. Still, no dice...

    I've been trying to get this setup with WHS 11 since it came out.
     
  20. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #70
    The infamous lock

    Well, it worked the first time I tried, seem my previous post. Now I always the infamous Lock beside my printer :(.

    I don't know what changed since then, is it a patch that was applied to Windows 7. It's unfortunate it don't work. Just what is it ?
     
  21. FatCatElvis macrumors newbie

    Joined:
    Feb 29, 2012
    #71
    Worked like a charm!

    Thanks for the iOS 5.x update. I was struggling for the last 3 hours with various AirPrint installation instructions. Nothing was working and getting extremely frustrated. Rebooted, deinstalled, restored, created various user accounts, checked shared printer, checked everything imaginaable, and no success.

    After reading this post, realized that perhaps it's because I have the latest iOS on both iPhone and iPad. Followed the .reg fixes, and it's a miracle!! Worked like a charm!!

    Thank you to the poster for sharing.

    =====

    OS = Windows 7 Professional, 64-bit. Have latest updates of everything installed.
    Printer = Brother HL-2170W
    Printing from = iPhone 4 and iPad (1st gen)
     
  22. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #72
    Puzzled

    FatCatElvis,

    how in the world did you get it to work :confused:. I can't get rid of the lock.

    Thanks
     
  23. clactonlad macrumors member

    Joined:
    Aug 18, 2010
  24. cbearden1 macrumors newbie

    Joined:
    Mar 21, 2012
    #74
    No luck on network

    I am trying to get this working at my corporate office. I have a networked win2003 server 32bit. The service was installed along with the registry edit. Both appear to be running, however I do not see any of the printers on the ios device. The printers are all shared on the network. I have also added a printer locally via a preexisting port. Still no printers show on the ios device.

    For the heck of it I took a winXP SP3 PC with a physically attached local printer that has been shared out to the network and added the AirPrint Service with the registry edit and bonjour. I still do not see the printer on the ios device.

    I haven't really seen any posts yet regarding getting the service to work on a large network. Any suggestions?
     
  25. dlist macrumors newbie

    Joined:
    Nov 16, 2011
    #75
    iOS 5.1 Seems to Prompt for Password

    I was trying this with my iPad running 5...

    I did not want to enable "Guest" acct.

    I updated iPad to 5.1, and it just prompted me for Windows username and password ... :D
     

Share This Page