How to prevent Safari banner "This webpage is using significant energy [...]"?

Discussion in 'macOS Mojave (10.14)' started by Yoms, Jun 11, 2019 at 9:19 AM.

  1. Yoms macrumors member

    Joined:
    Jun 1, 2016
    #1
    Hi,

    Several times per day, I see this banner in Safari:
    This webpage is using significant energy. Closing it may improve the responsiveness of your Mac.

    The website is what it is and there's nothing I can do to improve it.

    But this is banner happens too often. Is there a way to prevent Safari from displaying it? As it momentarily reduces the window size, it messes with the display of the webpage (rather a web app than a mere webpage actually).

    Thanks a lot,
     
  2. Honza1 macrumors 6502

    Joined:
    Nov 30, 2013
    Location:
    US
    #2
    Not sure how prevent this popup, but you may be able to reduce the load by using Ghostery or other content blocker. It makes a huge difference.
     
  3. NoBoMac macrumors 68020

    Joined:
    Jul 1, 2014
    #3
    Turn off extensions?

    Try different browser? Even in this day and age, still run into the odd website that has issues in one browser or another (eg. an online survey I got the other day would not launch in Safari, but had no issues in Firefox; Chrome has some Google-specific methods for dealing with caching/mobile content [for example]).
     
  4. Honza1 macrumors 6502

    Joined:
    Nov 30, 2013
    Location:
    US
    #4
    And did you try googling this message? I did and it shows as one of the top one results:

    https://www.tekrevue.com/tip/disable-safari-power-saver-os-x/

    It's bit old, but the checkbox is still there. Does that help?
     
  5. Yoms thread starter macrumors member

    Joined:
    Jun 1, 2016
    #5
    Hi,

    Thanks for your replies.

    I don't want to turn off extensions. The web app is demanding and is meant to be this way. It's a charting and graphic web app. Maybe one day, the developers will optimise their JS code, maybe not. But in the meantime, I don't want to disable JavaScript on this page as it's mandatory to use all its functionalities.

    Yes I did google it, but again I don't want to use Safari power saver mode. I want to use all the power I can :) I don't care. I just want Safari to stop annoying me with this message.
     
  6. Honza1 macrumors 6502

    Joined:
    Nov 30, 2013
    Location:
    US
    #6
    My reading of that page is, that checking that checkbox will prevent Safari from throwing that message and using all cpu it can.

    Try it and let us know, please. I do not have test to try it on and I am intrigued ;-)
     
  7. Yoms thread starter macrumors member

    Joined:
    Jun 1, 2016
    #7
    I can try, but again I'm ok with Safari using all the CPU it can. That's what I want with this page !
    Also, when I googled the msg, I also saw people writing that this msg appeared in High Sierra whereas what you are referring to is a much older functionality.
     

Share This Page

6 June 11, 2019