How to set custom resolution for internal display in Sierra?

Discussion in 'macOS Sierra (10.12)' started by theosib, Jan 29, 2017.

  1. theosib macrumors member

    Joined:
    Aug 30, 2009
    #1
    I'm using Sierra on a 2015 15" retinal MPB. When I do screen recordings using Quicktime, the files I get are enormous and entirely unnecessary since I'm just going to scale them down in iMovie anyway. Plus, doing a screen recording seems to just be too much for this laptop; the fans go like crazy, the CPU cores are pegged at 100%, and I find that I get gaps in the videos sometimes. If I could record at a lower res, that would help a LOT, both in terms of what is being displayed and how much compute power is necessary to record it.

    Is there a way I can set a non-retina *standard* resolution in Sierra for the internal display? For instance, I'd like to set the internal display to 1920x1080, because that's good for youtube.

    With an external monitor, I can option-click "Scaled" in the display preferences pane to get more resolutions, but this doesn't work for the internal display.

    One option I have is to connect an external monitor then mirror the displays, but I'd really like to have other content on my external monitor. Plus, this demonstrates that the internal display CAN support other resolutions. We just have to be able to set it manually.

    What options do we have for this? Surely, there's some setting I can make in a terminal to fix this. With Apple's built-in support for screen recording, editing with iMovie, and publishing directly to youtube, they MUST have accounted for this scenario somehow.

    Thanks.
     
  2. LOLZpersonok macrumors 6502a

    LOLZpersonok

    Joined:
    Aug 10, 2012
    Location:
    Calgary, Canada
    #2
    As far as I'm concerned, you can only choose your scaling (which is essentially setting your screen resolution). You've only got a few options and without 3rd party software or modifications to macOS, I'm pretty sure custom resolutions are out of the question. Try setting the "larger text" option in the Displays menu of the Settings app.
     

Share This Page