How to solve kernel_task high CPU usage?

fantasticbobski

macrumors newbie
Original poster
Feb 5, 2014
18
15
My MacBook Pro has been a bit of a problem the last couple of weeks. I started a thread called "MacBook Pro Randomly crashing.

The threads a mess.

Now it's a mid 2010 13inch MacBook Pro with a brand new battery, SSD hard drive. The problem pre-dates these two recent upgrades.

The Macbook was crashing but now this has stopped. Now the MacBook works VERY slowly. Activity Monitor is telling me that a process called "kernel_task" is using 87-93% CPU power.

What is this "kernel_task" and what does it do and how do I stop it? It seems to be throttling my machine.

Also. The battery is no longer recognised. There is an x where the percenatage should be. I bought a new battery but no change.

Help please.

FB
 

53kyle

macrumors 65816
Mar 27, 2012
1,281
106
Sebastopol, CA
I can't remember exactly how other people described it, but I will still try. Kernel_task is the main process of Mac OS X, so if you quit kernel_task, you quit the computer itself. I think that things which take up a lot of CPU in kernel task are things that you plug into your computer, like an uncompatible mouse or flash drive. However, don't be suprized if I'm wrong because this post is made up of bits that I remember from other related threads. Still if you do have anything plugged in that isn't the charger or an official apple accessory, it doesn't hurt to try unplugging it.

Another thing to try is uninstall any programs that you installed NOT by drag and drop, but with a package that opened the installer application. This could be drivers for an accessory, or anything that modifies UI, sound, your display, or your system in any other way.
 

fantasticbobski

macrumors newbie
Original poster
Feb 5, 2014
18
15
I can't remember exactly how other people described it, but I will still try. Kernel_task is the main process of Mac OS X, so if you quit kernel_task, you quit the computer itself. I think that things which take up a lot of CPU in kernel task are things that you plug into your computer, like an uncompatible mouse or flash drive. However, don't be suprized if I'm wrong because this post is made up of bits that I remember from other related threads. Still if you do have anything plugged in that isn't the charger or an official apple accessory, it doesn't hurt to try unplugging it.

Another thing to try is uninstall any programs that you installed NOT by drag and drop, but with a package that opened the installer application. This could be drivers for an accessory, or anything that modifies UI, sound, your display, or your system in any other way.
Hi, I've tried resetting the computer back with a fresh install of the Snow Leopard disk that came with the macbook. Tried reinstalling the the original hard drive and battery.. Nada. Same issue.

----------

Have you tried resetting your SMC?

http://support.apple.com/kb/ht3964

With your upgrades/battery detection issue, this might help.

If not, I would start to look into the Console or system logs for clues.
Hi, many thanks for your response.

Yep, tried a SMC reset and a Pram re-set. Nothing.
 

fantasticbobski

macrumors newbie
Original poster
Feb 5, 2014
18
15
Okay, I seem to have solved the kernel_task PCU drain using this method I stumbled across on the web.

1. Go to About this mac under the apple in the upper left and click on More info
2. Click on system report
3. make a note of what it says after Model Identifier
4. go to your master drive – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
3. Restart and you’re done
I hope this helps.

Only problem now is the battery won't register, new or old and the fan is running 100% of the time.
 

jpeezy

macrumors regular
Feb 24, 2010
101
8
Okay, I seem to have solved the kernel_task PCU drain using this method I stumbled across on the web.

1. Go to About this mac under the apple in the upper left and click on More info
2. Click on system report
3. make a note of what it says after Model Identifier
4. go to your master drive – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
3. Restart and you’re done
I hope this helps.

Only problem now is the battery won't register, new or old and the fan is running 100% of the time.
Really? WOW! LMAO If you are unfamiliar with what the "kernel_task" is/does, I suggest leaving system files alone.
 

Jesla

macrumors 6502a
Jan 7, 2013
539
165
Tennessee USA
So I guess you tried another SMC reset since the fix? Could both
batteries be bad for some reason? Try using iStat Menu to control
the fans and see what other info you can find with it.
 

fantasticbobski

macrumors newbie
Original poster
Feb 5, 2014
18
15
I think his point is it is easy to do more harm than good if you don't know what those system files do.
Thanks for your post,

The method I used seems to be recommended on quite a few mac forums and seems to have done the trick. My unusable macbook now seems to be usable.

I do know the intended function of the file I've moved. I can always put it back should I need to but like I said. The Macbook is now functioning a million times better but thank you ever so much for for taking the time to post.

----------

So I guess you tried another SMC reset since the fix? Could both
batteries be bad for some reason? Try using iStat Menu to control
the fans and see what other info you can find with it.
Hi, I've tried doing a SMC reset. No difference.

I will have a play with the aStat Menu and see. Many thanks.

I suspect that whatever is causing the fan to run constantly is the same issue that is preventing the battery from registering.

The original fault is now cured. Constant crashing. The high CPU, fan, Battery fault started whilst trying to fix the crashing fault. Whether these faults are related I don't know. I have too little experience.

These three current faults seemed to start when I removed the original battery whilst going through some recommended routine procedures to reset the machine.

Thanks.
 
  • Like
Reactions: scyllagist

simonsi

macrumors 601
Jan 3, 2014
4,850
734
Auckland
Thanks for your post,

The method I used seems to be recommended on quite a few mac forums and seems to have done the trick. My unusable macbook now seems to be usable.

I do know the intended function of the file I've moved. I can always put it back should I need to but like I said. The Macbook is now functioning a million times better but thank you ever so much for for taking the time to post.
You are welcome. I hope your experience level rises rapidly. You may need it.
 
  • Like
Reactions: dasmb

Persona

macrumors newbie
Jun 10, 2014
1
0
Yay !!!!

I followed these steps from above and it worked perfectly. Resetting the PRAM and SMC did not solve the issue.

The battery is registered and I "do not" have a high fan issue.

FYI,
MacBook Pro 2011
Replaced battery from original 7700mAh ? to an Anker 5400mAh




1. Go to About this mac under the apple in the upper left and click on More info
2. Click on system report
3. make a note of what it says after Model Identifier
4. go to your master drive – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
3. Restart and you’re done
 

asvob

macrumors newbie
Jun 9, 2014
11
0
I noticed this particular issue on my MBA after upgrading to 10.9. I had tried resetting SMC but the only "fix" was to reboot and it would go away until I'd wake up my MBA from sleep.

I remember reading somewhere that the purpose of this process was to throttle the CPU usage when it detects something is wrong, and it often misbehaves. I also read that modifying the kext can cause your mac to not know when to throttle itself down (when overheating perhaps), however the CPU should shut itself down at the hardware level if it reaches T-Junction MAX (max operating temperature).

Take this all with a grain of salt, because I don't think it was ever confirmed by apple or researched further.
 

mastermusic

macrumors newbie
Jun 24, 2014
1
0
This method works!

Okay, I seem to have solved the kernel_task PCU drain using this method I stumbled across on the web.

1. Go to About this mac under the apple in the upper left and click on More info
2. Click on system report
3. make a note of what it says after Model Identifier
4. go to your master drive – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
3. Restart and you’re done
I hope this helps.

Only problem now is the battery won't register, new or old and the fan is running 100% of the time.
I had the exact same problem with the battery and fan, and CPU usage was 177%. This worked IMMEDIATELY after reboot, noticeable right away, and did not cause any other problems. Thank-you for posting this solution.
 

eurotrash2008

macrumors newbie
Sep 23, 2010
1
0
it works for me

Having upgraded recently to a MacBook Pro 13" (early 2011, it is faster than my old MacBook early 2008!!), and installed OS X 10.9 I found that the CPU was running at over 300%. After a bit of research I removed old kext files that were on the system pre 10.9. Problem solved, until I unplugged it, and then back to the high CPU.

So, found this thread and tried the fix.

Works great now, and the fan is not running high, nor has the battery symbol vanished. Now my MBP is usable beyond the AC adapter once again.
 

porky2017

macrumors member
Aug 15, 2011
54
1
Australia
It worked for me

I have the same problem Macbook pro 2011 I5 8 gig ram, before all these problems occurred i was getting geek bench scores of 6850 now after this fix aim only getting 2500 even as low as 1800, & it takes as long as 3 minutes to run geek bench, when it should only take 1 min for geek bench to complete,
I don't know what is happening its like my mac is running on 1 core or something.
has anyone heard of a fix,not just a workaround it more than likely will be a costly expense

thank you..
 

dsf7

macrumors newbie
Aug 13, 2014
1
0
What if my model identifier is not on the mentioned folder? My late 2013 macbook has the identifier: MacBookPro11,1 but on the folder there is only files for MacBookPro from 1_1 to 8_3

Okay, I seem to have solved the kernel_task PCU drain using this method I stumbled across on the web.

1. Go to About this mac under the apple in the upper left and click on More info
2. Click on system report
3. make a note of what it says after Model Identifier
4. go to your master drive – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
3. Restart and you’re done
I hope this helps.

Only problem now is the battery won't register, new or old and the fan is running 100% of the time.
 
Last edited:

RicoSky

macrumors newbie
Sep 1, 2014
1
0
it works !!!!!!!!!!

fantasticbobski thank you thank you thank you !!!!!!!!
It works!!!! I reinstalled my MBP 2x with no effect. I was close to exchange my HDD. Your method works!
:):):):):):)

Okay, I seem to have solved the kernel_task PCU drain using this method I stumbled across on the web.

1. Go to About this mac under the apple in the upper left and click on More info
2. Click on system report
3. make a note of what it says after Model Identifier
4. go to your master drive – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
3. Restart and you’re done
I hope this helps.

Only problem now is the battery won't register, new or old and the fan is running 100% of the time.
 

EasyGoing1

macrumors newbie
Aug 4, 2013
9
13
Same Problem Here with 2013 model

What if my model identifier is not on the mentioned folder? My late 2013 macbook has the identifier: MacBookPro11,1 but on the folder there is only files for MacBookPro from 1_1 to 8_3
I'm having the same issue as you are ... high CPU on kernel_task and a 2013 model MacBookPro11,1 with no file containing that name under the kext folder. I went up to the top of the folder tree and searched all subfolders for that name as well without success.

I really need to fix this problem so if you found a solution on your 2013 MacBook Pro (hopefully running 10.9 Mavericks), I would love to hear what you did to solve it.

Mike
 

ideaman924

macrumors newbie
Feb 4, 2014
5
0
Definition

A lot of you don't really know what kernel_task does. You guys are moving system files that can really mess up your computer in the long run.

To make it short, kernels get directions from the Mac OS X, like "Power on the Wi-Fi!" or "Can you search for more peers in Bluetooth?" Kernels also report to the OS, like "Hey, a new USB device just got plugged into the machine." So, it's like a bridge between the OS and the hardware.

Moving files - system files - will not be good. I suggest unplugging every device connected to your Mac and restarting it. (except the MagSafe adapter - if you have a battery that won't hold up) If that doesn't help, reset the PRAM and the SMC. If that doesn't work either, think about what hardware you have replaced in the computer. Do a reinstallation of the OS X. Or a clean install. There are a lot of things you could try that are definitely not harmful to your computer.

Hope I helped.:D
 

EasyGoing1

macrumors newbie
Aug 4, 2013
9
13
Solved the problem on 2013 MacBookPro

OK, so I have a 2013 late model MBP, and I have been having this issue for some time now ... In my case, when I run the hardware diagnostics, it says that I *MAY* have a faulty PMU or PCU or power whatever logic board thing-a-ma-jig ... However, I had to replace my screen a few months back because I dropped the MBP and cracked my screen, and the screen I bought from ebay had some of the wires cut and I didn't read the fine print before I made the purchase (it was only $200 and other than the wires being cut (not the video cable, but the other ones) it works great! But since I put this screen in, I've been having the high CPU utilization in my kernel_task process and my MBP ran slower than molasses ...

Well, after much experimentation, research, trial and error, I finally solved the problem... here is what you need to do:

Open up terminal (If you don't know what that is, you have no business doing this in the first place)...

type (or copy and paste from here):

Code:
sudo mv /System/Library/Extensions/AppleSMCLMU.kext ~
that will move it to your parent home folder

Reboot!

I also have AppleIntelCPUPowerManagementClient.kext and NullCPUPowerManagement.kext in my home folder, but I'm 99.999% positive that the problem went away after moving that SMCLMU kext file out of the extensions folder and re-booting. I believe that is the file that reports the mis information to the kernel which then freaks the heck out for some reason - in my opinion, the way OSX responds to a bad sensor is a very poor way to respond to a bad sensor ... sure, lets make the computer almost unusable so that the user will pay us to fix it for them ... there are times when hardware can be faulty, yet there is no risk to the computer at all, it doesn't mean that your laptop will never reach temperature levels which that sensor monitors which will put your laptop in danger ... in fact, in my case, the sensor readings were pinging at -128 degrees ... you'd think that Apple would realize that -128 is indicative of a faulty sensor especially when the other sensors are reading normal temperatures ... so why dumb down the computer when it's obvious that the sensor isn't actually providing a reading which indicates danger for the hardware... that the sensor itself is actually the problem so no need to go to extremes and make the computer run slower... sensors are there as a secondary watch over the hardware, the user being the first ... so again ... why design an operating system to run slow when a sensor has merely gone bad? Could you imagine if car manufacturers made your car go no faster than 20 miles per hour because of a bad o2 sensor???? It's a piss poor design call on Apple's part and they really need to fix it.

Good luck everyone!

Mike Sims

----------

What if my model identifier is not on the mentioned folder? My late 2013 macbook has the identifier: MacBookPro11,1 but on the folder there is only files for MacBookPro from 1_1 to 8_3
I forgot to mention that I've been using my MBP for over 15 hours now since implementing the solution I posted without any slow down issues or high CPU utilization what so ever ... that is a world record for this MBP as I have been dealing with this problem for MONTHS ... it's like having a new mac now.
 

elshadee

macrumors newbie
Oct 4, 2014
1
0
Thank You!!

Okay, I seem to have solved the kernel_task PCU drain using this method I stumbled across on the web.

1. Go to About this mac under the apple in the upper left and click on More info
2. Click on system report
3. make a note of what it says after Model Identifier
4. go to your master drive – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
3. Restart and you’re done
I hope this helps.

Only problem now is the battery won't register, new or old and the fan is running 100% of the time.
Thank you for this post. It worked for me, no more high cpu usage from Kernal. Much love!
 

bigpete777

macrumors newbie
Oct 8, 2014
1
0
hi,

same problem with huge kernel usage (i think it may have occurred when trying to use wine bottler to install a program...

Trashed ATTOcelerity and ATTOexpress files as recommended in another thread. Tried to follow above advice, but couldn't find my computer model in Resources. Mine is a MacbookAir 6_1, and not on the list. Mac_book 6_1 is listed, but Mac_book Air only goes up to 4... what now?

**also, another thread suggested manually removing all of the .kext files listed in extensions. Is this worth a try, or could it cause harm to my computer? Thanks.
 

pumany

macrumors newbie
Oct 3, 2014
4
0
New York NY
One of the solutions posted to this problem seems to be working so far. See Feb 14, 2014 post by fantasticbobski. I don't know exactly what this does, but it has worked so far. I will post with more info if it becomes available.

I had previously reloaded Mac OS X to solve this problem, with no luck. Computer remained way too slow. After LOTS of Apple Hardware Diagnostics and visits to the Genius bar, I gave the solution below a shot. Some background: I have not loaded any suspicious software. I have only loaded well known established applications. Activity monitor was showing kernel_task with 100+% CPU use.

After seeing others post their configurations in order to get feedback with no resolution - I gave the solution a shot. If anyone has more details about the solution below or how it impacts the system, feel free to comment.

1. Go to About this mac under the apple in the upper left and click on More info
2. Click on system report
3. make a note of what it says after Model Identifier
4. go to your master drive – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
3. Restart and you’re done
I hope this helps.
 

PaWell

macrumors newbie
Oct 12, 2014
1
0
MacBookPro9_2 slved by memory clean after sleep

Problem with high cpu usage magically solved.
I've found that problem always ocurrs after my Powerbook2_9 with Maverick goes sleep. I've tried several options... and the last was installation of memory cleaner (from appstore - it's for free). Being frank I did it "incidentially" , just to chceck application ... and miracle!!! after cleaning memory CPU usage drops down till next sleeep. :). So You have to repeat memory cleaning. Works fine for last several hours.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.