How to solve kernel_task high CPU usage?

Discussion in 'MacBook Pro' started by fantasticbobski, Feb 14, 2014.

  1. acousticbiker macrumors 6502

    Joined:
    Jun 28, 2008
    #51
    I'm having the same kernel_task PCU drain / fan always on problem. My Model Identifier for step 3 is MacBookPro11,1 but is not found in the folder in step 4. Any tips?
     
  2. ibravo macrumors newbie

    Joined:
    Apr 20, 2015
    #52
    To resolve this problem, since it was tied to the kernel and how it works, I had to install Ubuntu in a separate partition of my HDD.

    I still have OSX installed, waiting for Apple to allow to control this kernel_task issue through software, but as I got frustrated more and more, and since I do love the form factor of the MacBook Air, Ubuntu was my best choice.

    I do have now a working computer again, with almost all the software that I need back on. Certainly, I do miss MS Office, the trackpad gestures and the icloud messenger.

    Other than that, I'm again a happy camper.
     
  3. maciejhalas macrumors newbie

    Joined:
    Apr 26, 2015
    #53
    Solving problem on Macbook Pro 11.1 (and others)

    We all got a problem to find proper file to delete/move... My Model Identifier is MacBookPro11,1 so there is not such a file in ACPI_SMC_PlatformPlugin.kext.

    So the FILE is in this dir – System -Library – Extensions – IOPlatformPluginFamily.kext -Contents – Plugins –X86PlatformPlugin.kext - Contents - Resources

    You have to identify Your laptop. This is all I found on other forums:

    [ 1 ] Mac-031B6874CF7F642A.plist / iMac14,1
    [ 2 ] Mac-189A3D4F975D5FFC.plist / MacBookPro11,1
    [ 3 ] Mac-27ADBB7B4CEE8E61.plist / iMac14,2
    [ 4 ] Mac-2BD1B31983FE1663.plist / MacBookPro11,3
    [ 5 ] Mac-35C1E88140C3E6CF.plist / MacBookAir6,1
    [ 6 ] Mac-35C5E08120C7EEAF.plist / Macmini7,1
    [ 7 ] Mac-3CBD00234E554E41.plist / MacBookPro11,2
    [ 8 ] Mac-42FD25EABCABB274.plist / iMac15,1
    [ 9 ] Mac-77EB7D7DAF985301.plist / iMac14,3
    [ 10 ] Mac-7DF21CB3ED6977E5.plist / MacBookAir6,2
    [ 11 ] Mac-81E3E92DD6088272.plist / iMac14,4
    [ 12 ] Mac-F60DEB81FF30ACF6.plist / MacPro6,1
    [ 13 ] Mac-FA842E06C61E91C5.plist / iMac15,2
    [ 14 ] Mac-00BE6ED71E35EB86 – iMac13,1/i5-3335S
    [ 15 ] Mac-2E6FAB96566FE58C – MacBookAir5,2/i5-3427U
    [ 16 ] Mac-4B7AC7E43945597E – MacBookPro9,1/i7-3720QM
    [ 17 ] Mac-6F01561E16C75D06 – MacBookPro9,2/i5-3210M
    [ 18 ] Mac-7DF2A3B5E5D671ED - ?
    [ 19 ] Mac-031AEE4D24BFF0B1 – Macmini6,1/i5-3210M
    [ 20 ] Mac-66F35F19FE2A0D05 – MacBookAir5,1/i5-3317U
    [ 21 ] Mac-AFD8A9D944EA4843 – MacBookPro10,2/i7-3520M
    [ 22 ] Mac-C3EC7CD22292981F – MacBookPro10,1/i7-3720QM
    [ 23 ] Mac-F65AE981FFA204ED – Macmini6,2/i7-3720QM
    [ 24 ] Mac-FC02E91DDD3FA6A4 – iMac 13,2/i7-3770

    It is temporary solution because we have to mix some system files. For me it works just fine. I found one small side-effect - There is 10sec delay when You wake up the MacBookPro but it is nothing comparing to my Mac few day ago...

    Of course it is a problem that we have to mixing in system files to have our Mac's efficient.

    P.S. I had no problem with kernel_task (before I moved the file) every time I pluged in magsafe.. What is the reason???? Maybe someone will find the answer. Please let me know.
     
  4. js09 macrumors member

    Joined:
    Sep 17, 2010
    #54
    this prevented my mac from restarting period, and then i had to reinstall OSX. nice fix.
     
  5. reflecti0nX macrumors newbie

    Joined:
    Mar 3, 2015
    #55
  6. Trav7 macrumors newbie

    Joined:
    May 21, 2015
    #56
    Thank you so much!!!!!!!!!!!! 1 week of trying to fix my Mac was solved in less then a minute!! It was down to a crawl, activity monitor showed nothing unusual, omyx wouldn't open, recovery mode, single user verbose etc didn't work, this weird little hack saved my Mac ###
     
  7. reflecti0nX macrumors newbie

    Joined:
    Mar 3, 2015
    #57
    Activity Monitor should definitely show something unusual, make sure you select View - All Processes in the menu of Activity Monitor, otherwise kernel_task process will not be shown.
     
  8. reggoboy macrumors member

    reggoboy

    Joined:
    Jul 8, 2009
    #58
    Thanks for the idea. But strange, my Model #, Macmini6,2, is not listed there. The last Macmini entry is Macmini5_3.plist. Next idea?

    p.s. I'm running Yosemite 10.10.3.
     
  9. Marcel_75 macrumors newbie

    Marcel_75

    Joined:
    Jun 16, 2015
    #59
    Have tested this on 10.11 El Capitan.

    Apple introduced a new rootless-mode which is activated by default, so also with a root-Shell (sudo) you can't delete important system files, which is IMHO a good decision by Apple.

    But for a short test I have deactivated the rootless-mode: sudo nvram boot-args=rootless=0

    After a restart I've moved the file to the Desktop (it's a MacBookPro8,1 as you can see):

    mv System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext/Contents/Resources/MacBookPro8_1.plist /Users/Marcel/Desktop/

    Now another restart was needed.

    It's true this "hackaround" will work - if the MacBook was on Power, all worked fine. But on Battery I got also a sluggish System thanks to nearly 100% CPU usage by the kernel_task.

    Now it worked also fine without Power (on Battery only) - no more high cpu usage by the kernel_task.

    BUT:

    If you do a test with yes > /dev/null (2x on a 2-cores machine, 4x on a 4-cores machine) to produce (2x or 4x) 100% usage of the cores, you will DESTROY your machine for sure after some time. The same would be true if you play a 3D game, ripping a DVD or rendering something - any job with high CPU and GPU usage could destroy your Macbook now. Why?

    With the free application smcFanControl you will realize, the fans are working only with around 2.000 rpm and the heat-sensors only "see" around 50 degree celsius.

    But normally after some seconds a yes > /dev/null will bring the machine to over 90 degree celsius and the fans will automatically run with the maximum speed of 6.200 rpm.

    Now you are WARNED (again) – please don't do this, it's not a solution at all. You could do it if you are happy with a machine which has to have the fans running with 6.200 rpm all the time (you can control this by define a mode like this with the smcFanControl app).

    But better put the file back where it has to be in the system, set the file permissions to the standard (owner root, group wheel) by sudo chown root:wheel <path to the plist file you have moved before>

    An official Apple Service Provider Repair Center will help you for sure, because it's only a problem with your battery (normally "not original ones", but also original Apple batteries are affected sometimes), let them change it and all will be fine again.
     
  10. tmy macrumors newbie

    Joined:
    Jun 16, 2015
    #60
    I experienced same issue with MBP Late 2013 and 10.10.3.

    Removing kext files, SMC reset, disconnecting external displays and replacing to Fusion from Parallels didn't help but in my case, stopping flash and flash plug-in of browser finally solved this issue.
     
  11. chepexrock macrumors newbie

    chepexrock

    Joined:
    Jun 17, 2015
    #61
    Thank you, this really help me out on my MBP 2011.
     
  12. eustacius macrumors newbie

    Joined:
    Jun 18, 2015
    #62
    Thanks for posting this fix. I applied the fix and the cpu system usage went from 97% to 3%. Now the machine is once again usable. I had tried all of the resets and reinstalls and nothing helped more than 5 minutes. I just copied the file to the desktop then deleted the the ktext ID file in the system file as noted. My hunch is that there is no exit coded properly and the machine was "chasing its tail" so to speak by self-identifying over and over and over in an endless loop. That also explains the fan issue since the cpu was eating itself. Apple could certainly fix that software easily. Probably a malicious plan to sell more machines since that was where I was going out of frustration. I thought the logic board was failing. This problem started suddenly, so me thinks someone changed the code, possibly negligent. Maybe intentional. Anyway, done, thanks again.
     
  13. neongrau macrumors newbie

    Joined:
    Feb 28, 2014
    #63
    I'm having this problem for the last 3 days. System becomes pretty much unusable while kernel_task moves between 200-1600% cpu. I'm running my rMBP (2012) with 2 external displays and the retina display open as well.

    Found out that the problem goes instantly away when i just close the lid. 10.10.4 is currently downloading hopefully there is a fix for this problem included too.
     
  14. albertdros macrumors member

    Joined:
    Jul 4, 2012
    #64
    I too have this problem. I wanted to try the fix many suggested here, but I have a MBP with model number 11.3. When I go to the folder, the last file I see is MacbookPro8_3.plist.

    Am i doing something wrong? This problem is getting annoying.
     
  15. albertdros macrumors member

    Joined:
    Jul 4, 2012
  16. cholybran macrumors newbie

    Joined:
    Jul 20, 2015
    #66
    Where you mention 'things that plug into your computer' ...this was an awesome hint, for me anyway. I went into activity monitior and saw that kernel_task was going at over 600% CPU usage! So ultimately got to this thread where you made this comment. I unplugged a tablet monitor and the kernel_task dropped to 5% (appx).

    Now that I know what the cause is, I can start to figure it out. But without the little clue you left in your description, I don't know how long it would have taken me to figure it out. Thanks.

     
  17. snaking macrumors newbie

    snaking

    Joined:
    Aug 8, 2015
    #67
    Finally solved.

    I signed up for thank you. :)

    Thank you very, very much.
     
  18. Fangpyre83 macrumors newbie

    Fangpyre83

    Joined:
    Aug 17, 2015
    Location:
    DXB
    #68
    me too just signed-up to say a BIG THANKS :D
     
  19. klausson macrumors newbie

    Joined:
    Mar 1, 2006
    #69
    Like others have reported, this method worked for me as well. No SMC or Pram reset required. After moving the file and restarting the Macbook Pro, the kernel_task CPU usage has gone done from more than 500% to under 10%. Memory usage has dropped slightly, but was not the problem to begin with. Also, the battery lifetime is much better since then.
     
  20. E5presso macrumors newbie

    E5presso

    Joined:
    Oct 2, 2015
  21. Count Blah macrumors 68030

    Count Blah

    Joined:
    Jan 6, 2004
    Location:
    US of A
    #71
    I recently fixed my sister's macbook, by resetting SMC and PRAM. Sadly, it took multiple attempts, but performing both of these actions quieted the 100+% CPU kernal task process that was rendering the machine unusable.
     
  22. Douglas Barnes macrumors newbie

    Douglas Barnes

    Joined:
    Oct 7, 2015
    #72
    Other people WOWing and LMAOing. Nope it worked brilliantly, and didn't cause a singularity or any of the other dire predictions.

    10/10 Would remove MacBookPro8_2.plist again.
     
  23. mcneale macrumors newbie

    mcneale

    Joined:
    Aug 10, 2011
    Location:
    Richmond, Virginia
    #73
    In my experience, MBP 2015, 16Gb RAM of which >9Gb were being used by kernel_task the problem disappeared after these steps. Also, I note that on reboot there's a re-reboot on start up (heart in the mouth moment) but then everything was ok. The system seems to regenerate all the files in the Resources directory, if needed, on restart.
     
  24. Badgermonkey macrumors newbie

    Joined:
    Oct 28, 2015
    #74
     
  25. Badgermonkey macrumors newbie

    Joined:
    Oct 28, 2015
    #75
    You are likely looking in the User Library rather than the system library; you need to start from your root drive, not your Home folder.

    That being said, I had this issue with a previous upgrade and this fix worked great. However, in El Cap this is a protected system file; in order to delete it you need to
    0. Reboot into recovery mode (Command + R on boot prior to startup chime), select Utilities/Terminal, csrutil disable <Enter> (repeat process, use csrutil enable after removing the file), reboot.
    1. Go to About this mac under the apple in the upper left and click on More info
    2. Click on system report
    3. make a note of what it says after Model Identifier
    4. From the Root drive (not home folder): – System Library – Extensions – IOPlatformPluginFamily.kext (alt-click/ View Contents) – Plugins – ACPI_SMC_PlatformPlugin.kext – Contents – Resources – find the name from step 3 and move it to a folder that you can find again if needed.
    3. Restart and you’re done
     

Share This Page