How to stop Safari 'auto-launch' at startup

Discussion in 'Mac Apps and Mac App Store' started by wunnspeed, Nov 3, 2016.

  1. wunnspeed macrumors newbie

    wunnspeed

    Joined:
    Feb 20, 2009
    Location:
    Mettmenstetten, Switzerland
    #1
    Since one of the most recent OS X updates, Safari has taken to 'auto-launching' each time I reboot my iMac. I've checked my startup preferences and it's not listed. One one of my other iMacs (I have 3 generations that I use for different purposes), the same thing is happening with Spotify.... which I hate and never use but can't seem to kill it.

    Anyway... ideas would be appreciated.
     
  2. G4DPII macrumors regular

    G4DPII

    Joined:
    Jun 8, 2015
    #2
    Right click on the icon in the dock, should give you the option there.
     
  3. wunnspeed thread starter macrumors newbie

    wunnspeed

    Joined:
    Feb 20, 2009
    Location:
    Mettmenstetten, Switzerland
    #3
    Thanks... I actually checked that as well. It's also closed when I reboot so it's not in the 'reopen apps' config either. I'm still baffled.
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    Spotify has a setting for this in the app itself.

    Is Safari opening a website on startup?
     
  5. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #5
    Check "Users & Groups" System prefs.
    Make sure Safari is not in your login items.
     
  6. presenta macrumors newbie

    presenta

    Joined:
    Nov 29, 2016
    Location:
    Bulgaria (EU)
    #6
    If you restart [or log out] your machine turn off "Reopen windows when logging back in" option on the restart alert. Most users overlook this option and then wonder why Safari starts on login. Also, you can make sure that you quit Safari before restart (use menu Safari -> Quit (Cmd+Q)).

    For more info see:
    https://support.apple.com/en-us/HT204005
     
  7. Jolygreenegiant macrumors newbie

    Jolygreenegiant

    Joined:
    Dec 13, 2016
    Location:
    Quad Cities
    #7
    I'm having this same problem, did anyone ever find a solution?
     
  8. presenta macrumors newbie

    presenta

    Joined:
    Nov 29, 2016
    Location:
    Bulgaria (EU)
    #8
    Yes, in our case we solved it, by unchecking "Reopen windows when logging back in" option on the macOS restart alert.

    If that doesn't help, you need to examine (and disable) all third-party apps that start when you login (i.e. LaunchBar). For example you may use the free KnockKnock app, that lists all startup items. There is no disable/remove function in this app, so you need to find out how to do it (i.e. use the uninstaller of the LaunchBar).

    There is another thread where people ask the same question. One of the answers points to LaunchBar.
     

Share This Page