How To: Windows 7 Build 64-bit on a MacBook Pro 2006 Model

Discussion in 'Windows, Linux & Others on the Mac' started by beatledud, Apr 19, 2009.

  1. beatledud macrumors 6502

    Joined:
    May 4, 2006
    #1
    The following is a How-To guide to install Windows 7 build 7077 x64 on an earlier version of a MacBook Pro with an ATI X1600 graphics card:

    So I’ve read on how Windows 7 could be installed on a MacBook Pro, with many how-to instructions. Albeit to say, even the most detailed how-tos neglected to state hardware requirements. Through my discoveries I found one major flag, that Apple didn’t support prior late 2007 models. My computer fell under that category, being the second edition (late 2006). The primary difference with my computer (including earlier MBPs) and the ones beyond was the switch to the nvidia chipset. I decided to modify a guide that I found detailed but not sufficient for my needs. The model # I have is MA610LL, the 2.33Ghz Intel Core 2 Duo 15.4” with an ATI mobility Radeon X1600. I assume that models MA609LL and MA611LL (2.1Ghz on the 15.4” and 2.33Ghz on the 17”) will work fine with this guide. As for the prior models which are the Intel Core Duos from early 2006, this may work, but I don’t know if the older processors will prove to be problematic, but the video card should work [EDIT: According to others, the core duos do not support 64-bit architecture, sorry]. I’ll update this guide as feedback comes in. PLEASE NOTE that this is for Windows 7 64-bit. I don't know if 32-bit needs this much help to get it to work. Those that get it to work, please email me your computer specs so I know which models are functional. Here we go:

    I recommend referencing this guide as a basis. It’s a detailed guide with a sufficient use of images to help out. The following are some changes you need to make:

    A. Once you reach step #7 on the guide, they’ll instruct you to insert your Windows 7 DVD to install. For many people this doesn’t appear to be an issue. However with build 7077 x64 and my MBP, I received the “Select CD-Rom Boot Type” error on reboot, not allowing me to start the installation. Unfortunately you’ll need a copy of Windows to fix this (XP will do) so head over to a friend’s house. One may be able to use CrossOver in OSX, but if there’s a real Mac fix that’s posted, we’ll update this.

    1. I’ll save you the trouble of reading the thread, the best solution posted there is here.
    2. I recommend using 7-zip instead of Imgburn to extract the iso before performing the process. I had problems figuring out how to use Imgburn to extract an iso into loose files on a hard drive. This program was much more straightforward, however I came across one warning that stated it may be unstable and not provide a valid extraction. Ultimately, it worked well for me and can be found here.
    3. Once the iso has been extracted to c:\windows7iso, make sure the original iso isn't in that folder anymore! If you don’t your new iso will be twice the size.
    4. For those not familiar with cmd prompt in Windows, do the following: Start Menu>Run – Type ‘cmd’ then hit enter. Type ‘cd\’ then hit enter. The prompt should now just say ‘c:’. Type ‘cd windows7exe’ and hit enter. Now the prompt should say ‘c:\windows7exe\’. You can cntrl-c the command ‘oscdimg -n -m -bc:\windows7iso\boot\etfsboot.com c:\windows7iso c:\windows7dvd\windows7dvd.iso’ then right click and select paste in the cmd prompt, or type it in manually. Yes, that command is one long command.
    5. Burn the new iso in c:\windows7dvd\ as the instructions state. Install windows as the original guide tells you. NOTE: windows may try to extract the files at the beginning of the installation process and hang at 0% for a long time. This happened to me too, just be patient, it should go.
    B. The next issue is getting BootCamp drivers that will work on Windows 7 64-bit. In my case I bought Leopard well after purchasing my MBP, and my drivers don’t appear to have 64-bit drivers installed. Since I’m not officially supported, and since Apple doesn’t off their drivers to download, this poses a problem.

    1. 64-bit Vista drivers will do, but finding them can be problematic. You’ll need 2.0 drivers, but ones that also have 64-bit ones in them. This doesn’t appear to be the case with all 2.0 drivers people may find. You can find a torrent for them here, but I do not condone downloading them if you do not already legitimately own Leopard and therefore have the right to BootCamp drivers.
    2. If you don’t get the automatic BootCamp install when you insert your CD into your fresh Windows 7, try going to the Apple folder on the CD and running BootCamp64.msi.

    This should get all the drivers to work. Although, you may have noticed that in the original guide, Windows 7 was suppose to install the updated Graphics Card driver. At this point the resolution is still awful and BootCamp hasn’t resolved it.

    C. This part was a bit more tricky and the most important step for us early MBP users. Thanks to this thread I was introduced to modtools. NOTE, you may want to open BootCamp control panel and change the automatic boot drive to be Windows for now; you’ll be rebooting a lot and it saves the work of holding down the option key each time.

    1. Go to this site to read a brief statement on why we are forced into this predicament, and how to get out of it. Follow the instructions minus the following slight annotations.
    2. In step 1 of the guide, MSXML 6.0 may not be needed to be downloaded and installed. However after a few failures at this, I tried two new things. The first was download MSXML 6.0. It should be built in, but this could have been the issue I was having (I doubt it). If you do install it, make sure you select ‘msxml6_x64.msi’.
    3. In step 2 of the guide many of the methods they link to disable UAC aren’t native to Windows 7. I recommend method 2. To easily open RegEdit, click the Windows start menu button, enter in ‘run’ in the search programs field, the application ‘run’ will pop up. Select it and enter ‘regedit’ in the field. Follow the instructions from the site there on and you’ll be find.
    4. As the modtools site states, you can either download the latest desktop drivers for the X1600 from AMD/ATI’s site or from their Driver Heaven Downloads site. I tried downloading the latest from ATI (version 9.3) but it didn’t work. Once I decided to do Driver Heaven’s, I selected the latest 8.12 Windows 64-Bit driver they had and it worked! Just follow the rest of their instructions like normal.

    And that's it! Took me a while to search out all the solutions (and modify them from Vista to Windows 7 for many of them) so I thought I'd share for those early MBP owners. Comment, share, elaborate. I'll make corrections to any obvious errors, but I'll color code major changes as other users comment on success of failures they have. Good luck and enjoy! :)
     
  2. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #2
    beatledud, you are awesome and thank for you the guide. I didn't use (didn't need to) but have been running Windows 7 x64 build 7068 since its release (build 7000 before it) and so far Win7 has been amazing. By far the best OS Microsoft has developed so far (yes, better then everyone's beloved old dinosaur XP). Again, you rock, keep up the good work.
     
  3. Inconsequential macrumors 68000

    Joined:
    Sep 12, 2007
    #3
    Thanks for the guide, thankfully the 2009 machines have a updated EFI so it doesn't need the change.
     
  4. beatledud thread starter macrumors 6502

    Joined:
    May 4, 2006
    #4
    Thanks for the kind words (and the anti-trolling removal). Anyone though tried this procedure and had success or failure? Concorde Rules, from your computer descriptions, I assume that this guide didn't fall under your specs. I hope that this guide helped/will help someone out, even if it's only one person.
     
  5. cashel macrumors member

    Joined:
    Oct 30, 2006
    #5
    I've got the same model MBP you do. How can I extract the iso with imgburn? I've tried both winrar and 7zip for extracting the image file and during the Windows install, I get an error about how the files can't be read because they could be corrupted.
     
  6. cashel macrumors member

    Joined:
    Oct 30, 2006
    #6
    Nevermind, finally got it to install. I copied the ISO over to an XP install in vmware, extracted it with winrar, then followed those steps. I didn't have to install a video driver, windows update found one and my resolution is fine. I installed the bootcamp drivers and everything works except for the touchpad. I can't tap the pad to click, and I can't double tap to right click. I can two finger scroll though. If I load the windows 7 bootcamp partition in vmware, the touchpad works perfectly, I can two finger right click, tap the pad, etc.


    edit: this is all on Windows 7 7100 RC

    edit 2: When booting the Windows 7 bootcamp partition in VMWare, the screen will go ballistic changing resolutions before it reaches the login screen and everything goes back to normal
     
  7. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #7
    Core Duo MacBooks and MacBook Pros do not support 64-bit Win 7 flavor. Core 2 Duo MacBooks/Pro do.
     
  8. beatledud thread starter macrumors 6502

    Joined:
    May 4, 2006
    #8
    cashel,

    Can you verify what video card you have? ATI doesn't support mobile video card drivers so they have to come straight from Apple. Also to right click you need to click with two fingers on the pad, not double clicking. Maybe that's what you meant though. The trackpad seems like a fluke, try reinstalling 64-bit bootcamp again or going into device drivers and removing the trackpad drivers and reinstalling them.

    jav6454,

    Do you know this doesn't work on the old Core Duos because you tried it already?
     
  9. NipsMG macrumors newbie

    Joined:
    May 6, 2009
    #9
    I have the MA610LL laptop as well.

    I have windows 7 running (RC), but I cannot get sound no matter what I do. The automated installer didn't work for me, so I had to run the 64bit driver installers and everything is now installed and working except for the trackpad issue mentioned above, and the fact that I have no sound.

    I tried the realtek installer, and downloaded the newest realtek drivers from realtek for vista, and they installed without error, but when I look at the sound settings, the driver being used is still the microsoft HDA driver, and I have no sound.

    Any ideas?
     
  10. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #10
    Because Core Duo architecture doesn't suppport 64-bit computing. Only Core 2 Duos up.

    Read up Intel's site or hit Google/Wikipedia.
     
  11. Arkanok macrumors 6502a

    Arkanok

    Joined:
    Feb 13, 2007
    #11
  12. cashel macrumors member

    Joined:
    Oct 30, 2006
    #12

    I've got the ATI X1600, which windows update found drivers for and installed immediately. Yeah, that's what I meant with the trackpad. Basically the only things I can do with it are move the mouse around, click with the pad button, and scroll up and down with it. Everything works perfectly in VMWare though. I'll try reinstalling the drivers later today.

    edit: the pirate bay link worked fine for me yesterday, those are the drivers I'm using.
     
  13. damado macrumors 6502

    Joined:
    Aug 8, 2006
    #13
    I have one of the first 2006 mac Pros (vid card changed to an 8800GT) and just finished installing Windows 7 64 on a separate hard drive. I didn't use boot camp. I was also having that issue with the DVD boot up thing when it restarted.

    The trick was to hold down option key after the first reboot and boot into my vista installation. That then automatically came up with the option to boot to the vista 64 hard drive or the W7 64 installation hard drive. Each time I just did the same and there were no problems.

    For some reason both windows are on the same boot thing. I hold option on boot, only see my OSX drive and a windows drive, choose windows, then get another choice by microsoft to go into vista or W7 (each on it's own drive). Not a big deal but I guess this way does come out a bit different.
     
  14. cashel macrumors member

    Joined:
    Oct 30, 2006
    #14
    One thing I've noticed, when I go to system properties, it shows all of my ram (4gb), but it only shows 2.98gb usable. Why is this? This is one of the main reasons I installed x64 in the first place.
     
  15. cashel macrumors member

    Joined:
    Oct 30, 2006
    #15
    Still havent gotten the touchpad issue solved. What drivers are listed under the Apple touchpad drivers in the device manager? Do you have a tab on the bootcamp control panel for the touchpad, because I don't.
     
  16. Geek 2.0 macrumors member

    Joined:
    Mar 28, 2007
    #16
    Okay, I didn't find your post until, well, just now, but I did everything exactly the same as you defined (I did a LOT of research to try to get this working) and so after wasting 5 DVDs with bad "select CD-ROM boot type" errors and 2 bad burns in a row (really bad luck) I finally got a DVD of it that didn't have any burn errors and everything was working. But then I got a

    "Windows cannot install required files. The file may be corrupt or missing. Make sure all files required for installation are available, and restart the installation. Error Code: 0x90070570"

    If the burn verified correctly with the ISO it was burning, that should mean the ISO was wrong. But I did everything the exact same way (unless the folder names when remaking the ISO matter, because I used a different tutorial that was the same only with different file names... didn't seem to make a difference). I compared the DVD and the ISO and there is one difference; all the folders and file names on the DVD are in capitals. Could that cause the problem? Or are these files not case sensitive?

    Thanks for your help, I don't know why I'm putting so much effort into getting Windows... A waste of my time, I guess.
     
  17. cashel macrumors member

    Joined:
    Oct 30, 2006
    #17
    I ran into the same problem as you with that error message. I literally went through 5 or 6 dvds before I finally got a copy that would install. If you read a few posts up, I detailed how I got mine to work.
     
  18. Geek 2.0 macrumors member

    Joined:
    Mar 28, 2007
    #18
    I did that too, though, only I used 7zip... I'll list my steps below:

    1. Download iso
    2. Burn iso using Disk Utility
    3. Swear at computer for "select CD-ROM boot type" error
    4. Research and find out how to do it differently
    5. Swear at computer for again not working (this way doesn't matter)
    6. Research and find 3 folder + oscdimg method
    7. Make a DVD using that method.
    8. Swear at computer when DVD doesn't burn correctly, causing the installation to not work.
    9. Try again, this time with no burning errors
    10. Swear at computer when it claims it's missing files
    11. Go to macrumors forums (on second thought, this should have been step 1 instead of step 11...)

    Anything look fishy to you guys? (sorry if my steps aren't very descriptive)
     
  19. cashel macrumors member

    Joined:
    Oct 30, 2006
    #19
    Lol nice. Are you doing it in XP? I used 7zip in windows 7 (on my HTPC) when I first started and that just gave me coasters. I didn't try 7zip on XP in vmware because it wasn't installed, I just had winrar. Try extracting the iso with winrar, or even just mounting the iso and copying everything from it and pasting it in the folder.
     
  20. Geek 2.0 macrumors member

    Joined:
    Mar 28, 2007
    #20
    Tried it both ways already... first way I tried it was by mounting the iso in OS X and then copying the files into the virtual machine (Windows XP), but that didn't work (it might have worked, but the DVD didn't burn right, so I wouldn't know) then I used 7zip... I found out that it was the oscdimg that made everything all caps, so that doesn't seem to be the problem

    I'm out of solutions...
     
  21. macfan881 macrumors 68020

    Joined:
    Feb 22, 2006
    #21
    hate to bring this back up but thanks for this post man great job got it working so far making the iso now:D
     
  22. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #22
    alas, im afraid you are correct jav. i was looking forward to MAYBE being able to install the 64-bit version.. but i guess not.

    beatledud: thanks for the great tutorial. only wish i could use it:(
     
  23. bradnic macrumors newbie

    Joined:
    May 16, 2009
    #23
    Win 7 64 bit EFI boot on 2007 era core2duo MacBook Pro?

    Hi

    I've installed 64 bit win7 several times no problem. good instructions here thanks much. my particular problem though is I need more than 4 partitions, plus GPT for my triple boot setup. The only way to do it afaik (as far as i know) is by getting win64 to EFI boot. Anyone been able to do that on current gen macbooks? what about older ones?

    more detailed explanation:

    I've installed win7 64 multiple times but every time the install used the BIOS emulation. this means win 7 can only see 4 partitions on the drive. so why is this a problem? well you can buy a 2.5" 500GB WD passport at bestbuy now in the US for $120 out the door. Did just that but can't partition things the way I need for my triple boot setup (win7, leopard, ubuntu)

    I've seen some posts from a guy called VirtualRain around apple support site and others asking about EFI boot of Win64 on macbook pros. no answer unfortunately.

    http://discussions.apple.com/message.jspa?messageID=9423996#9423996

    anyone have suggestions or guidance here? again this isn't about modding the win7 64 install dvd. this is about getting win7 64 booting off EFI on a GPT partitioned drive.

    thanks in advance for help on this


    UPDATE GOOD INFO HERE
    best info I've seen yet here http://forums.macrumors.com/showthread.php?t=696523
    clean drive EFI install of win7 64 with EFI boot possible, but then you can't install OS X. ARGH.

    this is what I need help with! anyone? hackintosh gurus to the rescue??
     
  24. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #24
  25. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #25
    Thank you. Anyone trying to install 64-bit on a Core Duo after reading what I posted will just be wasting their time.
     

Share This Page