I deleted my Macintosh HD! help!

lisaThowsen

macrumors newbie
Original poster
Nov 13, 2018
2
0
ok, so i need help. I tried to reset my macbook 2017 to factory settings, but something went wrong. I restarted my mac in recovery mode and used disk utility to erase my disk, then i restarted my mac (without reinstalling MacOS, i know so stupid) and it just showed this symbol . So i restarted in recovery mode and tried to download MacOS. I says 6 minuttes left, and i left it overnight and i just says something went wrong. I tried several times more. I tried to delete my disk, recover, and use first aid, but it just says i failed and there is an internal problem. Please help, i need a genius! btw sorry it's in norwegian :((
 

Attachments


chabig

macrumors 603
Sep 6, 2002
5,879
3,140
You might have corrupted the internal drive. To fix it, you probably need to boot from an OS not on that drive—from the internet. Try cmd-opt-R at boot. If it boots over the internet you can repartition the drive back to a single partition which will also repair any damage, and then do an internet install which will also restore the recovery partition.

If that doesn’t work, find an external drive to boot from and then fix the internal drive.
 
  • Like
Reactions: phunigai

lisaThowsen

macrumors newbie
Original poster
Nov 13, 2018
2
0
You might have corrupted the internal drive. To fix it, you probably need to boot from an OS not on that drive—from the internet. Try cmd-opt-R at boot. If it boots over the internet you can repartition the drive back to a single partition which will also repair any damage, and then do an internet install which will also restore the recovery partition.

If that doesn’t work, find an external drive to boot from and then fix the internal drive.
Ok, thanks! how do i repartition the drive? :)
 

chabig

macrumors 603
Sep 6, 2002
5,879
3,140
Ok, thanks! how do i repartition the drive? :)
Actually, try to repair it first. In Disk Utility, select AppleAPFSMefia in the left column, then First Aid. If that fails, try the Partition button, set it to one and OK.