iMac (2013) problem - WiFi connects, but no internet

Discussion in 'iMac' started by JVNeumann, Jun 30, 2017.

  1. JVNeumann macrumors member

    Joined:
    Mar 23, 2017
    #1
    So just the other day, the internet on my iMac started playing up when I try to use WiFi. I can still connect to the WiFi signal (and can even access the router), but I'm getting no data, even though other devices in my house are functioning just fine. It does still connect to the net via ethernet though.

    I've already tried:
    - flushing the DNS cache
    - innumerable resets/power cycles of the router
    - removing all preferred networks and re-adding the network

    I'm at a loss as to what to do. Surely if the WiFi thingo were broken it wouldn't connect at all, right? If it helps, I had been using a VPN for a few days leading up to the issue.
     
  2. Stefan johansson macrumors 65816

    Stefan johansson

    Joined:
    Apr 13, 2017
    Location:
    Sweden
    #2
    Tried to check the settings in firewalls,internet security programs or similar?
     
  3. Ylan macrumors member

    Ylan

    Joined:
    Oct 27, 2016
    Location:
    Stockholm
    #3
    Try to remove the WiFi service in the network pane of System Preferences, and then add a new service!

    Humbly, Ylan
     

Share This Page