iMac (27", 2014): fuse keeps blowing in plug?

Discussion in 'iMac' started by Carl Sagan, Mar 23, 2016.

  1. Carl Sagan macrumors 6502a

    Carl Sagan

    Joined:
    May 31, 2011
    Location:
    The Universe
    #1
    Hi all,

    My 27" iMac' (bought brand new March 2014) fuse keeps blowing. It has run with no problem for two years then last week wouldn't turn on.

    We changed the fuse (reasoning it was likely that as the power panel its plugged into worked fine with other chargers) replacing the 10amp fuse with another 10amp.

    Tried turning the iMac on again yesterday and it's not turning on again and we think it's the fuse. Some questions:
    • Has anyone else experienced this with this model?
    • Can I use a higher map fuse to mitigate burn out?
    • Does Apple have a policy on this assuming it's a known issue?
    Would greatly appreciate any experience or pointers about this!

    Cheers!

    CS
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    I would recommend against putting in a higher rated fuse, as you'll not mitigate the issue, but cause a safety concern.

    If you are blowing a fuse, then there's something wrong, especially when it as working fine for years. Bring the iMac into Apple and have them look at it, clearly there's a short somewhere that is cause the fuse to blow.
     
  3. Carl Sagan thread starter macrumors 6502a

    Carl Sagan

    Joined:
    May 31, 2011
    Location:
    The Universe
    #3
    Hi Mike,

    Many thanks for your reply, I was hoping to avoid lugging the thing to an Apple store but looks like I've got not choice! Out of interest out of warranty do you have any sense of what it could cost for them to fix?
     

Share This Page