iMac is normally fast, but apps open VERY slowly

Discussion in 'iMac' started by j2p4h, Oct 12, 2016.

  1. j2p4h macrumors newbie

    Joined:
    Aug 6, 2008
    #1
    My iMac is form late 2013, but it has behaved quite strangely for most of its lifespan.

    It runs fine most of the time but anytime an app is opening, it takes between 2-5 minutes to do so.

    During this time, I can operate most open apps without any trouble. However, it has a number of side effects. Until the app has finished opening, notifications will not appear and any webpage being loaded will not finish loading.

    If I received multiple notifications while the app was opening they will appear in quick succession once it is done opening. Because I have a fair number of apps that open at startup this also means that my startup takes about 20-30 minutes after login where I cannot use my iMac until the apps have opened (having multiple apps open at once compounds the time). This is the case for ANY app (e.g. a crash reporter).

    I also have a MacBook Pro that was purchased around the same time as my iMac and it has no such problems, despite the fact that I run all the same apps. However, the MacBook Pro has an SSD and the iMac does not.

    I am very interested to know if anyone has experienced similar behaviour or if they know of a solution.

    Any help would be greatly appreciated. Thanks!

    macOS 10.12
    2.7 GHz Intel Core i5
    16 GB 1600 MHz DDR3
    Intel Iris Pro 1536 MB
     
  2. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #2
    Yeah, since El Capitan my old 2009 iMac has some issues with Chrome while I start say VLC, or Skype just takes a year to open, while the rest is fine.

    dtrace shows it's just poor programming on their end as it tries to do 'resolve all of this, before draw a window on that active part of the screen'. OSX moving to Metal didn't do much good for people like me with older iMacs.
     

Share This Page