iMessage haptic feedback help

Discussion in 'Apple Watch' started by ron7624, Jun 12, 2016.

  1. ron7624 Contributor

    ron7624

    Joined:
    Oct 14, 2011
    Location:
    Houston, Texas area
    #1
    hello Apple watch fans! I got my Apple watch a week ago and have found it very useful.
    I need help with iMessage. I use iMessage all day long to communicate with my family and friends. Always have. I have my watch set to provide haptic feedback on everything, and it does except on iMessage.
    I think I have all the right buttons pushed and even have my watch set to silent to force it to vibrate but it has not been doing that. I have rebooted my watch as well. What can I do to make it vibrate when I receive an iMessage? TIA
     
  2. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #2
    if the screen on your phone is currently on, the watch will not alert you for anything

    if you're still not getting alerts when your phone is locked and the screen is off, there are settings for messages in the watch app on the phone, make sure you've not accidentally disabled the them.
     
  3. ron7624 thread starter Contributor

    ron7624

    Joined:
    Oct 14, 2011
    Location:
    Houston, Texas area
    #3
    For the feedback. No I have everything set properly I have done a hard reboot and followed guides published on the web to fix....
    This was a gift and I do not think it has AppleCare but I guess I will walk into an Apple Store and see if the genius can help me. I have AppleCare on 3 computers and seven I devices, I will try to buy it for this but it's probably out of the warranty. As it was a hand-me-down gift.
     
  4. BarracksSi macrumors 68040

    BarracksSi

    Joined:
    Jul 14, 2015
    #4
    What waw74 was saying was, if you're using your phone when a message comes in, you're not going to get it on the watch. This is how Apple set up notifications -- they'll come to the device you're using at the moment instead of simultaneously pinging every iCloud-connected device you own.

    Have you got your Messages settings in the Watch app set something like this?
    [​IMG]
     
  5. ron7624 thread starter Contributor

    ron7624

    Joined:
    Oct 14, 2011
    Location:
    Houston, Texas area
    #5
    Yes I did understand and I do not have iMessages open on any other devices. Under my Apple Watch app I also have the settings exactly as you have them. Still no joy. Any other suggestions? And thank you for taking the time to reply
     
  6. BarracksSi macrumors 68040

    BarracksSi

    Joined:
    Jul 14, 2015
    #6
    Have someone text you, then don't pick up the phone. See if it comes in on the watch at all.

    So if the watch receives messages and puts them on the screen, but still doesn't tap your wrist, the next step would be to unpair and re-pair with the phone, taking the option to reset the watch as new. If you take it in to Apple, they'll ask if you already tried this.

    Because the watch taps for other notifications, it shouldn't be a hardware problem. Work on its software first, and most of the possible fixes can be done yourself.
     
  7. ron7624 thread starter Contributor

    ron7624

    Joined:
    Oct 14, 2011
    Location:
    Houston, Texas area
    #7
    Thank you for that reply I'll try all of this.
    I do receive the messages on the watch I can read and reply. No it is not a hardware problem because everything else works perfectly I get vibrations for everything except my messages, but I do see everything.
     
  8. ron7624 thread starter Contributor

    ron7624

    Joined:
    Oct 14, 2011
    Location:
    Houston, Texas area
    #8
    Okay, got it done!!
    On the iPhone, in the Watch app I went into My Watch and unpaired the watch. Then restored from my iCloud back up.
    iMessage now alerts me with a strong haptic on my watch when I get a message. Very Cool :apple:
    Thanks all for the help!:)
     

Share This Page