iMessage on Mac not showing contact names

Discussion in 'Mac Apps and Mac App Store' started by Hicksmat1976, May 16, 2017.

  1. SilkY SliM macrumors newbie

    Joined:
    Jun 27, 2018
    #251
    Like many, i've logged in simply to say THANKS and this definitely works for me, honestly it seems like years that this issue has slipped passed Apple updates.

    For any others having issues just drag and drop the downloaded file into terminal app then type "R:AUS +61000000000"

    or the country and country code relevant to you
     
  2. tomaseriksson macrumors member

    tomaseriksson

    Joined:
    Oct 3, 2010
    Location:
    Stockholm, Sweden
    #252
    Hero of the day! I been annoyed with this for so long and just now found this solution.
     
  3. scrodd macrumors newbie

    Joined:
    Jul 22, 2018
    #253
    Thx for all this info. This problem was driving me insane. This may not apply to everyone but here's what I did to fix it. I have outlook (O365) and have had my contacts in there forever. I also use the stock iPhone contacts app. I never had a problem with contact names coming up in iMessage on my old MacBook but I recently got a new one and only the numbers would come up. I tried a lot of the thing from this form but no luck. I eventually found that there were a couple of settings that I needed to change in the Contacts app, which I never use on the Mac, as I use Outlook. Annoyingly, the settings were in Contacts instead of iMessage, which is where I had devoted a lot of my time. I fixed it by going to: Contacts>Preferences>Accounts. Then I checked off the box that enabled Exchange (the account where my contacts resided I guess). Then I went to Contacts>Preferences>General and switched the default account to Exchange. As soon as I did that, iMessage had all my contact names in it again. It may not be the same problem everyone else had but hopefully it will help some of you.
    Screen Shot 2018-07-22 at 12.31.55 PM.png Screen Shot 2018-07-22 at 12.32.08 PM.png
     

    Attached Files:

  4. ikir macrumors 65816

    ikir

    Joined:
    Sep 26, 2007
    #254
    Thanks so much. I've ready many pages but not every post. The questions is... is Apple aware of this? average users need this to be fixed in next updates.
     
  5. jhill84 macrumors newbie

    Joined:
    Sep 6, 2018
    #255
    Just for continued feedback as of 9/6/18 on High Sierra 10.13.6 this doesn't seem to work with the US region. After inputing the prompt and inserting the region code I do get the two prompts for the password and select "Always Allow," but no dice even after a restart. I thought about getting calling Apple but it seems after reading here and many other places that's not going to offer a solution. If any other US users have had success with a workaround I'd be ALL EARS.
     
  6. Risco macrumors 68000

    Risco

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #256
    Mojave resolves this issue. Beta is very stable now.
     
  7. moontz macrumors newbie

    Joined:
    Sep 11, 2018
    #257
    This was it for me. Thanks for the idea!
     
  8. mjv617 macrumors newbie

    Joined:
    Sep 26, 2018
    #258
    I had the same problem: iMessage on Mac was showing phone numbers but not the contact name (while it was working fine on iPhone and iPad). I use Outlook for my contacts.

    My solution: go to Mac System > Internet Accounts > iCloud and uncheck contacts.
    (While System > Internet Accounts > Exchange keeps contacts checked.)

    Suddenly all names re-appeared on Mac Message.
     
  9. SohaibSdq macrumors newbie

    SohaibSdq

    Joined:
    Jun 28, 2018
    Location:
    Pakistan
    #259
    I just read all conversation, you saved my life, I just set my region and my contacts names are ok now. half of my contact with country code and the half without country code all contacts name are ok.

    thanks
     
  10. wonder-boy macrumors newbie

    wonder-boy

    Joined:
    Mar 15, 2011
    #260
    Thank you - this worked for me, has been driving me crazy for ever.
     
  11. Hicksmat1976 thread starter macrumors regular

    Hicksmat1976

    Joined:
    Jul 12, 2016
    Location:
    Middleton, England
  12. jammyr macrumors newbie

    Joined:
    Oct 12, 2018
    #262
    Thank you thank you thank you! This has been bugging me for over a year now. I thought Mojave might fix it , but it hasn't.

    Finally, all my contacts names appear exactly how the should do on Messages app on my MacBook Pro,

    Awesome,
     
  13. ecko26 macrumors newbie

    Joined:
    Nov 21, 2018
    #263
    HOLY CRAP! I fixed it on my computer. I am in the US and the regional issue was not the problem at all. I must've tried everything on every page of this forum--except downloading the program that was offered (for those with regional issues) because I was sure it was not the case with my problem. For me, it was the fact that the contacts stored on my iPhone, stored in iCloud, and stored in Contacts on my MacBook Pro were not all the same. I just had to "force a sync" of my phone contacts to iCloud. Then update my Contacts on my Mac from the updated iCloud.

    I can't believe it was something so simple and obvious, but seems to be. I was so frustrated with it that I joined this forum just to put this here. Thanks for leading me down the right path.

    Here it is step-by-step:

    Turn off iCloud sync on your Mac in the Contacts app (in preferences) and in the Apple>>Systems>>iCloud>>Contacts to be certain.

    Go to your iPhone:

    1. Turn OFF Contact sync on your iPhone. This is very important so you don't lose your contacts.
    2. Select Keep on My iPhone when asked what you want to do with your existing contacts.
    3. Log into iCloud (icloud.com) and delete all of your contacts from there. Just highlight them all and delete.
    4. Turn Contact sync back ON on your iPhone.
    5. If prompted, select the option to Merge contact information.
    6. This could take a few minutes to populate--took about 5 minutes for 149 contacts for me. Wait till it finishes.
    7. On your Mac, go back and turn on the iCloud sync in the Apple//Systems//iCloud//Contacts and then open the Contacts application and make sure it's turned on there, too, under preferences//accounts
    8. POOF! All the names that were on your phone are now all in the iCloud and they are synced with your Contacts application on the computer, which is where the iMessages application gets the names and you will now see names instead of phone numbers.

    This process effectively disables iCloud sync on your iPhone (step 1) while keeping a local copy of all of your contact information (step 2). This local copy is then re-uploaded to iCloud (step 4).

    Deleting your iCloud contacts (step 3) is safe as long as you've turned off iCloud sync -- iCloud always merges contact data when first enabling sync (or at least gives you the option to do so, depending on your iOS version), so the deletions made on the iCloud web site will not be propagated back to your device when turning sync back on (as long as it's off when you actually do the deleting).

    I hope this helps some of you guys with this extremely frustrating issue.
     
  14. jhill84 macrumors newbie

    Joined:
    Sep 6, 2018
    #264
    I just tried this twice, still to no avail. When the contact list is rebuilt on my macbook pro it is always the same 141 contacts, however I have 256 on my phone. This process makes sense to me, but it is still not working for me. I've tried every solution on this forum... I feel as though this is one of those things that you just expect an Apple product to do better than any other... so frustrating.
     
  15. ecko26 macrumors newbie

    Joined:
    Nov 21, 2018
    #265
    Dang! I was hoping my first reply would be positive, but here we are. First, I'm no Mac expert or anything (obviously, right), but there is something that's not syncing with either a setting you have somewhere or the way you've executed the procedure I did. I just re-did everything I said verbatim to see if I had made a mistake in the way I worded it (which is still a possibility), but I couldn't find any errors. Also, there is a disconnect in your iCloud/iPhone/iMessage/iContacts. There is no way to have that discrepancy (256/149) if you perform, exactly, the actions I say. If you said simply, "I tried it and it didn't work," that would be totally different and I would have no clue what to tell you. But, the fact that the contacts on your phone do not match what's on your Macbook, is exactly the same problem I was having. From what you describe, it sounds, to me, like you did not delete all the contacts from your iCloud (with your computer) when you signed out from your Apple ID on your iPhone. You have to sign out from your Apple ID. Put your phone away. Then sign into iCloud on your computer, delete ALL the contacts. Sign out of iCloud from your computer. Sign into Apple ID on your phone, then it will ask you if you want to "merge" contacts and say "yes."
     
  16. redhaven, Nov 28, 2018
    Last edited: Nov 28, 2018

    redhaven macrumors newbie

    Joined:
    Nov 28, 2018
    #266
    I am not in the UK but I solved this by adding my Google account to my contacts application on the Mac. I am not 100% sure why but my iPhone is creating new contacts in my Google account. I think this has something to do with the default contacts account in Contacts from the iPhone settings menu. My default contacts was actually set to an old employer email. You would think if that account is not active, it would default to iCloud but I guess it is possible it selected the first one alphabetically or something.

    On your iPhone, go to Settings > Passwords & Accounts
    Check to see which accounts are syncing contacts (listed underneath each one)
    Then go to your Mac and open the contacts app. Go to Contacts in the top menu and select Accounts to make sure every account that your phone is using is in the list on the left.

    You can check your default contact app by going to Settings > Contacts on your iPhone.
     
  17. swanseaboy macrumors member

    Joined:
    Oct 15, 2012
    Location:
    Swansea, Wales
    #267

    Thank you!
     
  18. Sass87 macrumors newbie

    Sass87

    Joined:
    Dec 25, 2018
    #268
    --- Post Merged, Dec 25, 2018 ---
    My sister got a new MacBook for Christmas and was having this same issue. In the contacts application, she had two contacts lists: “All iCloud” and “All On My Mac”. When she synced her phone and laptop, they all went on her iCloud, but not the Mac contact list. We just dragged and dropped the ones from the Cloud onto the Mac contact list, restarted the laptop, and it worked.
     
  19. hybridstyle macrumors newbie

    hybridstyle

    Joined:
    Dec 25, 2018
    Location:
    Santa Clara, CA
    #269
    I have been following this thread for over a year now and nothing ever worked. I have multiple Apple computers and just recently I found a solution and it worked on ALL my computers.

    First, I have to mention that I use Google Contacts and sync that with my computers and devices.

    Second, go to Systems Preferences on your Apple computer.

    Third, in Systems Preferences click on Internet Accounts.

    After clicking on Internet Accounts you will see a few web service companies including Google. Select Google on the left-hand side of the window. Then on the right-hand side of the window, you will see options for Google to sync with your computer such as Mail, Contacts, Calendars, and Notes. I personally use all the options that they provide and selected all of them.

    Next, you will have to sign into Google. Sign in to your Goole account in the Internet Accounts window using your Google email and password. After logging in wait a few minutes and then restart your computer. This should work. As I said, this is what I did and it worked on ALL my computers.
     
  20. ddevil226 macrumors newbie

    ddevil226

    Joined:
    Feb 7, 2019
    #270
    THANK YOU!! This has fixed the issue that Apple were clueless about. Every box was ticked, so I unticked and re-ticked and all of my contact names returned within the iMessage app!

     

Share This Page