iMessage on Mac not showing contact names

Discussion in 'Mac Apps and Mac App Store' started by Hicksmat1976, May 16, 2017.

  1. tarsins macrumors 6502a

    tarsins

    Joined:
    Sep 15, 2009
    Location:
    Wales
  2. Hicksmat1976 thread starter macrumors regular

    Hicksmat1976

    Joined:
    Jul 12, 2016
    Location:
    Middleton, England
  3. jjppp6 macrumors member

    Joined:
    Jul 8, 2008
    #203
    I've found a fix.

    If you change the numbers from +44 to 0 it displays the name instead.
     
  4. ipabuilt macrumors newbie

    Joined:
    Jan 6, 2018
    #204
    Same issue here. Some addresses randomly won't appear as options when using share/iMessage. I managed to fix it by deleting the "missing" contact from my address book on my iPhone and reentering as new contact. A bit annoying, but easy enough to remedy.
     
  5. mvmendez macrumors newbie

    mvmendez

    Joined:
    Jan 8, 2018
    #205

    This is exactly what my problem was! Fixed! Thanks!
     
  6. eastcoasthiker macrumors newbie

    eastcoasthiker

    Joined:
    Jan 14, 2018
    #206
    I tried this, with no success. But I couldn't do the steps as described. Can someone help me?

    1. First, on my Mac, I don't see "iMessage", I see "Messages". I did go to "Messages account preferences and sign out.
    2. I click on a message that I know is from another iPhone user (ie an iMessage), and the conversation showed up in the right hand side of my Messages window. Does that mean the iMessage is "Open"? If not, how do I open the iMessage? Double clicking on the message just made the whole window bigger, but no change in the view.
    3. I could not get a blank contact card to open, either by using the "Buddies" menu bar, or by using the short cut keys. Because I was signed out, when I click on Buddies, all the menu options are greyed out. I also tried all the steps except the first signing out stage, and when I use the keystrokes, the Buddies menu item flashes, but nothing happens. When I click on the Buddies menu item, the only ones not greyed out are : Create new contact, Send file, and three different calling options (FaceTime,etc). There is no "Show Contact Card" menu item. If I click on "create new contact, nothing happens. So this step doesn't seem to work at all. I cannot get to the point of viewing the contact card. Also, the keystroke sequence doesn't open Contacts, so, step 4, 5 and 6 cannot be done.

    In short, the steps outlined above don't work for me. So disappointed; I want this situation fixed so badly.

    One other thing I found when I was trying that may be connected:

    When I opened up Contacts on my Mac, under "All Contacts", only one contact is showing. When I select the various accounts (iCloud, gmail), all of my contacts show up in the list. Why aren't they all showing under "All Contacts'? All of the accounts are enabled.
     
  7. TexasChance macrumors newbie

    TexasChance

    Joined:
    Jan 14, 2018
    Location:
    Magnolia, Texas
    #207
    SOLVED (at least for me)

    I fixed mine. Read the first four pages of the thread and didn't have luck so I rolled my sleeves up and put my hat on backwards. I was having the exact same problem as everyone. Just bought a new iMac to go along with the one I got last year. Same OS (high Sierra latest) same damn near everything. I had them side by side and all check marks were the same but I had numbers on the new one and names on the old. And it was totally a Google thing.

    My solution was to go to Settings-->Internet Accounts. Highlight your Google account and click the little minus button (-) to nuke that bad boy. Then click the plus (+) button and add it back. Unselect everything then only select Contacts and click done or OK or whatever the hell it is. I did that and most all of my contacts came back magically.

    Most all. But not all. I looked at the ones that didn't populate and realized they had all been added in the last couple years. Aha! About two years ago I switched my primary email to my personal one. my @texaschance.com account that is set up through G-suite. Nuked it in Internet Accounts, added it back, and my contacts are all there in all of their glory.

    If I restart and they aren't there then I will do it again and trust the Apple Overlords to fix it in their good time. They are pretty good about addressing things that are this ubiquitous.

    Side note - I have read comments in this forum for years but only added an account today to, hopefully, solve a problem you good and helpful people are having.

    (edit - I spelled least wrong. Leat is not a word, Chance)
     
  8. acgeisen macrumors newbie

    Joined:
    Jan 16, 2018
    #208
    THIS WORKED!!!! I have been trying to figure this out for nearly a year, and this solved it. I created this account just so I could leave this message and thank you for posting it!
     
  9. eats goots macrumors newbie

    Joined:
    Jan 20, 2018
    #209

    How did you add your Google contacts to your Mac? I think that's my problem too!

    Thanks!
     
  10. bSr43 macrumors newbie

    bSr43

    Joined:
    Dec 19, 2016
    #210
    Hi,

    I also had this problem, and I finally found a way to fix it without changing my contacts!
    This is not an easy fix, so I wrote a small utility, and set up a GitHub project.

    The main page: https://github.com/bSr43/FixIDSRegion
    The pre-compiled binary can be downloaded here: https://github.com/bSr43/FixIDSRegion/releases

    It worked for me, but I cannot guarantee that it'll work for everyone... use it at your own risks...
     
  11. newtonuk macrumors member

    newtonuk

    Joined:
    Jun 17, 2005
    Location:
    West Yorkshire, UK
  12. richatkinson macrumors newbie

    richatkinson

    Joined:
    Jan 25, 2018
    Location:
    Troon, Scotland
    #212
    FNG here. Apologies in advance if this has been solved. This was happening to me a few days ago and discovered a solution by chance. It's to do with (not only iMessage) but FaceTime. The same thing happens when you use a temp number on your iPhone. As you probably already know, it syncs with your iCloud and assigns/locks it to your Apple ID and both iMessage/FaceTime. On your Mac, go to the iMessage/FaceTime preferences and sign out. When signing back in, recheck the number on both ensuring your FaceTime location is set to the U.K and not the U.S.
     
  13. arohl macrumors newbie

    Joined:
    Jan 28, 2018
    #213
    Worked a treat for me - THANKS!!!!!!

    Only suggestion is that you add the

    && killall identityservicesd && killall imagent

    to the help within the program
     
  14. tarsins macrumors 6502a

    tarsins

    Joined:
    Sep 15, 2009
    Location:
    Wales
    #214
    Confirmed that it works for me too in the UK. Excellent stuff.
     
  15. Ruggy macrumors member

    Joined:
    Jan 11, 2017
    #215
    The 'maybe' problem is definitely fixed by going into contacts and changing the number from beginning with '0' to beginning with '+country code'.

    So if your number is 06... and you are in the UK you change it to +446....
    I have done this and it works instantly every time.
     
  16. Risco macrumors 68000

    Risco

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #216
    Just tried this, will it only fix new messages? I tried and my current messages are still showing just the number.
     
  17. riccardodalessio, Jan 31, 2018
    Last edited: Jan 31, 2018

    riccardodalessio macrumors newbie

    riccardodalessio

    Joined:
    Oct 27, 2017
    #217
    Worked for me

    EDIT
    Advice for everyone,
    Open the terminal in the same directory as the script.
    The example commands as wrote in the readme are:
    ./FixIDSRegion R:IT +390000000000 (for Italy, modify it according to your country)
    killall identityservicesd
    killall imagent
     
  18. bSr43 macrumors newbie

    bSr43

    Joined:
    Dec 19, 2016
    #218
    I just released another version (1.1). Now you can skip the second part of the process (the "killall" commands).
    --- Post Merged, Jan 31, 2018 ---
    Which arguments have you provided to the command? After the FixIDSRegion command, don’t forget to kill the running daemon, or reboot your computer if you prefer. If should work with all the conversations, the new and the old ones.
     
  19. Feek macrumors regular

    Feek

    Joined:
    Nov 9, 2009
    #219
    This worked perfectly for me, thank you. I ran the script, closed and reopened iMessage and now everything looks as it should. Thank you very much indeed.
     
  20. Risco, Feb 1, 2018
    Last edited: Feb 1, 2018

    Risco macrumors 68000

    Risco

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #220
    Ok figured it out, your instructions are too ambiguous for someone who is not a programmer. I thought I needed to double click and that was it. However your program does work, so thanks.

    For others, these are how to make it work:

    • Download the pre-compiled zip to your desktop
    • Open terminal
    • Type FixIDSRegion R:UK +4400000000000 (replace UK for your region and +44 for your international code)
    • Press enter
    • Input password as required
    • Open terminal
    • Type killall identityservicesd
    • Input password as required
    • Type killall imagent
    • Input password as required.
    • Open iMessage and all will be fixed.
     
  21. bSr43 macrumors newbie

    bSr43

    Joined:
    Dec 19, 2016
    #221
    You're right, information were ambiguous.

    To summarize, download, and unpack (if Safari doesn't do it for you automatically) the ZIP file at https://github.com/bSr43/FixIDSRegion/releases

    You need to launch the program using the Terminal application, which is located in the "Utilities" folder of the Finder. You can reach this folder by pressing ⌘⇧U in the Finder, or using the Finder's menu "Go > Utilities" (I don't have the correct English translation, as my system is installed in French, sorry about that).

    Once launched, you can drag and drop the FixIDSRegion utility into the Terminal window: this will paste the exact location of the program on the disk. You'll probably see something like:
    "/Users/yourname/Downloads/FixIDSRegion" appearing in the window.

    Add the arguments to this command, ie, something like:

    R:FR +330000000000

    The exact arguments depend on the region where you live. If you are in the UK, it would be "R:UK +4400000000000", etc. The first part is the "R:" string, followed by the country, and the second part is a template international number for the country.

    Once done, press enter. You'll be prompted to enter your password: this is to allow the program to modify a key on your behalf in the Keychain system program.

    After that, launch Messages. You'll, once again, be asked for your password: this is because the key has changed, and now, you just need to allow Messages to access it again. So, in this case, choose the option to always allow access to the item (once again, sorry about that, I don't know the exact sentence in the English version).
     
  22. edmooredop macrumors newbie

    edmooredop

    Joined:
    Feb 14, 2018
    #222
    This worked for me - thanks so much!

    Anyone reading from the UK, the usage was FixIDSRegion R:UK +4400000000000 and all working now. Had to restart iMessage to see correct names.
     
  23. CaTOAGU macrumors 6502a

    Joined:
    Jul 15, 2008
    Location:
    Manchester, UK
    #223
    Many Thanks.

    This worked for me also.
     
  24. user1234 macrumors 6502a

    user1234

    Joined:
    Mar 3, 2009
    Location:
    Sweden
    #224
    Thank you!!! I finally have contact names displayed again!
     
  25. mswanston macrumors newbie

    Joined:
    Mar 1, 2018
    Location:
    West Sussex, UK
    #225
    Brilliant! Been bugging me for ages and following this thread, thanks for fixing this and making it accessible to others. I ran it on my MBP and it worked for 3 out of the 4 contacts I have existing messages from, looked at the 4th contact and can’t see anything different to the others, yet still shows it as +447...
    Yet to try it on my iMac, but thought I’d ask the question as to why it doesn’t work for all? Am I missing something?
    Thanks again
    Martin
    --- Post Merged, Mar 1, 2018 ---
    Not ideal but exporting the contact to PDF, deleting and then re-adding as a new contact fixed the issue. Must have been something about the original contact? Thanks again.
     

Share This Page