Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

chris1111

macrumors 6502
Original poster
Jul 8, 2015
418
1,004
Montréal Canada
OTA from B8 to B9 took less than 40 min.

I really am considering the switch to Monterey when Apple releases it later this year. I am planning on keeping both Big Sur and Monterey running on the same SSD (2TB) with duplicate Data volumes for a while and then, around 12.1, get rid of Big Sur.

Thanks, @chris1111

Thanks @macpro_mid2014
I have already switch since I install the first Beta :D
Another easy Update here

Screen Shot 2021-10-07 at 10.21.49 AM.png
 
  • Like
Reactions: macpro_mid2014

Tronstar

macrumors member
Aug 7, 2021
43
23
Easy update BETA 7 without any trouble here :D , no loop just a couple reboot then Voila
I have Update the EFI for Beta 7 Monterey on Github
I am really happy of the result, everithings work without any system patch its a Genuine MacBookPro :D

View attachment 1840181
Well yours / ours always was a genuine MBPr. It’s Apple that pushed it in the Hackintosh scene for the ones that wanted the upgrade. This MacBook is still fast today. I think in case of this particular MacBook Pro that their choice to exclude it from MacOS 12 is pure marketing.

Still waiting on the final release to upgrade mine. I’ll keep you posted and share my results here!
 
  • Like
Reactions: macpro_mid2014

samiqa

macrumors member
Apr 9, 2015
36
20
Do this method work on Macbooks with dGPU ?
I have mid 2014 with nvidia gpu , and it's drivers were stripped in beta 7
I don't know if I should precede with it as it looks in post #1 and #9 that you have only iGPU
thanks
 
  • Like
Reactions: Tronstar

samiqa

macrumors member
Apr 9, 2015
36
20
Try it then let me know
for post Install and the drivers Kepler its not a problem See Geforce Kepler Patcher
Just updated from Big Sur 11.6.1 to Monterey 12.0 Beta 9 with a success
small issue I faced that wasn't in Big Sur is the sound quality looks very bad like muffled or crackling
what can this be related to ? different Audio driver ? bug in the beta itself ? do Graphics Drivers have something to do with audio ? may I have done something wrong when using some nvram commands to switch between iGPU/dGPU ?
 

macpro_mid2014

macrumors 6502
Oct 21, 2019
376
327
Toronto, Canada
OTA update from B9 to B10 without any issues. Again, few boots and a single 10-minute progress bar and the login prompt.

Everything working fine, BUT I'll be REALLY tempted by the Monday event... o_O
 
  • Like
Reactions: chris1111

RomaM65

macrumors newbie
Jun 25, 2014
6
3
Ukraine, Kharkiv
Does this method work with new beta versions (7,8,9) where Kepler drivers are removed?
(USB Install)
The installation of the system does not complete, the apple logo is on the screen, but the system works, there is a sound
 
  • Like
Reactions: macpro_mid2014

macpro_mid2014

macrumors 6502
Oct 21, 2019
376
327
Toronto, Canada
Does this method work with new beta versions (7,8,9) where Kepler drivers are removed?
(USB Install)
The installation of the system does not complete, the apple logo is on the screen, but the system works, there is a sound

This method is for people without any "special" needs (OC running with minimal tweaks).

In your case, I think these are your options:

1- Use OCLP and root patch your system after installation (check Mr. Macintosh Youtube channel - he explains how to patch an MBA 2013 with HD4000).

2-Do 1 above AND customize the Kext folder by excluding everything not related to the Kepler and apply the changes to the config file.
 

Tronstar

macrumors member
Aug 7, 2021
43
23
Hi @chris1111,

Your solution worked for me. What I did:

1- Generated an EFI folder using OCLP 0.2.4;
2- Removed all Kext files from Kexts;
3- Added HfsPlus.efi on Drivers (OpenCanopy.efi, OpenRuntime.efi, and HfsPlus.efi);
4- Added CleanNvram.efi in Tools (BootKicker.efi, OpenShell.efi, and CleanNvram.efi);
5- Removed ALL PCI in <key> including the key for brcmfx-country from DeviceProperties in config.plist;
6- Fine tuned config.plist to reflect all my previous changes (spoofing a MacBookPro11,4).

I started by booting a CCC clone of my main internal SSD (Thunderbolt 2 Lacie SSD) and enrolling it in the Public Beta software program. I went from Public Beta 4 to Public Beta 5 using OTA and 2.54 GB download in Software Update.

I hope this helps someone else.

Thank you,
Thanks!
Would you like to share your config.plist file to spoof a MBPr11,4 ?
 
  • Like
Reactions: macpro_mid2014

Tronstar

macrumors member
Aug 7, 2021
43
23
How to install macOS Monterey on a MacBook Pro retina late 2013
Without patcher, without any kexts files. Genuine macOS booting with OpenCore SIP activate
Probably work on other Mac? Please confirm this solution if its work for you
Confirm works on MacBook Pro (Mid 2014)

Download files ➤ EFI Monterey 12
Credit: Acidanthera

View attachment 1817251


Create install Media of Monterey put the EFI folder on EFI Partition of USB installer then boot from option select EFI USB install Media on the OpenCore menue Icons, select ClearNvram
View attachment 1817035

and Reboot the system ➣ TAB
Reboot
View attachment 1817036


Reboot again Option EFI USB install Media select Install macOS Monterey
View attachment 1817037


Formate the Disk then Install macOS

Reboot again Option EFI USB install Media, select macOS Installer then complet Installation
NOTE : You have to boot multiple time on macOS Installer.


Reboot again Option EFI USB install Media, select your Disk to complete installation
You have to boot twice on the disk to complet

Post Install ⬇︎
Mount the EFI Partition of the SSD then put the EFI Folder then unplug USB Install media


Done! Enjoy.
After everything is finished, you can remove the -v in the config.plist to have the apple at boot.

- Looking for other OpenCore boot theme ➤ My-Simple-OC-Themes

My boot disk

View attachment 1817092

Desktop Monterey
View attachment 1817093


HWMonitor
View attachment 1817098

If you want make your own EFI OC I strongly advise you to compile OpenCore from source here ☞ OpenCorePKG

and use the output files in OpenCorePkg ➤ / Binaries ➤ / OpenCore-0.7.3-RELEASE.zip unzip the file and everything is there : DOC , EFI , Utilities
Read the DOC You don't need nothing else
View attachment 1826727
Just looking in to it to prepare mine with dedicated GPU.
I was wondering if you have the dedicated GPU? Your system specs screenshot doesn’t say so I think.

Anything worth mentioning for those who do have?
 

macpro_mid2014

macrumors 6502
Oct 21, 2019
376
327
Toronto, Canada
This is surely not the config from my EFI on github because this config is not good, you can not open it with Xcode
You have to chek your file
Thanks, @chris1111! I will do that!
I never used Xcode to open it. I used a regular editor (Visual Studio Code) to edit it and this is the config file I've been using so far without any issues.

When I created it, I used OCLP to generate a config.plist and then, I stripped everything "extra". Maybe, this is why it has problems... 🧐

The complete EFI partition is attached...

I am planning to download OC and compile/customize it to my MBP once Monterey is release.
 

Attachments

  • EFI Partition (Lacie).zip
    1.3 MB · Views: 99
Last edited:
  • Like
Reactions: Tronstar

macpro_mid2014

macrumors 6502
Oct 21, 2019
376
327
Toronto, Canada
btw. Did you populate it yourself or did you get it from somewhere?
When you compile OC, it generates the folder structure with Kexts on Kext folder and everything else.

The goal here is to run OC without any Kexts because these types of computers (2013/2014 MBP/A) don't need any special kext to run Monterey natively.

I think that with the death of Kepler GPUs in Monterey, one can still benefit from this thread by injecting ONLY the appropriate kext in the kext folder (root patch) + modify the config.plist file appropriately and get rid of all the other Kexts generated by OC
 
  • Like
Reactions: Tronstar

DmitryZ

macrumors newbie
Jun 30, 2019
21
6
Ukraine
Hi :)
Thanks for the instruction - working perfectly macOS 12.0 (21A5552a) on macbook pro 11.2 (mid-2014). I install Beta Monterey above BigSur (please create CCC backup before any operations).
1. I download EFI folder from macpro_mid2014 attached, but update opencore to 0.7.4 and place to my EFI partition on laptop.
2. Run sudo /System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil enroll PublicSeed (from macpro_mid2014 messages) and reboot.
3. Check updates from System Preferences, receive update and run installation. That's all. All app still present and working. Thanks :)
p.s. This is bad way, casue may be better run clean installation, but working(please create CCC backup before any operations). Please usage if you want check you device for working Monterey and waiting new m1x(m2) laptops. ;)
 

Attachments

  • Снимок экрана 2021-10-17 в 11.49.16.png
    Снимок экрана 2021-10-17 в 11.49.16.png
    632.1 KB · Views: 238
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.