Installed Samsung 850 EVO shows only 950MB of free space.

Discussion in 'MacBook Pro' started by paulojbarbosa, Mar 26, 2018.

  1. paulojbarbosa macrumors newbie

    Joined:
    Mar 26, 2018
    #1
    Hey, everyone!

    I have just installed a 250 GB Samsung 850 EVO as a second drive on my Mid-2012 Macbook Pro. Now this hard drive was purchased second hand from a re-seller. I removed the optical DVD drive and replaced it with the SSD using a caddy.

    The Mac can see the drive, but it says that its capacity is just about 950MB. I think that this could maybe be related to allocated and unallocated space? Although I'm not really that tech savvy. Any ideas of what is going on, and what I can do to fix it?

    Many thanks for any help! ;)

    I'm running macOS High Sierra (10.13.3)
     
  2. chscag macrumors 68030

    chscag

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    Did you format the EVO after placing it in your MacBook Pro? Since it's not the primary drive, you should be able to format it as HFS+ or APFS. It's possible the drive contains data or hidden files which is why the capacity is only showing up as 950MB. Use Disk Utility to do an erase and then format. Also check to see if there aren't any partitions remaining on the drive. That should show up in Disk Utility.
     
  3. paulojbarbosa thread starter macrumors newbie

    Joined:
    Mar 26, 2018
    #3
    Thank you very much for the reply! Well, I opened Disk Utility and that's where I managed to find it. I tried erasing the drive several times and used different formats, although I don't see the option for APFS. So I tried EX-FAT, HFS+ and FAT32, but all of them show the same space.

    Here's a screenshot of what it looks like:
    https://ibb.co/jqQT0S
     

    Attached Files:

  4. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #4
    There is a long history of problems with putting SATA3/6G devices in the optical bay of 2011/2012 which was only designed as SATA 1 for the optical drive. Scroll down this link and look at OWC's warning in red. However there are reports that the mid 2012 MBPs don't have this so you may be lucky.

    You could try formatting the drive with diskutil in Terminal which is more powerful than the Disk Utility app.

    Open Terminal
    Type diskutil list
    Note the number of the disk you want to erase.
    Type diskutil eraseDisk JHFS+ Untitled /dev/diskn where "n" is the number you noted above.

    Google format disk with Terminal for lengthier articles.
     
  5. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #6
    OWC added the warnings about using the optical bay for the 2012 at some point. It wasn't always there. I don't know what prompted them to do that. I have the 2012 MBP and don't have problems with it (both SSD's have the correct size) and I have not seen posts of people having problems with the 2012 optical bay.

    It would be helpful if you posted the results of the "diskutil list" command mentioned in post #4. Otherwise, it's difficult to know what's going on with your disks just by the screenshot you posted.
     
  6. paulojbarbosa thread starter macrumors newbie

    Joined:
    Mar 26, 2018
    #7
    Hey, there!

    I tried the diskutil in the terminal. Great suggestion as the list showed the identifier for the hidden storage. I managed to erase and format using HFS+ and I can now see it and use it as normal.

    I appreciate all the help! It was a great suggestion.

    Cheers
     

Share This Page