iOS 10 - IWork apps not working on new iPad Pro

Discussion in 'iOS 10' started by Starvision1970, Jun 22, 2016.

  1. Starvision1970 macrumors newbie

    Joined:
    Jun 14, 2016
    #1
    Hi,

    I have just installed the iOS 10 Developer Preview on a new iPad Pro.

    After the installation the following native apps do not launch:

    • Keynote
    • Pages
    • Numbers
    • iMovie
    • iTunesU
    • GarageBand

    The app window opens for just a split second and then disappears.

    Have any body experienced something like this?

    Thank you.
     
  2. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #2
    Try rebooting your device (holding the Power button and Home button together until the Apple logo appears.

    All those apps launch and run on my iPad Pro 12.9" on iOS 10 beta. (Couldn't check iTunes U because I removed it, but I would assume it would also launch and run if all the others have as well)
     
  3. Starvision1970 thread starter macrumors newbie

    Joined:
    Jun 14, 2016
    #3
    Hi lagwagon,

    Thank you for your suggestion.
    I tried that, but they still didn't work.
    I was able to making Pages, Keynote and Numbers work by uninstalling and reinstalling them, however iTunesU was not fixed by this.

    I don't really know what else to do.
    Maybe I just have to wait that's a more stable beta comes out or Apple updates their apps.
     
  4. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #4
    A better beta build will happen far sooner than Apple releasing an update to the apps for iOS 10.

    Apps with new OS specific updates can't be released until the OS itself is released.

    Something else might be causing it. All the apps launch and work on my iPhone 6 and iPad Pro and I'm sure they do for many others. So it isn't a widespread issue and something more isolated.

    Another thing to try is to reset your settings (Make sure you don't do the reset and wipe) under Settings > General > Reset > Reset All Settings. (Again do not accidentally tap Reset All Content and Settings)

    It might be a bit of a pain having to redo your settings (depending on how many you've tweaked) but it usually does the trick for quite a few issues when updating the OS.
     
  5. DaveOP macrumors 6502a

    Joined:
    May 29, 2011
    Location:
    Portland, OR
    #5
    These all work just fine for me on an iPad Pro 9.7 running Dev Beta 1. Downloaded each app just to make sure. Your problem is more device specific, and probably needs some troubleshooting. Have you deleted and re-downloaded each? Have you tried resetting settings as the poster above mentioned?
     

Share This Page