iOS 10 Remove EU Volume Limit

Discussion in 'Jailbreaks and iOS Hacks' started by JDrummond, Mar 9, 2017.

  1. JDrummond macrumors newbie

    Joined:
    Dec 17, 2014
    #1
    Hi all,

    Has anyone had any success with disabling the EU Volume limits in iOS 10? Having jailbroken on 10.2, I've tried the various methods which were successful in iOS 9, but these don't seem to have carried over as functional tweaks. As a summary of what I have explored:

    1. Using the option in "mikoto" - seems to have no effect at all.
    2. Installing the Flex 2/3 tweaks
      • "No Eu Volume Limit ios 9.0.2" - disables the visual warning yellow and red limits on the HUD, but again, no effect on volume.
      • "No EU Volume Limit + Volume Boost [Beta]" - disables the visual warning yellow and red limits on the HUD, but again, no effect on volume.
    3. Manually editing the plist files in:
      • /var/mobile/Library/Preferences/com.apple.celestial.plist
        • "canExceedEUVolumeLimit" set to "true"
        • "volumeLimits" dictionary
          • Set to "1.3", but resets to the default of "1" again following a reboot.
      • /System/Library/Frameworks/MediaToolbox.framework
        • Default, N61, N71, N71m
          • EUVolumeLimits.plist
            • "HighVolumeLimit" set to "1.2" - Persists following reboot, but has no effect.
            • "LowVolumeLimit" set to "1.2" - Persists following reboot, but has no effect.
          • RegionalVolumeLimits.plist
            • "HighVolumeLimit" set to "1.2" - Persists following reboot, but has no effect.
    Does anyone happen to have any ideas?

    Thanks

    Jacob
     
  2. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
    #2
    Can't you just turn it off here, or am I missing something?
     

    Attached Files:

  3. JDrummond thread starter macrumors newbie

    Joined:
    Dec 17, 2014
    #3
    You're missing something. That's the "recommended" level, which is even lower than the EU imposed restriction. Regulations imposed by the EU, limits the headphone output to a certain level so that we're not allowed to damage our ears. This is something our friends in the US are not restricted to in their flavour of iOS. It's been the same in all prior versions of iOS too, hence why people have made the above tweaks in the past.
     
  4. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
  5. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #5
    I am really curious about the "imposed restrictions by EU", and the "recommended level" of headphone output, cause I almost always keep mine at half point of max volume to eliminate "suprise" during using headphone.
    Mine is bought from AU, and does not have that setting in "volume limit".
     
  6. Johnluke91, Mar 10, 2017
    Last edited: Mar 10, 2017

    Johnluke91 macrumors member

    Joined:
    Jul 9, 2016
    Location:
    Italy
    #6
  7. anyjungleinguy macrumors regular

    Joined:
    Mar 6, 2012
    #7
    Have you got a source for this? I can't find anything on it.
     
  8. JDrummond thread starter macrumors newbie

    Joined:
    Dec 17, 2014
    #8
  9. stevenhadjez macrumors newbie

    Joined:
    Mar 13, 2017
    #9
    Hey JDrummond. Thanks for pointing me to this thread. I have exactly the same situation described in your original post. Word for word.
    Hope someone can help us out !!!!
     
  10. stevenhadjez macrumors newbie

    Joined:
    Mar 13, 2017
    #10
  11. JDrummond thread starter macrumors newbie

    Joined:
    Dec 17, 2014
    #11
  12. stevenhadjez macrumors newbie

    Joined:
    Mar 13, 2017
    #12
    Yeah no luck for me either. Ive tried everything as well. Are you testing with cabled headphones or bluetooth? Ive been testing for results only with my AirPods, maybe thats an issue...
     
  13. JDrummond thread starter macrumors newbie

    Joined:
    Dec 17, 2014
    #13
    Cabled EarPods.
     
  14. stevenhadjez macrumors newbie

    Joined:
    Mar 13, 2017
    #14
    I just found this thread which was active all week. Its in german but google translate does a pretty good job. theres this guy who made some discovery about the iPhone 7. apparently theres only one file that matters

    http://iszene.com/thread-182560-page-2.html
    --- Post Merged, Mar 13, 2017 ---
    The part that has me curious is that one guy says you need a reboot not a respring. He claims he tested and the respring is not enough and it only works after a full reboot. Personally, im jailbroken on yalu and its semi untethered. So after a reboot I have to re jailbreak. Do you think it could be a reason?
    By the way, are you on iPhone 7 or lower ? Maybe its only on iPhone 7 that it does not work.
     
  15. JDrummond thread starter macrumors newbie

    Joined:
    Dec 17, 2014
    #15
    I've always done a reboot, as that is what has always been required in my experience. I am using an iPhone 6. The instructions seem to be exactly the same as the previous link, though again, I do not see a difference.
     
  16. stevenhadjez macrumors newbie

    Joined:
    Mar 13, 2017
    #16
  17. Johnluke91 macrumors member

    Joined:
    Jul 9, 2016
    Location:
    Italy
    #17
    I thought you might try changing the string "canexceedeuvolumelimit" in the celestial.plist, putting "false" instead of "true".
     
  18. Makale.Helvetia macrumors 6502a

    Makale.Helvetia

    Joined:
    Sep 14, 2014
    Location:
    İSTANBUL - TÜRKİYE
    #18
    anybody tried on ios 11 betas? or still no way to break this volume limit on ios 10-11
     

Share This Page