iPhone iOS 13 - Cannot Connect to App Store

Helmsley

macrumors 6502
Original poster
Sep 4, 2017
260
72
United Kingdom
Since updating to iOS 13 on my 8 Plus, I cannot get on App Store. I have tried restarting, signing out and even restoring my phone.

The app hangs for ages before saying "cannot connect to App Store". Same with iTunes Store.

Is this a known issue?

I have checked everything. Mobile data is enabled too. Does not work I'm WiFi either.
 

digitalexplr

macrumors 65816
Dec 13, 2016
1,174
736
Central Missouri
Since updating to iOS 13 on my 8 Plus, I cannot get on App Store. I have tried restarting, signing out and even restoring my phone.

The app hangs for ages before saying "cannot connect to App Store". Same with iTunes Store.

Is this a known issue?

I have checked everything. Mobile data is enabled too. Does not work I'm WiFi either.
May be updates on the server side. Just wait a bit and try again. I’m having no issues getting to stores.
 
  • Like
Reactions: Helmsley

Helmsley

macrumors 6502
Original poster
Sep 4, 2017
260
72
United Kingdom
So after a lengthy chat with Apple Support, the issue still remains. I have literally tried everything.

Is anyone else having issues?
 

Just sayin...

macrumors regular
Jan 8, 2008
139
51
I’ve seen similar messages when trying to connect to the App Store - but it eventually connects. Other apps (Chrome, open Table, Maps, etc) are behaving similarly for me. It’s almost like Apple has modified network stack in iOS 13, and many bugs remain.
 

yanki01

macrumors 68040
Feb 28, 2009
3,505
1,499
Texas
this started today with my iPx. it works sometimes but always has to show the loading screen. many times having to hit retry.
 
  • Like
Reactions: Helmsley

Helmsley

macrumors 6502
Original poster
Sep 4, 2017
260
72
United Kingdom
So after updating to iOS 13.1, App Store now works perfectly on WiFi.

Annoyingly, it will not connect on cellular (4G). I was hoping 13.1 would have fixed this bug.
 

Oktober

macrumors regular
Dec 16, 2008
168
1
United Kingdom of Great Britain
I am having the same issue since updating to to 13.1.2. The iTunes Store and App Store don't work with cellular (4G) but do work with WiFi. I have restored my phone, signed in and out of invites and app stores all to no avail. Anyone have a working around solution?
 

Helmsley

macrumors 6502
Original poster
Sep 4, 2017
260
72
United Kingdom
I am having the same issue since updating to to 13.1.2. The iTunes Store and App Store don't work with cellular (4G) but do work with WiFi. I have restored my phone, signed in and out of invites and app stores all to no avail. Anyone have a working around solution?
Well, it started working for me and is now not working again.

The only workaround I have found is to open App Store, then switch to 3G and it works.

I see you are in the UK. Is your network provider Three by any chance?
 

Oktober

macrumors regular
Dec 16, 2008
168
1
United Kingdom of Great Britain
Since updating to the latest update 13.1.3, which I thought would have fixed the issue, but no still not able to connect to either the app or iTunes Store on cellular (4G). A colleague at work as the new iPhone 11 and his works fine - why am I not surprised.

I am on Vodafone in the UK.

But I am due an upgrade next month so I might just upgrade?!
- - Post merged: - -

What I just said above - scratch that as I have just synced my iPhone (connected to my iMac) and turned on data (4G) and low-and-behold both the App Store and iTunes Store apps now work on 4G. There must have been a glitch or something got 'stuck'.
 
Last edited:

Stuart6

Suspended
Jan 30, 2017
81
48
I am having the same exact issue. Only on LTE, app store and itunes cannot connect. All other apps work fine on LTE. This happened after the ios 13.1 update. The last 2 updates never fixed it for me. This is frustrating as i have tried many ways to fix it including going to the apple store, and they too are not sure what is happening even after helping me to restore my phone. They basically asked me to wait for the next update and see if it resolves... I am using the iphone Xs by the way.
 

Helmsley

macrumors 6502
Original poster
Sep 4, 2017
260
72
United Kingdom
So, after much contact with my network provider, they claim the SIM card is the issue and are sending me a new one.

Apparently, some older SIM cards (mine is four years old) can have "technical issues" with iOS 13. I'll give it a go when it arrives and see what happens.
 

Ninflu

macrumors regular
May 11, 2018
119
82
Cologne & Chicago
So, after much contact with my network provider, they claim the SIM card is the issue and are sending me a new one.

Apparently, some older SIM cards (mine is four years old) can have "technical issues" with iOS 13. I'll give it a go when it arrives and see what happens.
I'm using a Vodafone Sim (Plastic) and an eSim and it doesn't work at all. I've swapped sins with another carrier and can't get it to work.
Did your carrier mention something more what's the issue is?
 

Helmsley

macrumors 6502
Original poster
Sep 4, 2017
260
72
United Kingdom
Did your carrier mention something more what's the issue is?
No, they just said the SIM is old and has technical restrictions...whatever that means.

However, two days after speaking to them, everything is now working perfectly so I haven't bothered putting the new SIM card in.

I suspect there was a network issue that they didn't tell me about and finally it has been resolved (on Three, at least).