iOS 8.1: 'Text Message Forwarding' Activation Requires iMessage Email Address

Discussion in 'iOS Blog Discussion' started by MacRumors, Oct 20, 2014.

  1. MacRumors macrumors bot

    MacRumors

    Joined:
    Apr 12, 2001
    #1
    [​IMG]


    Earlier today, Apple released iOS 8.1 which introduced number of new features to iOS and Yosemite. One of the anticipated features was SMS Text Message Forwarding, which allows SMS messages received by your iPhone to be mirrored on your iPad or Mac running OS X Yosemite.

    [​IMG]
    Several of our forum members had difficulty activating the feature, as the required activation code would never appear on their Macs or iPads.

    MacRumors reader Michael wrote in with this solution which requires an email address to be activated in iMessage:
    MacRumors was able to verify this scenario and found that an email address does indeed have to be active on your iPhone for the activation message to properly be sent. In our testing, SMS messages were still received after the email address was removed from iMessage. The setting to add your email address to iMessage is under Settings -> Messages -> Send & Receive. Note, you may have to wait a few moments after adding an email address before the activation code will send.

    Article Link: iOS 8.1: 'Text Message Forwarding' Activation Requires iMessage Email Address
     
  2. rdlink macrumors 68040

    rdlink

    Joined:
    Nov 10, 2007
    Location:
    Out of the Reach of the FBI
    #2
    Not sure why that would be a surprise to anyone. Your Messages account is tied to your Apple ID, which is your email address.
     
  3. gadgetguy03 macrumors regular

    Joined:
    Nov 1, 2012
    #3
    I had an issue with my iPhone 5s not recognizing my iPad 2 shortly after updating to 8.1. I turned iMessage off and on again on the iPad 2 and was able to successfully pair the two. Now I can access my SMS messages from my iPad, iPhone, or Mac Mini (Late 2009)
     
  4. arn macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #4
    it doesn't entirely make sense. You are already logged into your iMessage account either way. This is just which phone numbers / email addresses you want to receive iMessages for.

    arn
     
  5. Glassed Silver macrumors 68020

    Glassed Silver

    Joined:
    Mar 10, 2007
    Location:
    Kassel, Germany
    #5
    I have a bunch of email addresses active in iMessages on iPhone, yet, no code.

    *sigh*

    (iPhone 5, iMac mid-11, iPad Air)

    Glassed Silver:mac
     
  6. sepo01 macrumors newbie

    Joined:
    Mar 6, 2008
    Location:
    Anchorage, AK
  7. tennisproha macrumors 65816

    Joined:
    Jun 24, 2011
    Location:
    Texas
    #8
    Technically your apple id is not your email address actually. Its an internal account id number since that is the only way you would be able to change the email address tied to your apple id, on demand.
     
  8. anthonyzp macrumors member

    Joined:
    Oct 20, 2014
    #9
    Ok same issue seems to be under FaceTime settings too.

    I only like to tick my mobile number under FaceTime not my email address as well.

    When email address is not ticked, you cannot enable iPhone Mobile Calls. Keep getting error.

    Anyone else?
     
  9. abemonkey macrumors member

    Joined:
    Apr 4, 2009
    #10
    Yup. Same here.
     
  10. anthonyzp macrumors member

    Joined:
    Oct 20, 2014
    #11
    I found that after you set it up, you must keep the email checked. Otherwise only your messages will be forwarded. If you try to reply from your computer or iPad it will hang and not send the text reply.

    From your tests MacRumors is this the case? Saw the above comment on your FB post. Please confirm.
     
  11. rdlink macrumors 68040

    rdlink

    Joined:
    Nov 10, 2007
    Location:
    Out of the Reach of the FBI
    #12
    Well, actually I suppose my Apple ID is technically just a few bits laid out on some silicon in Maiden, NC.... :rolleyes:
     
  12. abemonkey macrumors member

    Joined:
    Apr 4, 2009
    #13
    Same here on this as well.
     
  13. anthonyzp macrumors member

    Joined:
    Oct 20, 2014
    #14
    ok looks like i'll be keeping my email address ticked then for the time being... hopefully Apple release a fix where we can send texts from our other devices without having to have our email address ticked
     
  14. PlutoPrime macrumors regular

    Joined:
    Oct 15, 2009
    #15
    I think this article is inaccurate and it simply states a workaround that happens to work...

    I had the same problem described in the article, and all I had to do was sign out of iMessages app on my iPhone and sign back in. After signing in, I still had a checkbox next to my phone number and I was able to receive the verification number on my Mac.
     
  15. tennisproha macrumors 65816

    Joined:
    Jun 24, 2011
    Location:
    Texas
    #16
    touché lol.
     
  16. Jimmyjamh macrumors member

    Joined:
    Aug 4, 2013
    #17
    Worked first time for me. Great feature and very welcomed!
     
  17. HangmanSwingset macrumors 6502

    HangmanSwingset

    Joined:
    Feb 28, 2011
    Location:
    Everett, WA
    #18
    I fixed mine by adding my email address. The girlfriend's just worked.

    Really frustrated me because I wanted it and had to struggle to get it set up. She didn't and it worked. :/
     
  18. bollyboy macrumors regular

    Joined:
    Apr 21, 2010
    Location:
    Manchester - UK
    #19
    I have the same problem, messages just hang on the iMac when sending.
     
  19. jroadley macrumors regular

    Joined:
    Oct 5, 2009
    Location:
    Norwich, UK
  20. tillsbury macrumors 65816

    Joined:
    Dec 24, 2007
    #21
    Annoying. Works perfectly iphone to mac, but no message pop-up on the ipad at all. Exactly the same configuration iphone to ipad.
     
  21. borneo76 macrumors member

    Joined:
    Sep 19, 2012
    Location:
    Indonesia
    #22
    i have no problem....i receive the code on my mac and it's just work.
     
  22. Westside guy, Oct 21, 2014
    Last edited: Oct 21, 2014

    Westside guy macrumors 603

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #23
    Same experience here. Three different target devices for SMS forwarding, three times toggling iMessage on my iPhone.

    On a side note, thanks to 8.x Safari being so bloody unstable, this is my third attempt to reply here. Safari seems to have trouble with form input now.
     
  23. mrmini78 macrumors newbie

    Joined:
    May 21, 2009
    Location:
    Sydney, Australia
    #24
    All I did was re add my email address on my Mac and then switched "Text Message Forwarding" "ON" on my iPhone and the code came straight through
     
  24. 827538 macrumors 65816

    Joined:
    Jul 3, 2013
    #25
    Safari has been solid for me. What device are you on?

    The code wasn't showing up on my Mac, even although I've always had my emailed activated. I'll try turning iMessages off then on again later to see if that's works, calling via my Mac works fine though.
     

Share This Page