iPhone/iPad WiFi Woes [long]

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Buadhai, Feb 17, 2018.

  1. Buadhai macrumors member

    Buadhai

    Joined:
    Jan 15, 2018
    Location:
    Korat, Thailand
    #1
    I have an iPhone 6s and an iPad mini 4. Both are running 11.2.5.

    I also have a TP-Link N600 Dual Band Gigabit ADSL2+ Modem Router (Model No. TD-W8980). The 2.4 and 5 GHz bands have different SSIDs.

    Issue #1: On both the iPhone and the iPad throughput on the 2.4 GHz network is generally somewhere around 350 Kbps. However, on both devices, throughput on the 5 GHz network is more like what I expect and pay for: from 15 to 20 Mbps. We have multiple devices in the house including two MBAs, two Apple TVs, an iPhone X & 5s, an older iPad mini, a 2017 iMac, a Raspberry PI, etc. No other device is affected by this horrible throughput on the 2.4 GHz band; only my 6s and iPad mini.

    I have attached photos showing Speedtest results with the X and 6s sitting right next to each other. Once with both on the 2.4GHZ network and once with both on the 5GHz network.

    Both devices perform as expected on other 2.4GHz networks. To put it simply, I only have throughput problem with these two devices and only when they are on my home 2.4 GHz network.

    Issue #2: Same two devices. (iPhone 6s & iPad mini 4). Both of these devices frequently have a self-assigned IP address when using public WiFi access points. For example, on Friday I was in a coffee shop that I have visited weekly for several years. On this visit I had to re-enter the WiFi password because I reset the network attempting to solve Issue #1. No matter what I tried I couldn't get a DHCP assigned IP address for either device. I tried forgetting the network, turning WiFi on and off, force restarting both devices, turning WiFi assist OFF on the iPhone. Nothing worked.

    I had a wander around the restaurant eavesdropping on other people's devices. I observed many different phones, tablets and laptops all successfully connected to the shop's WiFi network. Based solely on that surreptitious survey, me and my devices were the only ones having a problem.

    I have previously solved this problem at this and other public WiFi APs by manually assigning an IP address based on IP addresses I see or ask about on other devices. (I was too frustrated to bother with this on Friday.)

    ==========

    I have sort of solved Issue #1 by turning OFF Auto-Join for the 2.4GHz band on my home LAN.

    I can sort of solve Issue #2 by entering manual IP addresses for networks where the iPhone and/or iPad refuse to use DHCP.

    These seem like kludges. Any better suggestions?

    [​IMG]
    iPhone 6s and X on home 2.4GHz network.


    [​IMG]
    iPhone 6s and X on home 5GHz network.



     
  2. flaubert macrumors regular

    flaubert

    Joined:
    Jun 16, 2015
    Location:
    Portland, Oregon
    #2
    So many possibilities, none of them high probability... just about any reasonable scenario I can come up with has a counterargument:

    Bad hardware? Happens on two devices.
    Interference on 2.4 GHz band? Other devices work fine.
    Vestige of VPN turned on? Doesn't happen on 5 GHz.
    and so on.

    I've got to wonder, though, if there isn't something wonky about the state of your iOS firmware, since that is kind of a common element in both devices. It's possible to get to latest firmware through different paths (clean install versus accumulated updates), and perhaps Apple's update process was less than perfect (I saw your rant over on Macintouch, spot on). So, my suggestion would be probably the same as what Apple would tell you: back up (at least one of) your devices, then perform a firmware wipe and re-install (confusingly referred to as a firmware restore to latest version). Then, don't restore the backup data immediately; instead, run your speed test on the device again, with nothing but Apple-supplied applications in play. If the problem has gone away, try restoring data. If the problem comes back then you can reasonably conclude that one of your apps is somehow involved; you'll probably have to wipe and restore firmware a second time, and add in only safe apps, or use a utility like iMazing to add in app data one at a time to determine who is misbehaving. I know, it is ridiculous that one has to play detective on devices that should Just Work, but that is where we are.

    While writing this up another thought occurred to me: Apple has been in the press lately for deliberate slow-downs of performance based on battery health... I wonder if the 2.4 GHz scenario is somehow related to this. Perhaps 5 GHz communication is more hardware-based, while the 2.4 GHz stream is processor-intensive? Worth checking your battery health, anyway; download Coconut Battery (free) from Mac App Store, and connect your device to your computer to read out battery capacity.

    Good luck, let us know what you find.
     
  3. Buadhai thread starter macrumors member

    Buadhai

    Joined:
    Jan 15, 2018
    Location:
    Korat, Thailand
    #3
    Thanks for your detailed and well considered reply. Let me cover a few points:
    • Battery: According to Coconut Battery the iPad is at 97% of design capacity. When I first discovered the problem, the iPhone was at about 82% (just above the throttling threshold?). I have since had that battery replaced under Apple's battery replacement program. The new battery did not affect throughput.
    • Firmware: I think the if it were a firmware problem it would affect all 2.4GHz networks. But, it doesn't. I'm a retired guy with lots of time on his hands. I got out for coffee every day at a variety of places that have Wifi. Some of them have 2.4 only networks and some are dual band, but have different SSIDs for each. I've never experienced any throughput trouble at any of these places. It's only at home….
    • VPN: I do have NetShade installed on both devices. I rarely use it (only for news sites blocked by the Thai government). When I get some more time I will try removing the VPN configurations from the iPhone to see if that makes a difference. (I agree that it should not affect only the 2.4 band.)
    In the meantime I have "solved" the problem by telling both devices to forget the 2.4 band. So, they both always connect to the 5GHz band. Of course, this works fine.

    But, I still have this nagging desire to figure out exactly what's going on….

    What follows is the WiFi status grabbed from Apple's Wireless Diagnostics test. Looks pretty normal to me. (This is from an iMac that sits a meter away from the router, so the RSSI looks rather big.)

    # --- Wi-Fi Status

    MAC Address : 98:9e:63:39:8b:ec
    Interface Name : en1
    Power : On [On,On,On]
    Op Mode : STA
    SSID : mgn
    BSSID : e8:94:f6:5c:87:94
    RSSI : -33 dBm
    Noise : -80 dBm
    Tx Rate : 145.0 Mbps
    Security : WPA2 Personal
    PHY Mode : 11n
    MCS Index : 15
    Guard Interval : 800
    NSS : 2
    Channel : 6 (20 MHz, Active)
    Country Code : TH
    NetworkServiceID : 381023BF-19AC-491F-B8ED-B2BE78FA611F
    IPv4 Config Method : DHCP
    IPv4 Address : 192.168.0.76
    IPv4 Router : 192.168.0.1
    IPv6 Config Method : Automatic
    IPv6 Address : None
    IPv6 Router : None
     
  4. flaubert macrumors regular

    flaubert

    Joined:
    Jun 16, 2015
    Location:
    Portland, Oregon
    #4
    That's very interesting about the NetShade VPN. Some VPN's can now turn on automatically when it thinks you're not on the home network, so perhaps there is something there. Will look into it later this weekend.
     
  5. Buadhai thread starter macrumors member

    Buadhai

    Joined:
    Jan 15, 2018
    Location:
    Korat, Thailand
    #5
    I've never seen NetShade turn itself on. At least I've never seen the VPN symbol unless I explicitly turned it on. Removing Netshade and uninstalling the configuration didn't help with the 2.4GHz problem.
     

Share This Page

4 February 17, 2018