iPhone X Iphone X 11.2 messed up haptic engine

Discussion in 'iPhone' started by Zigourney, Dec 2, 2017.

  1. Zigourney macrumors regular

    Joined:
    Sep 27, 2017
    Location:
    United Kingdom
    #1
    I have noticed now that I have updated to 11.2 that the haptic engine makes a weird buzzing sound when I flick up on the notification centre only. Everything else seems to haptic feedback correctly and normally.

    Anyone else notice the pronounced buzzing sound only when flicking the notification centre up to make it disappear?

    Its definitely a software issue caused by 11.2, it was all fine before the update.
     
  2. SeanLe macrumors member

    SeanLe

    Joined:
    Dec 2, 2017
    Location:
    Australia
    #3
    Yep can confirm after updating I have the same problem! It happens when you use reachability too! Weird bug!
     
  3. TheRealAlex macrumors 68000

    Joined:
    Sep 2, 2015
  4. area52 macrumors member

    Joined:
    Nov 4, 2014
    #5
    Hmm weird I have no haptics with that action. Do I have to turn that on somewhere? I have system haptics turned on. [​IMG]
     
  5. M33-1 macrumors regular

    M33-1

    Joined:
    Jun 15, 2010
    #6
    I have no haptics when flicking away Notification Center, but a haptic click when flicking up reach ability.
     
  6. Dee2001 macrumors member

    Joined:
    Nov 12, 2009
    #7
    Do you have phone on silent? I always have mine on silent and didn’t have bug but found it when I switched ringer back on.
     
  7. mcdj macrumors G3

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #8
    No haptics for me on swiping in or out of reachability, Control Center it notifications, ringer on or off.

    I got reachability to make a clacking sound this morning right after updating, but it hasn’t done it since a reboot.
     
  8. bevsb2 macrumors 68000

    Joined:
    Nov 23, 2012
    #9
    When I swipe up from the bottom of the screen to close the Control Center I hear a haptic click. If I swipe up from the middle of the screen it is silent. I have a significant vibration when I swipe up to use passcode, but that was there before the 11.2 update.
     
  9. pinskerj macrumors newbie

    Joined:
    Jun 23, 2003
    #10
    --- Post Merged, Dec 2, 2017 ---
    Same has happened to me. Very annoying , I can’t turn it off.
     
  10. Smokie88 macrumors newbie

    Joined:
    Oct 27, 2017
    #11
    Confirmed having the same issue when swiping up from control center and reach ability.

    If the phones on silent it doesn’t happen.
     
  11. kirk.vino macrumors member

    Joined:
    Oct 27, 2017
    #12
    Confirming this as well! It only happens if the phone is not on silent. It doesn’t happen every time but pretty often.
     
  12. area52 macrumors member

    Joined:
    Nov 4, 2014
    #13
    No, the ringer is on and all sounds and vibrations coming through. Tried replicating but not happening for me.... Guess that's a good thing
     
  13. Zigourney, Dec 2, 2017
    Last edited: Dec 3, 2017

    Zigourney thread starter macrumors regular

    Joined:
    Sep 27, 2017
    Location:
    United Kingdom
    #14
  14. Smokie88 macrumors newbie

    Joined:
    Oct 27, 2017
    #15
    You have to make sure the ringer isn’t silent and then when swiping up make sure you swipe “under” the bar and up.

    You should definitely hear it. It’s definately a bug with 11.2
     
  15. JtheLemur macrumors 6502

    Joined:
    May 13, 2002
    #16
    I can easily reproduce by just tapping through vibration patterns. For a real weird time, I can tap the SOS pattern and while it’s vibrating, open then dismiss Control Center. Cacophony of weird clicking coming from the Taptic Engine. -___-
     
  16. WilliamG macrumors G3

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #17
    Yep confirmed here on my X. Only does it with silent mode off.

    For the record - even before 11.2 there are sporadic occasions where the haptic feedback makes a one-off “broken” vibration. Could never repeat it, though - on demand.
     
  17. Zigourney thread starter macrumors regular

    Joined:
    Sep 27, 2017
    Location:
    United Kingdom
    #18
    I think I'll wait for apple to resolve this, rather than trying to make a genius bar appointment. It is obviously a software issue rather than a hardware issue.
     
  18. area52 macrumors member

    Joined:
    Nov 4, 2014
    #19
    Ah swiping up under the line that appears got a haptic tap. That's what your calling "loud"? It's just a tap
     
  19. Smokie88 macrumors newbie

    Joined:
    Oct 27, 2017
    #20
    That shouldn’t be there. And it’s not a tap. It sounds like something is broken. Or rather a broken “tap”
     
  20. Zigourney thread starter macrumors regular

    Joined:
    Sep 27, 2017
    Location:
    United Kingdom
    #21
  21. bevsb2 macrumors 68000

    Joined:
    Nov 23, 2012
    #22
    I just submitted a bug report also. The more people that address this the better.
     
  22. virginblue4 macrumors 68000

    virginblue4

    Joined:
    Apr 15, 2012
    Location:
    United Kingdom
    #23
    I can confirm it’s also there on my X running 11.2.
     
  23. itsmemuffins macrumors 68040

    itsmemuffins

    Joined:
    Jun 23, 2010
    #24
    Can confirm ‘tis was introduced with 11.2.

    I get it most with reachability. With notification centre. Sometimes I get the loud haptic. Sometimes the regular one, and at times none.
     
  24. iapplelove macrumors 601

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #25
    This is exactly my case as well.
     

Share This Page

61 December 2, 2017