Is MacRumors slow to load on Safari for anyone else?

Discussion in 'Site and Forum Feedback' started by s2mike, Nov 7, 2017.

  1. I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #26
    I am having the same issue on ios 11b4. Load times are very random, not as consistent as in the past. I'm guessing at some point in time this will be figured out.
     
  2. tromboneaholic Suspended

    tromboneaholic

    Joined:
    Jun 9, 2004
    Location:
    Clearwater, FL
  3. splifingate macrumors 6502

    splifingate

    Joined:
    Nov 27, 2013
    Location:
    ATL
    #28
    No slowness, here, but Safari in iOS 11.x and HS will jump to a different place on the page than expected after the assets are loaded.

    Inexplicable.

    Regards, splifingate
     
  4. Good User Name macrumors regular

    Joined:
    Jul 7, 2011
    #29
    The front-page of the site has become damn near unusable for me. Initial loading is slow and even when it says it's done it's incomplete. Scrolling is impossible at times. All of Safari becomes unresponsive.

    I'm on my iPhone 6 Plus with whatever the last iOS 10 release was.

    I'm just going to stop coming to this site.
     
  5. MadeTheSwitch macrumors 6502a

    MadeTheSwitch

    Joined:
    Apr 20, 2009
    #30
    Safari on my ipad is now giving me webpage errors and reloading the front page whenever I scroll down a bit which is SUPER annoying. This is the only site I am having trouble with and also the only part of MR I am having trouble with, so something funky with that front page. Been that way for several days now.
     
  6. swanseaboy macrumors member

    Joined:
    Oct 15, 2012
    Location:
    Swansea, Wales
  7. Good User Name macrumors regular

    Joined:
    Jul 7, 2011
    #32
    There's been some improvement since I last posted. Still not as good as it used to be but hopefully it gets better.
     
  8. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #33
    Very slow today, with lagging, hanging and one or two duplicate posts as I thought the thing had stalled completely.
     
  9. sman789 Customer Support

    sman789

    Joined:
    Dec 25, 2007
    Location:
    Richmond, VA
    #34
    I just installed 11.2.5 (iPad Pro 9.7) and it’s loading well. Tried it on Firefox as well, no speed difference.
     
  10. Raid macrumors 68020

    Raid

    Joined:
    Feb 18, 2003
    Location:
    Toronto
    #35
    Just wait for the full release of iOS 11.3 to come out. It will make all programs teh snappier! :D
     
  11. Plutonius macrumors 604

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire, USA
    #36
    Or stay on OS 10 if you haven't updated yet.
     
  12. Sedulous macrumors 68020

    Sedulous

    Joined:
    Dec 10, 2002
    #37
    Advertisement loading slows page. I allow it to support site but sometimes it gets annoying.
     
  13. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #38
    I am finding that the forums are slow to load today; they are also hanging and stalling, and I've noticed that double posting - because it seemed the post hadn't loaded, or been posted - has also been a bit of an issue this morning.
     
  14. sman789 Customer Support

    sman789

    Joined:
    Dec 25, 2007
    Location:
    Richmond, VA
    #39
    Everything is copasetic over here. You try using a different internet connection?
     
  15. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #40
    Forums very slow tonight for some reason, laggy and hanging; worse, have also had a few cases of the dreaded 'double post' syndrome.
     
  16. oldhifi macrumors 65816

    oldhifi

    Joined:
    Jan 12, 2013
    Location:
    USA
  17. lobo1978 macrumors 6502

    lobo1978

    Joined:
    Sep 22, 2011
    #42
    Macrumors.com is super slow and buggy on Safari (Version 11.1 (13605.1.33.1.4) and the latest version of High Sierra (10.13.4 (17E202)). It has severe issues with memory leak too - Activity monitor reports +1.8 GB of RAM (safari is constantly prompting me to close it down) used and +20% of CPU utilisation (notice the total time used by CPU!!). Slow down with aggressive/non-optimised/buggy ads maybe?

    I stay away from having this website open.

    A1160A79-9F7B-4833-86AF-2E7033426C74.jpg
    7DEB97F8-8C42-458A-8319-F324716A1686.jpg
     
  18. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #43
    Very slow loading yesterday and this morning; moreover, I experienced the dreaded double posting syndrome - the thing hangs, stalls, which means that (impatient) you press 'post reply' again, which leads to a duplicated post (which you then delete), but it is slightly irksome.
     
  19. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #44
    I've been finding it very slow to load these past two days, with pages hanging, freezing, or the dreaded double-posting making an appearance because you think that the post hadn't been sent the first time and you click on "post reply" a second time.
     
  20. Ulenspiegel macrumors 68030

    Ulenspiegel

    Joined:
    Nov 8, 2014
    Location:
    Land of Flanders and Elsewhere
    #45
    Yes it is slow on Safari, but on Windows it is superslow for me.
     
  21. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #46
    Well, it has been slow for a few days - even this morning, a post seemed to be hanging for what seemed ages (in reality a few seconds) before it was successfully sent (or posted).
     
  22. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #47
    Freezing and hanging pages and - thus - double posting (as a result) seem to be features of the system and forum this morning.
     
  23. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #48
    Forum very slow to load today, as are the individual pages within it.

    I have also noticed that incoming "Notifications" seem to cause stalling or freezing or hanging of pages.
     
  24. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #49
    This morning the site is hanging, freezing, stalling and double posting; and taking ages to load.
     
  25. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #50
    Actually, the forums are unusually slow this evening - I had difficulty accessing the actual forums earlier tonight - and they are still slow.
     

Share This Page