Is the sync button for iCloud Messages doing anything?

Discussion in 'macOS High Sierra (10.13)' started by oMc, Jun 12, 2018.

  1. oMc macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #1
    Hi,

    I have 3 devices (iPhone, iPad and a 2017 MacBook) where iMessages in iCloud is working perfectly (sync/delete across all devices). I recently started to use my old MacBook Pro as a media center / NAS / spare machine. I decided to log in into iCloud with that old machine because well, it's convenient to have everything synced with your other devices.

    Every iCloud service (Safari, Calendar, Contacts, Photo library, etc) seems to work fine on that old MacBook Pro except Messages in iCloud. At first, the messages were downloaded but I've noticed that some were missing compared to the other devices, so I've decided to deactivate Messages in iCloud for that MBP, erase everything and reactivate again to try to do a proper sync. The thing is that, since then, I can activate the service but even if I press the "synchronize" button (see the screenshot), nothing happens. The button is greyed out for a few seconds and then become clickable again. So on that 4th device, I am stuck with an empty Messages app which does not seem to want to download any message from iCloud. Everything is still fine on the other devices.

    Capture d'écran 2018-06-12 15.10.52.png
    (the service is not activated in the screenshot but I am just using it to illustrate the button I am speaking about)

    I have tried to log out / log in from iMessage, as well as from iCloud, but it does not change anything. It's like the app can do a sync the very first time you activate the service, but then, never again...

    Thanks for any help or advices,
    oMc
    --- Post Merged, Jun 12, 2018 ---
    I just want to add that any new message will sync perfectly to the old device and will be deleted too if I delete it from any other device. It's only the message history that doesn't want to be downloaded to this old device.
     
  2. oMc thread starter macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #2
    Bump.

    Alright, I found a solution, so I am sharing it in case it can help someone someday.

    To force Messages to re-download the messages from iCloud, it's actually pretty simple. Just make sure that Messages in iCloud is activated in the app, close the app, go to ~/Library/Messages, delete everything in the folder (do a backup first, just in case) and restart macOS.

    After the restart, you should see that Messages is downloading everything again from iCloud in that same folder. Wait a little bit until it's done and then re-open the app, the messages should be back. I still have a few missing messages here and there (the mysteries of iCloud), but I'm not going to waste my time anymore with that. It's just a spare machine after all, anyway.
     
  3. Mr_Brightside_@ macrumors 68030

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    The 6ix
    #3
    Neat, thanks!
     
  4. CDutch macrumors regular

    Joined:
    Jul 6, 2009
    #4
    Out of curiosity, how long did it take for your messages to download from iCloud? I followed the instructions, restarted my Mac, opened my messages app and hit the "Sync Now" button. It went gray but nothing has downloaded yet.
     
  5. oMc thread starter macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #5
    Not very long. The chat.db file in the folder is not very huge in my case (17.5 Mo), and the attachment folder as well (8 Mo), mostly because it was like a setup as a new machine and you can always re-download the attachements (pictures, videos, etc) in the app if you need too.

    But you should not open Messages right away. I did not even use the sync button. Here is the procedure:

    - make sure Messages in iCloud is activated in the app.
    - close the app.
    - delete everything in ~/Library/Messages, backup first just in case. You should find in that folder three "chat" files as well as a few folders.
    - restart macOS.
    - don't open Messages right away. Go to ~/Library/Messages and you should see new files, the chat.db files should growth in size as the messages are downloaded from iCloud. You should also see an "attachement" folder appear at some point. Wait until the files and the folders are not gaining size anymore, it will mean that the sync should be done.
    - open Messages and it should be ok. You can try to send/delete a few messages to yourself to see if everything is syncing properly.

    I've also read in a few forums, including here, that keychain should be activated in iCloud in order for Messages in the cloud to work properly. At least for me it solved a earlier problem where the option for iCloud was not appearing in Messages.
     

Share This Page